wp-admin - This feature is disabled

Hi,
Bit of an odd one...
Whenever I am on the home page of my website and click on 'Dashboard' it comes up with a white screen and an error message of 'This feature is disabled'.
However, at this point the url is http://www.rocketbuilder.io. If I add 'https://' in front of that url it loads the dashboard fine.
Odd one, I can work around it, but not ideal for a multisite I want to role out to the public soon.
Thanks.
Alex

  • Ash

    Hello Alex Morgan

    Well, this is kinda right. When you use masking admin url for visitors, and if the wp-admin can't be redirected to the masked url, then that message is shown.

    When you checked, you logged in using https in the url, so you were logged in for https. But when you visited the admin using http, and for some reason it could not redirect, so it shows you that message.

    As you are using SSL on your site, I think you should force https for admin urls. Would you please try adding this line in wp-config.php?

    define('FORCE_SSL_ADMIN', true);

    Please make sure you put the line before /* That's all. Stop editing */ message.

    Also, please go to Dashboard > Settings > General and set site url and home url to https version of the URL.

    Let us know if that works for you. Have a nice day!

    Cheers,
    Ash

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.