WP Defender File Scanning Hung

Thank you for stopping in.

I was just updating all of my configuration on WP Defender and I keep getting an error message and the file scanning won't begin.

P.S. I tried to set the topic of this post to the WP Defender plugin but, it wasn't available. I don't think my HUB has realised that I have WP Defender installed.

  • Katya Tsihotska

    Hello SixTsevN

    Hope you are doing fine today.

    Could you tell us what exact configurations did you update?

    To make sure that it doesn't relate to any plugin/theme conflict, could you, perform plugin/theme conflict test? Please, disable all plugins except WPMU DEV plugins, switch to default WordPress theme (e.g TwentySixtee) and try again. If it works this time then activate each plugin and theme one by one and keep checking to find out what plugin/theme is causing this conflict.

    If this has no result you can send us your details through our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question using this template:

    Subject: "Attn: Katya Tsihotska"
    -WordPress admin username
    -WordPress admin password
    -login URL
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant URLs

    Please use this subject line to ensure that it gets assigned to me.

    Best regards,

  • SixTsevN

    Hi Katya,

    Thank you for your assistance.

    I performed the conflict test and nothing appears to have worked. In fact WP Defender is more buggy than ever. It keeps saying I have to re-salt my security keys and I perform the change, login and it still says I have to perform the fix.
    Interestingly enough, WP Defender says that it is approximately ~50% complete in it's file scan (which previously never got past 5%) but, as I'm watching it hasn't updated in over 30 minutes.

    I have sent a message from "I have a different question" with all the relevant details. If you could take a look for me, that would be greatly appreciated.

    Thank you for your time.
    Yours sincerely,

    James Kimberley

  • Katya Tsihotska

    Hi SixTsevN

    Hope you had a wonderful day!

    Thank you for sending your credentials!
    My colleague Hoang Ngo has investigated trough your site and fix your issue. Causing was in the memory limit, it was set 256MB, he increased it to 312MB and this has solved the problem. Now it's working fine.

    Also, Hoang has pasted the patch in your plugin to solved the security key issue.

    Please, let me know if you have any additional questions, I'll be happy to help.

    Best regards,

  • SixTsevN

    Dear Katya,

    Thank you very much for your excellent support and please give my thanks to Hoang .

    Is it possible you could instruct me on how to fix this problem, in case I encounter it once more, on one of my other installations? "Teach a man to fish". haha.
    If I can fix this issue in the future, it will free you and the other support agents from having to assist me again.

    Thank you for your support.
    Yours sincerely,

    James Kimberley

  • Hoang Ngo

    Hi James,

    I hope you are well today.

    For the patch, please use the attached beta version, extract it, and copy the file /wp-defender/app/module/hardener/component/security-key-service.php, use it to replace the same file on your server.

    For increasing memory, please add this to your wp-config.php
    define( 'WP_MEMORY_LIMIT', '312M' );

    If you have any additional issues, please let us know and we'll be happy to help.

    Best regards,