WP Engine Caching Issue (saving doesn't work), question from their support

A few other folks have asked about this, and I've been in touch with WP Engine.

Basic idea: pressing save "works" in that it says it's saving, but when the page refreshes, all settings and content is blank.

The popup is created, but nothing I add to it works.

Testing on WP Engine's Staging site works perfectly. That site has no caching.


They ask: "which results and paths are being cached on the frontend?"

I can't find the answer in the plugin files because I'm PHP illiterate.

Any help?


  • Exponential Admin

    Follow-up question from them:

    just a note, triggering admin-ajax.php bypasses the cache, so every time a call is made to it, the server gets hit directly instead of the cache being able to offset the majority of the load.

    in this case, there may be something else to it, so we can verify that admin-ajax.php is not cached but are there any other elements playing a part when saving settings for the plugin?

  • Michelle Shull

    Hi, Exponential!

    I'm going to flag the developer, Philipp, as he's going to be able to give you a much clearer and more concise description of how the plugin behaves, and because I know some other WP Engine customers are having similar issues. He's going to have the best answer for this.

    Sometimes it can take a little longer to hear back from our devs, they're so, so busy, but I'll make sure to follow up and keep you posted.

    Thanks for your patience, and for showing such great initiative in getting this sorted with us and with your host. We love members like you. : )

  • Michelle Shull

    Hi Sean! (Nice to have a name to call you!)

    Short answer: because caching is awesome and troublesome at the same time. Caching can do so much for your site, in terms of how fast it loads and how well it performs, but because caching involves storing static files, anything we users add that's dynamic is going to make issues for the caching. AJAX, by it's very nature, is all dynamic, all the time, so it's particularly tricky to make it work with caching.

    I'm glad you found a temp solution! I'll keep you posted if I hear anything.
    : )

  • Philipp Stracker

    Hi @Sean!

    Thanks for all the helpful information, saves us a ton of time since you already found the actual issue and a working way to bypass it :slight_smile:

    As mentioned, we have contacted WPEngine and try to find a solution for this. Currently I only need to know the exact scope of the problem.

    Can you take the following steps and confirm my suspicion:

    1. Disable Caching as you mentioned above, then create a new demo PopUp with some condition.
    Set the Loading-Method to "WordPress Ajax"!
    (If possible create a PopUp with condition "Visitor Is Logged In")

    2. After you edit a PopUp you can enable Caching again and the PopUps will work on the Front-End of your site.
    (With caching enabled test the PopUp as a guest [should not display] nand as logged-in user [should display])

    --> This confirms that caching only affects the ADMIN area, but not the Front-End.

    Thanks, Philipp

  • Philipp Stracker


    When debugging issues of another user we found a problem with our usage of WordPress Cache. This might very likely be the cause of your issues here... (Details here)

    I attach a beta version of the next plugin release. It also includes some other bugfixes/small changes and will install as a separate plugin: You can deactivate the current PopUp Pro plugin and then activate the Beta version or vice versa.
    (you should not activate both at the same time!)

    Please let us know if the new beta version solves your issues!
    Thanks, Philipp

    p.s. Once the new version is tested and released you can delete the beta plugin (this will NOT delete any of your PopUps, only the files) and then update the plugin via the WPMU Dev Dashboard.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.