WP Engine & Caching – Pop-over Plugin


This is a sort-of continuation of the above linked discussion, so I am tagging @Elliott Bristow, because he is familiar with my issue from the last discussion.

@Elliot Birstow,

After WP Engine sped up my website a bit, I let go the support representative that I was working with.

But today, I was curious if the issue was actually resolved (since checking the HTTP headers of my website) still showed the caching as a “MISS” (instead of a “HIT”:wink:.

Well, I started another support ticket with WP Engine through their Zendesk powered system and asked if my caching was working fine and nothing was invalidating it (without reference to the last ticket about the cache). I was assigned to a different support representative (thankfully) and got a more specific answer:

Hey [insert my full name here],

Thanks for contacting WP Engine. It appears that your site is utilizing caching in every regard except for one. This, Popover plugin, is sending a request to apache every time you have a visitor. Essentially, this plugin is not going to scale well the more visitors you get. [insert some more information about WP Engine’s CDN, because I had asked a question about it, which was completely unrelated]


[insert support representative’s full name here]

WP – Engine – Finely Tuned WordPress

Since this is a WPMU Dev plugin that was referred to, I have come here to ask if there are any solutions to this? A WPMU Dev staff member might need to tag/flag the Lead Developer of this plugin on this issue.

Please respond ASAP. Thanks in advance. It’s really appreciated.