WP for android, web page not available error after launching app.

Hi,
I have followed all the instructions in the manual successfully. I made the app and uploaded it on google play already.
Search google play for "24x7 online city network" and you will be able to install the app and try it out to check the error which i am facing right now.
When i am opening the app after installing, and trying to register and account, its giving error:

Web page not available.
The web page at: https://MYSITENAMEHERE.com/signup/?ref=wp-android might be temporarily down or it may have moved permanently to a new web address.

I have read similar thread here: https://premium.wpmudev.org/forums/topic/wp-android-app-could-not-connect-to-the-website-error
I am sending the exported zip version of my app to Jack Kitterhing as well.

Kindly have a look and help me out with solving the issue.
Kindly treat this as urgent and stay with me to resolve it as soon as possible, as i wont be able to wait 3 days to get response.

Thanks in anticipation.

  • Michael Bissett

    Hey @Shoeb Ansari, hope you're doing well today!

    I've informed my colleague @Jack Kitterhing of your request here, but just to be sure (as the site name wasn't mentioned), you're running the latest version of WordPress on your site, correct?

    And just in case Jack needs these details, could you also please send in the following:

    - Mark to my attention, the subject line should contain only: ATTN: Michael Bissett
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - Include WordPress admin access details
    - Include FTP log-in details
    - Include any relevant URLs for your site

    On the contact form, select "I have a different question", this ensures it comes through and gets assigned to me.

    https://premium.wpmudev.org/contact/

    Thanks!

    Kind Regards,
    Michael

  • Shoeb Ansari

    Hi @Michael Bissett,
    Thanks a lot for prompt response.
    I am using WP version 4.1. (recent)
    Link to My App on google play: https://play.google.com/store/apps/details?id=org.onlinecity.android&hl=en
    My site is 24x7city.com

    I am having issue with registering a new site from APP, the site is working perfectly, as i have tested it already. It is a multisite installation and i can register new blogs from the site easily.

    Kindly test the app and advice, i have forwarded the exported zip format of the app to @Jack Kitterhing, with link back to this thread.

    I am not sure if i need to send wp admin details and ftp details right now, because the site is working perfectly.

    If you can require, i can forward the APP code to your inbox as well.

    Regards.
    Shoeb Ansari

  • Jack Kitterhing

    Hi there @Shoeb Ansari,

    Hope you're well today and thanks for sending your app through, I've been debugging this issue further this afternoon and found the issue.

    In wp-android/res/values/strings.xml, you'll see.

    <!-- WORDPRESS CONFIGURATION -->
      <string name="readerURL">https://en.24x7city.com/reader/mobile/v2</string>
      <string name="readerLoginURL">http://24x7city.com/wp-login.php</string>
      <string name="helpURL">http://help.24x7city.com/android/</string>
      <string name="wpcomXMLRPCURL">http://24x7city.com/xmlrpc-JepexZakOe.php</string>
      <string name="wpcomLoginURL">http://24x7city.com/wp-login.php</string>
      <string name="singupURL">https://yourdomain.com/singup/?ref=wp-android</string>

    Change this

    <string name="singupURL">https://yourdomain.com/singup/?ref=wp-android</string>

    To

    <string name="singupURL">http://yourdomain.com/wp-signup.php</string>

    Then go to project > clean and then restart the workspace and re-launch the Android AVD, you'll then be able to sign up.

    Thanks!

    Kind Regards
    Jack.

  • Shoeb Ansari

    Thanks a lot buddy.
    I was expecting the issue in that region, but wasnt sure what to change.
    I will do the changes and will test and will let you know.
    ---------------------------------------------------------
    Update:
    I changed the code and followed your instruction.
    After launching virtual android device, its still giving the same error.
    What should i do?

  • Shoeb Ansari

    Hi,
    i got the problem and solved it. sharing the solution with the community.

    Then go to project > clean and then restart the workspace and re-launch the Android AVD, you'll then be able to sign up.

    I was going to android virtual device manager, and was starting it to check if the thing was working properly.
    But after a bit of tweaks, i realized that I SHOULD TRY TO RUN THE PROGRAM after changing the string, as mentioned above.
    Running the program as 1 application did the work, and AVD responded with new code. Else, it wasn't showing the new code, when i was trying to start it from android virtual device manager.

    Error was due to a wrong url in the code, the link which was provided, doesnt exist. After changing the link in the code, i had to RUN the application and it solved the issue.

    Thanks @Jack Kitterhing for your valuable time. I appreciate your efforts.