[WP Jobs Manager] WP Jobs error on digitalscot.net

Hi
When a user tries to submit a job, he gets a 'this site is experiencing technical difficulties' error message. screen shot attached.
thanks, Neil.

  • Predrag Dubajic
    • Support

    Hi Neil,

    Seems like the screenshot didn't upload properly, can you please attach it again?

    The error you see usually means that there's a fatal error going on somewhere and debug log should tell us more about the cause.

    Can you enable debug log in your wp-config.php file (located in root WP folder) by replacing define('WP_DEBUG', false); with this code:

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set( 'log_errors', 1 );
    @ini_set( 'display_errors', 0 );

    Submit a job again so the error is shown this should create debug.log file in your wp-content folder that could tell us what is going on.
    Can you please save it as .txt file and attach it here so we can check it out.

    Best regards,
    Predrag

  • Neil McEvoy
    • The Incredible Code Injector

    Hi Predrag

    That's too technical for me, but I believe it is already enabled, to troubleshoot previous problems.

    Due to another bug the WPMUDev plugin doesn't synch this site, so I can send through login details to you directly?

    Kind regards, Neil.

  • Predrag Dubajic
    • Support

    Hi Neil,

    Debug log is indeed enabled already and I was able to access it from the browser directly.
    So after checking the logs I found this fatal error that is related to your Job Manager plugin:
    PHP Fatal error: Uncaught Error: Call to undefined function capstone_get_user_companies() in /var/www/html/wp-content/plugins/wp-job-manager-company-profiles/includes/class-fields.php:391

    However, I wasn't able to find any similar reports online and I'm not sure what exactly could be causing the issue.
    I see on plugin's page on wp.org that it hasn't been updated for almost a year and it's possible that the issue is with latest version of WordPress.
    Or there could a conflict somewhere so I would suggest performing a conflict test by disabling other plugins and switching to default WP theme to see if submissions work after that.

    P.S. Just for future reference, to enable debug log on your site all you need to do is access your site files via FTP or cPanel, navigate to root folder of your WP installation backup and then edit wp-config.php file.
    All that is left to do now is to add the code I mentioned above instead of this line:
    define( 'WP_DEBUG', false );

    I just wanted to add this here since debug can tell you a lot when it comes to debugging issues and it's worth knowing how to enable it :slight_smile:

    Best regards,
    Predrag

  • Neil McEvoy
    • The Incredible Code Injector

    Thanks mate. I know what this is.

    I had a previous theme installed 'Capstone' - It's a jobs specific theme and came with all the WP Job plugins. I still have their plugin active and so thought I could switch themes and they'd still work, but obviously there must be functions hard-coded into the theme as well.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.