WP keeps syncing with mailchimp

Hi there,

My website has slowed down to a crawl. After investigating I noticed that the log from the MailChimp Integration plugin and "Last Changed" column within the MailChimp list updates continuously to the current time.

It seems like the plugin keeps syncing and updating MailChimp which shouldn't happen I guess?

Can you have a look?

Thx!

Grtz,

Stephane

PS: Please note this is a live site.

  • Kasia Swiderska
    • Support nomad

    Hello Stephane,

    It seems like the plugin keeps syncing and updating MailChimp which shouldn't happen I guess?

    I'm sorry, but I'm not sure if I understand - MailChimp job is to sync users with newsletter list - why would it stop syncing? You setup webhooks in MailChimp - so it will be syncing both ways (WP user to mailchimp list and newsubscribers to WP users).
    You can remove the subscription forms from mailchimp - but you have Hustle now that handles opt-in for the list.
    So Mailchimp still will be syncing users to you WordPress if you setup the same list for both plugins.
    If you don't need syncing users between mailchimp then deactivate and remove mailchimp.

    Let me know if you have more questions.

    kind regards,
    Kasia

  • Stephane
    • Flash Drive

    Hi Kasia,

    Thank you for getting back to me.

    As I understand it:

    Hustle: Let's me grow my mailing list in MailChimp by adding new subscribers to the list.
    MailChimp sync: Makes sure my woocommerce customers and mailchimp are synced, adding new customers to the mailchimp list (which I also need).

    The fact that MailChimp and WP now sync all their e-mail accounts is good, that's the idea. But is it supposed to continuosly sync every existing e-mail/user/subscriber over and over for now end? I thought it would only sync (both ways) when something changed, not continuously which cuts in my resources.

    I deactivated the MailChimp sync plugin yesterday to stop this from happening. I reactivated it today and "for now" it seems to be ok and not syncing all the time.

    Thx!

    Grtz,

    Stephane

  • Nithin
    • Support Wizard

    Hey Stephane,

    Hope you are doing good today. :slight_smile:

    But is it supposed to continuosly sync every existing e-mail/user/subscriber over and over for now end? I thought it would only sync (both ways) when something changed, not continuously which cuts in my resources.

    You meant the same user, and email gets synced repeatedly? If yes, that's not a common behavior, the plugin will sync existing users, and also when a new WordPress user is created. Other than that, once you have configured the MailChimp Web hooks, the subscribers will be automatically added as users on your Website too.

    Glad to know you that the plugin is working fine now, please do let us know if you find, or you are able to replicate the same issue again, we would be happy to give a further look. Have a nice weekend. :slight_smile:

    Kind Regards,
    Nithin

  • Stephane
    • Flash Drive

    Hi Nithin,

    It still seems like the plugin for mailchimp issue is resolved (or not), but the website still slows down to a crawl from time to time and overall remains slow.

    I installed Hummingbird + Smush it + WP Super Cache + Defender + CloudFlare to improve speed.

    This partly worked, also paid for the Performance Profiler to check the weight of each plugin on the page load.

    I'm still not getting the website fast again so I was hoping you could help.

    I did still have some issues that might be part of the solution:

    - Smush it: Doesn't want to smush only 7 images, everything else is done.
    --> However Hummingbird still says images are not smushed
    - Hummingbird also says that GZIP compression is not working but as far as I can tell the server supports this (other sites have this up and running)
    --> Can't figure out the problem
    - Kallyas Page Builder can't save anymore since these installations (500 error)
    --> Tried disabling installed plugins (and then also clearing cache), tried deactivating and reactivating theme, ... all no success, so at this moment I'm unable to update any of my pages :slight_frown:.
    Minification I did not activate (first of all minification is already reported at 100% and secondly from experience on another website, this would mess up the kallyas pagebuilder even more!)

    If you could have a look and help me out, that would be great!

    I also checked with my provider and I could pay for the following caching options: Redis, Memcached, Varnish or Ramdisk. If any of these would be an added value, I'm willing to pay for this but then I need to figure out which one is best and how to get it installed within WP.

    I have opened support access to the site haakbeest.be.

    Thx!

    Grtz,

    Stephane

  • Nithin
    • Support Wizard

    Hi Stephane,

    Hope you are doing good today. :slight_smile:

    - Smush it: Doesn't want to smush only 7 images, everything else is done.

    https://haakbeest.be/wp-content/uploads/2016/06/lossen-en-vasten-CAL-2016.jpg
    https://haakbeest.be/wp-content/uploads/2014/07/°°482-esprit-mix.jpg

    These image are causing issues in your system, the 1st link doesn't seem to exist, and the second seems to broken. Since there are only 2 images that's causing issue, easiest would be delete the existing images, and re-upload these images again.

    - Hummingbird also says that GZIP compression is not working but as far as I can tell the server supports this (other sites have this up and running)

    I checked your website, and GZIP seems to be working fine in your system:

    --> Can't figure out the problem
    - Kallyas Page Builder can't save anymore since these installations (500 error)

    Please try increasing your memory limit, and see whether this helps. To increase your memory limit, you'll have to create a php.ini file inside your root directory, and add the following rules to it:
    For eg:

    upload_max_filesize = 128M
    post_max_size = 256M
    memory_limit = 512M
    file_uploads = On
    max_execution_time = 180

    If you aren't able to increase your memory limit, would recommend you to get in touch with your host, in order to increase these values.

    Please check this link for more info:
    https://premium.wpmudev.org/blog/increase-memory-limit/

    Minification I did not activate (first of all minification is already reported at 100% and secondly from experience on another website, this would mess up the kallyas pagebuilder even more!)

    Minification is meant to optimize your website, and it's meant to be enabled once you have finished working on your website, and your website is ready for production. Wouldn't recommend you to enable minfication if you are still working on your website.

    I checked your website in pingdom test, and I could see that your server has a very slow response, over 3 seconds, and that seems to be one of the main reason.
    https://tools.pingdom.com/#!/c0uqU1/https://haakbeest.be/

    You might find the following article helpful:
    https://varvy.com/pagespeed/improve-server-response.html

    Please do note that if you have issues which isn't related to the initial question of your thread, would recommend that you create a new thread, so that it's easier for both of us to follow, and to avoid any confusions.

    I hope this helps, please let us know if you still need any further assistance. Have a nice weekend. :slight_smile:

    Kind Regards,
    Nithin

  • Stephane
    • Flash Drive

    Hi Nithin,

    Thank you for your support.

    Regarding SmushIt: Did what you asked, error has gone away, but Hummingbird keeps the score on 9 for the images, even though SmushIt sasy all is done.

    I did the rest of your tips and now I can indeed edit pages with the page builder again. Thx!

    The speed of the website still seems slow even though I have done everything except minifying (since the pages are still changing).

    Anything else?

    Thx!

    Grtz,

    Stephane

  • Rupok
    • Support Ninja

    Hi Stephane,

    Hummingbird keeps the score on 9 for the images, even though SmushIt sasy all is done

    Actually, Hummingbird image optimization score doesn't depend on compressing only. It also depends on image scaling. Let me explain.

    WP Smush Pro only compresses image to make file size lower. But if you show a 1200 X 800 px image in a 300 X 200 px image frame, then this is not optimum and will bring poor grade in your image score in Hummingbird. For example, https://haakbeest.be/wp-content/uploads/2017/01/Over-mij-home.png is resized in HTML or CSS from 908x1221 to 230x309. Serving a scaled image could save 1.2MiB (93% reduction). So can you please check the listed images [when you click on the "Improve Score" button beside Optimize Images score] and resize those images to the frame size where they are being displayed? That will dramatically increase your image optimization score.

    I also found that you don't have Hummingbird minification enabled. Can you please try minification and combining of your assets? That will also increase your site loading time.

    Different sites use different plugins and themes and those plugins and themes call different assets. And some assets need to be left untouched, I mean, not minified and combined. So minifying all assets might break your site design or some functionality at first try. But when you start excluding one by one, you will know which files should be minified and which files should be untouched. In this way, you can find the most optimum setup for your site.

    Please note, I'll suggest you to take a complete backup of your site before enabling minification so you can always revert back to current state if anything goes wrong.

    Please let us know if you have any confusion or any further query. We will be glad to help.

    Have a nice day. Cheers!
    Rupok

  • Stephane
    • Flash Drive

    Hi Rupok,

    Yes, I know. I have 2 images (on purpose) that Hummingbird marks as "Compress and resize" so that fits your description. However, all the others are not, it only mentions "Compress" which should have been done already by Smush It I think?

    Regarding minification, when I get everything setup I will create a clone to first test the minification and find out the best settings before applying it to my live site.

    Thx!

    Grtz,

    Stephane

  • Rupok
    • Support Ninja

    Hi Stephane,

    Thanks for confirming. I had a detailed look on your listed images and found that most of them are from a specific image size "200 X 200". But I could not find 200 X 200 image size defined on your site. Smush settings is also not showing 200 X 200 image size. That means, that image size is not currently registered. But maybe your previous theme or somehow, you had 200 X 200 image size defined and your site is still using lots of images from that size.

    To fix this, please add the following line in your theme's "functions.php" file:
    add_image_size( 'smush-fix', 200, 200, true );
    And save. It will register 200 X 200 image size on your site. Then go to Smush Settings page and you will get that image size listed in Automatically Smush section. Please check the attached screenshot for reference.

    Check the 200 X 200 size now and smush all the images of that size.

    I believe this will resolve your issue. Please let us know how it goes. If it doesn't help, we will be glad to investigate further.

    Have a nice day. Cheers!
    Rupok

  • Kasia Swiderska
    • Support nomad

    Hello Stephane,

    Those images that needs only compression (and not resizing) have smaller impact on your score that those big images that need resizing.
    Score will change when those two big images will be handled.

    For those smaller images can you try using this plugin https://srd.wordpress.org/plugins/regenerate-thumbnails/ to regenerate those images and then smush them again so all the sizes will be smushed properly?
    Don't try regenerating whole library - just those listed files (you can do that directly from the media list). Let me know how it goes.

    kind regards,
    Kasia

  • Stephane
    • Flash Drive

    Hi Kasia,

    Thx! I used the plugin and also set the dimensions of the WooCommerce products to match exactly the ones shown by the theme catalog page.

    I was able to get all of them sorted, except 2 but that is ok I guess.

    I also have 1 that remains because of resizing but I can't make the image smaller as this is set to the largest possible size needed, depending on the screen. The responsiveness of the site will use different sizes of this image, depending on the total width of the page so I guess that can't and shouldn't be solved either.

    So thank you, I guess this is the best I'll get it to be and seems not to bad :wink:.

    Thx!

    Grtz,

    Stephane

  • Denitsa
    • WordPress Warrior

    Hey there Stephane,
    I trust you're well!

    So are you happy about the current stats on your site?
    I checked your site on Google Page Insights and there are no Image optimizations showing up.

    Please let us know if you have any confusion or any further query. We will be glad to help.

    Cheers,
    Denitsa

  • Stephane
    • Flash Drive

    Hi Denitsa,

    Thx, I was able to get all the images optimized, although 1 is not looking good, might need to rethink that one.

    PageSpeed gives me a 93 for desktop so pretty good, main bottle neck remaining is server response time.
    PageSpeed for mobile is around 80, bottleneck here is css/js above the fold, but I guess once I'm ready to minify with hummingbird I can move most of this to the bottom of the page.

    At this time the site is fast and all functionality seems to work. Just the server response time will need some more attention as the report often says it waits for 0,48 seconds or double that for a first response.

    Anyway, much better now with Hummingbird + WP Super Cache + CloudFlare.

    Thx!

    Grtz,

    Stephane

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.