WP, Marketpress, Buddypress successfully anyone?

hey all,

is anyone successfully running marketpress with global products/stores with global products showing on front page and buddypress successfully?

when i add buddypress it won't display any new global products added after that...

anyone?

thanks,
gina

  • gina
    • The Bug Hunter

    well.. after 2 full days of uninstalling, installing.. starting with fresh WP installs... i mean i seriously did this at least 20-30 times.. i finally found the issue of why global products failed to show on the front page..

    it was when i had selected to show the gridmarket drop down option for shops. i don't know if anyone can duplicate but that is the ONLY thing different in the current install that is working properly.

    i have all my plugins installed again including buddypress and it is showing sub-site products. so relieved but man... what a headache and waste of two days for such a simple thing that i never thought to check.. until the last minute. and that was it for me.

    if tammie/anyone wants to test this and fix the issue: even when i only had marketpress, gridmarket, multisite and wp installed with the option to show global products on front page and i would add a sub site and products.. it would show the product.. but as soon as i select to show the drop down of shops.. those products i had already added would remain but no new products from that shop or new shops will appear after that.

    gina :slight_smile:

  • gina
    • The Bug Hunter

    yes.. there was no issue with buddypress .. it was just that global products weren't showing up for me.. ended up being an issue with the "shop picker" enabled.

    at least that was what my issue was after installing it 54 million times. (ok.. maybe 30) but still... lot's of attempts with fresh installs... only difference in the last install (that works!) was i didn't opt to show shop picker.

    and that made me recall that a few attempts before it was working and i was pretty stoked.. then i added the shop picker and added a new test shop but new products wouldn't show up.. only shops/products added previous to enabling the shop picker. i had enabled buddypress right after shop picker so at first i thought it was that.

    but now i have WPMU, buddypress, gridmarket and marketpress playing nice together... just shop picker is in time out.

    :slight_smile:
    gina

  • Mason
    • DEV MAN’s Sidekick

    Hiya gina,

    I'll definitely take a look at this and ask Tammie to take a look as well.

    Can you tell us more about what you mean here?

    it may also be from trying to add products to subsites from super admin dashboard access

    As Fondeli mentioned, many folks are having no problem with the store picker at all, so it sounds like we may have another variable that's having an affect here.

    Please let us know and we'll dig into this with ya.

    Thanks!

  • gina
    • The Bug Hunter

    thanks fondelli. did you try adding products on a sub-site after the shop picker was activated?

    ....actually i think now it may be happening when i create a "demo shop" and then access the dashboard to add test products for that shop via /wp-admin/network/sites.php ...the test products will not show on the front page or any other global widget etc..

    it may have not been the shop picker... but it was the only thing i did different on the most recent install that is working. so i thought it was that.

    so... maybe try that to duplicate mason... adding a demo sub-shop then accessing the dashboard for that shop via /wp-admin/network/sites.php and see if you add a test product if it shows on front page/global widgets. ...cuz it won't show for me.

    thanks :slight_smile:
    gina

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.