WP MU network - Posts and Pages Permalinks not working

Hello,
I am setting up a network and using marketpress. I am currently working on setting up the primary site at Craftwing.com. The pages and posts work fine when using the default permalinks but when I change the permalinks to pretty permalinks as required by marketpress it breaks and when clicking on the links i get a 404 error. My custom permalinks I am trying to use is /%postname%/

I did notice that when I go to change the permalinks there is already a /blog/ already there in front of the field that I enter my custom permalink setting. When the pages are saved there is no /blog/ included in the url.

I have deactivated all the plugins and the problem still remains.

Any ideas how I can fix this? Thank you.

Melissa

  • DavidM

    Hi Melissa,

    Hmm, if you change your permalinks to other than default, with MarketPress deactivated, do other pages on your site work okay?

    If those are fine, then MarketPress really shouldn't have any issues as well. If so, could you go ahead and activate MarketPress then reset your permalinks?

    Basically, you can go to Appearance > Permalinks, set your permalinks to perhaps the default setting, Save that change, then set it to your preferred setting and Save again.

    Also, if you could try selecting one of the other permalinks rather than the custom /%postname%/, that'll help sort it.

    Just to add too, the /blog/ slug is due to your having Multisite enabled with a sub-directory install. There are ways to get rid of it but it's there for stability purposes.

    Cheers,
    David

  • Melissa

    Thanks David for your quick response.

    If I change my permalinks to other than default, with MarketPress deactivated, my pages and posts do not work.

    I have already tried setting permalinks to the default and it works fine but then when I change it to any other setting, including the options listed on the permalink page it breaks and both posts and pages don't work (404 error).

    Thanks for the info on the /blog/ slug that shows up when multisite is enabled. It seems weird that when I save the posts and pages the url does not have the /blog/ slug in it.

    I don't know what else to try. I have been using WP for several years and I have never had any problems adding pretty url permalink settings before. this is my first experience with Multisite though and it obviously adds a new level of difficulty.

    Thanks for your help,
    Melissa

  • DavidM

    Hi Melissa,

    Actually, if you've had other WordPress sites working with your host I really can't imagine mod_rewrite being an issue. It seems instead, as you mentioned you didn't have an .htaccess file, that that's the issue here.

    Part of the Multisite installation process involves copying and pasting the information provided at Tools > Network into your htacess file during the setup process.

    If you don't recall that step and therefore don't have an htaccess file, that definitely seems to be the issue. As such, do you now have that htaccess file that you posted here now existing in your WordPress main directory?

    It should be named .htaccess with no file extension. I think that should sort this. Could you let us know how that goes?

    Thanks,
    David

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.