WP Multi-Domain Plugin HTTP Only?

Hi,

I would really like to use the Multi-Domain plugin in conjunction with Domain Mapping however it seems to only support HTTP?

Is there a way to change to HTTPS for sites created with the Multi-Domain plugin?

Thanks.

  • James Morris

    Hello Mitch,

    I hope you are well today.

    Multi-Domains will work with HTTPS, but not exactly out of the box. Please let me explain a little better about why and then I'll provide a workaround...

    In order to run HTTPS on all your domains registered in Multi-Domains, you'll either need to have a wildcard SSL certificate that covers every domain configured in this plugin, or you'll need to purchase a SSL certificate for each domain separately and install it.

    By default, if your primary domain is setup with HTTPS from the start, whenever you setup Multi-Domains, the Admin Dashboard is already set to HTTPS, but the front-end of the site is HTTP.

    However, you can switch any site you create with a Multi-Domaind domain very easily. Here's a video walk-through of the process: https://goo.gl/EMHO3S

    As you can see in my video, because my Network Master (Primary Domain) was originally configured with HTTPS, the sites I setup with Multi-Domains are already redirecting to the HTTPS schema. But, because I do not have a wildcard SSL or a cert for the domain configured in Multi-Domains, it threw an error. But, by going into Network Admin -> Sites -> Edit {site.tld} and then edit the schema in Site Address (URL), I can change this on a per-site basis as needed.

    I hope this clarifies a bit.

    Best regards,

    James Morris