WP Security Defender

I am a member and have of your many plugins installed.
I have seen an offer for a plugin called WP Secure (wpsecure.me). It changes the names of files and removes and replaces wp-admin.
Do I need this if I have WPMU? Can it work with what I already have? Please advise. Thanks, Randy