WP-Signup redirect loop

I have a Marketpress Multi-site setup. Was latest version this morning.

My site was up and pretty close to finished then the SSL was installed. The static IP was added at the same time.

Now when I try to access the site I am running into a "This webpage has a redirect loop" message.

I did the usual things - cleared cookies, rebooted, and opened developer tools to see what was going on.

Under

Resources->data->other, it flashes through a series of trying to load wp-signup.php. A constant loop.

Anyone have ideas what I can do to correct this issue?

Thank you again
Angela

  • Angela

    Hi Jack - I am well - thank you for asking!

    Not sure about the SSL enabled or not - but I think not on either. Unfortunately not accessible.

    Here is my .htaccess:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

  • Jack Kitterhing

    Hi there Angela,

    Glad your well :slight_smile:

    Don't give up! Everything can be sorted :slight_smile: Them .htaccess rules don't look correct to me, as your on a multisite install aren't you? As you have the wp-signup.php ?

    If that is correct, replace your current rules with these and see if it works.

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

    Thanks!

    Kind Regards
    Jack.

  • Angela

    Hi Jack - thank you for the response! No, I haven't quite given up but I do know there is a time to cut bait and just start over.

    Yes, this is a multi-site install. I was in the process of getting everything set up and nearly had it complete when this happened.

    I replaced the contents of my .htaccess as shown below:

    # BEGIN WordPress

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    # END WordPress

    I still get constant looping on the wp-signup.php.

    Also, during my troubleshooting earlier this morning for the heck of it I renamed the wp-signup.php and it had zero impact on this error. (it's back to the original name - was a temporary test)

    Thanks
    Angela

  • Angela

    Hi Jack

    Done. Here is the content. Ran a couple times - once to negotiari.com, once to negotiari.com/wp-login.php

    [28-Mar-2013 16:00:41 UTC] PHP Notice: wp_enqueue_script was called incorrectly. Scripts and styles should not be registered or enqueued until the wp_enqueue_scripts, admin_enqueue_scripts, or init hooks. Please see Debugging in WordPress for more information. (This message was added in version 3.3.) in /home/amfonline/negotiari.com/wp-includes/functions.php on line 2959
    [28-Mar-2013 16:00:42 UTC] PHP Notice: A session had already been started - ignoring session_start() in /home/amfonline/negotiari.com/wp-content/plugins/e-newsletter/e-newsletter.php on line 1493
    [28-Mar-2013 16:00:44 UTC] PHP Notice: wp_enqueue_script was called incorrectly. Scripts and styles should not be registered or enqueued until the wp_enqueue_scripts, admin_enqueue_scripts, or init hooks. Please see Debugging in WordPress for more information. (This message was added in version 3.3.) in /home/amfonline/negotiari.com/wp-includes/functions.php on line 2959
    [28-Mar-2013 16:00:45 UTC] PHP Notice: A session had already been started - ignoring session_start() in /home/amfonline/negotiari.com/wp-content/plugins/e-newsletter/e-newsletter.php on line 1493
    [28-Mar-2013 16:00:45 UTC] PHP Notice: Undefined index: custom_fields_map in /home/amfonline/negotiari.com/wp-content/plugins/wpmu_dev_maps_plugin/lib/class_agm_user_maps.php on line 99
    [28-Mar-2013 16:00:45 UTC] PHP Notice: Undefined index: gateways in /home/amfonline/negotiari.com/wp-content/plugins/pay-per-view/pay-per-view.php on line 874
    [28-Mar-2013 16:00:45 UTC] PHP Notice: Undefined index: gateways in /home/amfonline/negotiari.com/wp-content/plugins/pay-per-view/pay-per-view.php on line 879
    [28-Mar-2013 16:00:45 UTC] PHP Notice: Undefined index: gateways in /home/amfonline/negotiari.com/wp-content/plugins/pay-per-view/pay-per-view.php on line 874
    [28-Mar-2013 16:00:45 UTC] PHP Notice: Undefined index: gateways in /home/amfonline/negotiari.com/wp-content/plugins/pay-per-view/pay-per-view.php on line 879

  • Angela

    Ok, this is new. I just tried to run one of the stores - http://games.negotiari.com/ - and I do get the screen (after the errors).

    Notice: wp_enqueue_script was called incorrectly. Scripts and styles should not be registered or enqueued until the wp_enqueue_scripts, admin_enqueue_scripts, or init hooks. Please see Debugging in WordPress for more information. (This message was added in version 3.3.) in /home/amfonline/negotiari.com/wp-includes/functions.php on line 2959

    Notice: A session had already been started - ignoring session_start() in /home/amfonline/negotiari.com/wp-content/plugins/e-newsletter/e-newsletter.php on line 1493

    Then the screen comes up. I can also move from store to store - but that same error is coming up.

  • Angela

    Hi Jack

    I put this in the wp-config.php instead

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);

    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);

    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set('display_errors',0);

    // Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
    define('SCRIPT_DEBUG', true);

    and I can now get to the stores and the backend. The errors are still going into the log, and debug is still running.

    The issue still needs fixing, but I have access to the stores at least.

    I do not have access to the Network Admin though. Still get the redirect loop.

    Angela

  • Angela

    Two entries of note in the log file:

    [28-Mar-2013 17:24:22 UTC] WordPress database error Table 'negotiaricart.wp_tblnme_reports_user_activity' doesn't exist for query INSERT INTO wp_tblnme_reports_user_activity (user_ID, location, date_time) VALUES ( '1', 'www.negotiari.com/wp-admin/admin.php?page=bcat_settings', '2013-03-28 17:24:22' ) made by include('wp-admin/admin-footer.php'), do_action('admin_footer'), call_user_func_array, Activity_Reports->user_activity

    and

    [28-Mar-2013 17:21:42 UTC] PHP Notice: Use of undefined constant WP_NETWORK_ADMIN - assumed 'WP_NETWORK_ADMIN' in /home/amfonline/negotiari.com/wp-content/plugins/comments-plus/lib/class_wdcp_admin_form_renderer.php on line 11

    Angela

  • Jack Kitterhing

    Hi there @Angela

    Can you try disabling e-newsletter be removing them files or following this and do it to all your plugins, then move back over one by one

    You create a new folder called /plugins-ole/.
    You then upload or move across all active plugins.
    Then rename the original /plugins/ folder to /plugins-old/ and the newly created /plugins-ole/ to /plugins/
    Do not load the WordPress plugins admin area; this will deactivate them all in the DB thus requiring you to then manually reactivate them.

    Let me know how this goes :slight_smile:

    Thank you!

    Kind Regards
    Jack.

  • Angela

    Hi Jack

    Database changes fixed the main issue and I can now get to my network admin area! Not sure how they wound up in there, but must have been early on.

    I am still throwing errors in the log file, and this is what I got when I clicked on my admin dashboard (so I will go through the plug ins 1 by 1):

    [28-Mar-2013 18:44:42 UTC] PHP Notice: wp_enqueue_script was called incorrectly. Scripts and styles should not be registered or enqueued until the wp_enqueue_scripts, admin_enqueue_scripts, or init hooks. Please see Debugging in WordPress for more information. (This message was added in version 3.3.) in /home/amfonline/negotiari.com/wp-includes/functions.php on line 2959
    [28-Mar-2013 18:44:43 UTC] PHP Notice: A session had already been started - ignoring session_start() in /home/amfonline/negotiari.com/wp-content/plugins/e-newsletter/e-newsletter.php on line 1493
    [28-Mar-2013 18:44:44 UTC] PHP Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /home/amfonline/negotiari.com/wp-includes/functions.php on line 2923
    [28-Mar-2013 18:44:44 UTC] PHP Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /home/amfonline/negotiari.com/wp-includes/functions.php on line 2923
    [28-Mar-2013 18:44:44 UTC] PHP Notice: Undefined variable: global_site_tags_current_version in /home/amfonline/negotiari.com/wp-content/plugins/global-site-tags/global-site-tags.php on line 83
    [28-Mar-2013 18:44:44 UTC] PHP Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /home/amfonline/negotiari.com/wp-includes/functions.php on line 2923
    [28-Mar-2013 18:44:44 UTC] PHP Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /home/amfonline/negotiari.com/wp-includes/functions.php on line 2923
    [28-Mar-2013 18:44:45 UTC] WordPress database error Table 'negotiaricart.wp_sgtphz_reports_user_activity' doesn't exist for query INSERT INTO wp_sgtphz_reports_user_activity (user_ID, location, date_time) VALUES ( '1', 'negotiari.com/wp-admin/network/admin.php?page=wpmudev', '2013-03-28 18:44:45' ) made by require_once('wp-admin/admin.php'), include('wp-admin/admin-footer.php'), do_action('admin_footer'), call_user_func_array, Activity_Reports->user_activity

  • Angela

    Hi Jack -

    Yes it seems like we are down to plugins. I have removed a few, and may do more investigating as to what errors each brought but it's a beautiful holiday weekend in Michigan and I feel it may not be this weekend! I will list each instance separately for anything unusual (unless I find it documented out there already.)

    I appreciate all of the help. I am tweaking the design and will be able to do a show and tell first of next week as I said I would so that is the main thing.

    Thank you again! Hope all is well with you too and I appreciate all of the help.
    Angela

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.