WP Smush it Pro ... stopped fetching images

Hey there,

I started the smush it plugin about 3 days ago and just checked up on it today and found that it fetched 5/861 images. This is the error message I got:

Smush server was unable to access images from your site

Please let me know what I could do to fix this.
Thanks

    Michelle Shull

    Hi, Alex!

    This could be one of several things.

    1. Are you using a CDN, or a service like Cloudflare to distribute your content? Sometimes the Smush server IP needs to be whitelisted for these services. That IP address is: 66.135.55.161

    2. We may need to reset your connection to the Smush server. To do so, temporarily add this code to your functions.php file:

    delete_option('wp-smpro-sent-ids');
    delete_option('wp-smpro-bulk-sent');
    delete_option('wp-smpro-bulk-received');
    delete_option('wp-smpro-current-requests');
    delete_site_option('wp-smpro-current-requests');
    global $wpdb;
    $wpdb->query("DELETE FROM $wpdb->postmeta WHERE meta_key='wp-smpro-is-smushed' OR meta_key='wp-smpro-smush-data' OR meta_key LIKE '%wp-smpro-request%' ");

    Next, go to the front end of your site and refresh any page.
    Now, remove the code you just added from above.
    Retry Smushing.

    Let us know how this goes!

    Alex

    Hey there,
    So I spoke with my hosting provider and they said that the IP address is now not blocked but that it didn't look like they were blocking it in the first place.

    I added that function to the parent theme (first, since I didn't see a functions.php file in the child-theme) and I was able to refresh the smush process but it quickly failed and said that there was already a request coming from that server.

    I also tried to add that code in my child theme by making a new functions.php file, and it made my whole website white screen so I had to take it out.

    Please advise.

    Thanks.

    Jude

    Has W3 Total cache ever been activated on the site at any point? or are you using a security plugin - iThemes, WordFence, Succuri or any other ?

    Looks like you are smushing too many images on the site at once. Can you try with a lower number ?

    Also increase your memory limit, please do this by inserting the following into the wp-config.php file, just about the "That's it, stop editing" line:

    define( 'WP_MEMORY_LIMIT', '256M' );

    Let me know if that worked for you

    Cheers
    Jude