WP SMUSH NEW BULK DIRECTORY

Great New Directory Smush Feature!!!

I bulked my wp Content Directory yesterday and it worked like a charm in most cases.

For some reason even tho it processed hundreds of images in about 20 minutes,
Hummingbird is still telling me to Smush some that it couldnt find.

Attaching Screenshot here, would like to understand how these Subsites arent located in the wp-content folder or if the plugin just missed them?

  • Kasia Swiderska
    • Support nomad

    Hello Mr Right Now,

    I can see similar issue on my site - it's very strange because it shows me that images were smushed, but when I go to media library for that subsite it shows me that images are not smushed.
    I really need to consult this with developer - why this is happening.

    In the meantime can you check if when you do bulk smush on that subsite media library will Hummingbird stop showing that those images need compression?

    kind regards,
    Kasia

  • Mr Right Now
    • The Crimson Coder

    I dont know why my multisite is not listing the contents folder by subsite?

    It seems that all content is inside the FTP contents folder, by dates?

    I have ran the smush from each subsite inside WP Dashboards already they are all up to date.

    Even had one site that smushed a higher number of images that what was shown, something like Smushed 2000of1900images

  • Kasia Swiderska
    • Support nomad

    Hello Mr Right Now,

    Okey, I know everything now. So fact that images from media library are showing in custom directory in Multisite was a bug and developer fixed that in latest version. So now they wont show anymore in custom directories.

    Data of smushed images of custom directory is kept separate from images smushed in media library, that is why in media library they were showing as not smushed.

    It seems that all content is inside the FTP contents folder, by dates?

    Can you show me a screenshot of the directory structure?

    Even had one site that smushed a higher number of images that what was shown, something like Smushed 2000of1900images

    Does this still shows after last update?

    kind regards,
    Kasia

  • Mr Right Now
    • The Crimson Coder

    Thanks For that info!

    I think ive found the issue here.

    1.Attaching my structure on the FTP here in Screenshot 1&2 where I can locate the "sites"
    folder which contains the subsites.

    As I can only reach the directory smush from my main site ( is it supposed to be like that?)
    then sites does not list in the directory like it does on the FTP.

    2. Dont see that second problem anymore with smushing more than what was in the folder.

    Thanks

  • Umesh Kumar
    • Code Wrangler

    Hey Mr Right Now,

    The sites folder is excluded on purpose, as it only contains the Media Library files for specific sites, which should be smushed from Media Library and not using the directory smush.

    Do you have plugin specific folder inside sites folder as well? Would love to know if any of the plugin/theme stores images in there as well.

    Cheers, Umesh

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.