WP Smush Not finding images

I need to smush all of our images with a major focus on performance. When I try to do that, it says it cannot find images. We do have hummingbird and a CDN.

  • Adam Czajczyk

    Hello Matthew,

    I hope you're well today and thank you for your question!

    I accessed your site and took a look around. I can see that there are images in Media Library that are already "smushed" and additionally WP Smush Pro ("Media -> WP Smush") is also reporting that there are still 226 images that could be optimized.

    That being said, are you referring to some other images from Media Library that are "skipped" by WP Smush Pro or to images from outside Media Library? If latter one is the issue then please note that WP Smush Pro will not include images such as theme images or images included in plugins etc. It cannot handle images hosted on external servers as well.

    As for images in Media Library, it seems it's picking them all but if I'm missing anything here, please correct me and point to the images that are being skipped.

    Best regards,
    Adam

  • Matthew

    I'm referring to the 226 images that it is saying can be smushed. When we tell it to smush, it does nothing. See the errors below. Also, to my knowledge, these images are hosted on our site and not on an external server.

    Could not find /home/content/68/11000368/html/cottonbeltoutfitters/wp-content/uploads/2013/10/size-guide-150x150.jpgCould not find /home/content/68/11000368/html/cottonbeltoutfitters/wp-content/uploads/2013/10/manuel-ritz-sakko-braun_4_0081329600_003_1-150x150.jpgCould not find /home/content/68/11000368/html/cottonbeltoutfitters/wp-content/uploads/2013/10/hackett-london-freizeithemd-rot_4_0081460300_002_1-150x150.jpgCould not find /home/content/68/11000368/html/cottonbeltoutfitters/wp-content/uploads/2013/10/hackett-london-freizeithemd-rot_4_0081460300_003_1-150x150.jpgCould not find /home/content/68/11000368/html/cottonbeltoutfitters/wp-content/uploads/2013/10/second-banner2-150x150.pngCould not find /home/content/68/11000368/html/cottonbeltoutfitters/wp-content/uploads/2013/10/hackett-london-sakko-oliv_4_0081218000_001_1-copy-150x150.jpgCould not find /home/content/68/11000368/html/cottonbeltoutfitters/wp-content/uploads/2013/10/hackett-london-sakko-oliv_4_0081218000_001_1-copy2-150x150.jpgCould not find /home/content/68/11000368/html/cottonbeltoutfitters/wp-content/uploads/2013/10/hackett-london-sakko-oliv_4_0081218000_001_1-copy21-150x150.jpgCould not find /home/content/68/11000368/html/cottonbeltoutfitters/wp-content/uploads/2013/10/b15-150x150.jpg

  • Alex Stine

    Hello Matthew
    Hope you are well.

    Firstly, sorry about what happened in chat today. We got disconnected some how and another customer joined the chat before you joined. I just wanted to make sure you knew that I didn't intentionally leave you hanging.

    Back to your issue, could you please try WP Smush again? I corrected all your permissions to 0755 so there should no longer be any issues.

    Please let us know how it goes.

    Cheers,
    Alex :smiley:

  • Matthew

    Thank you for getting back to me. That's ok, I understand and appreciate the follow up.

    Unfortunately, I am still receiving the same errors:

    Wp Smush, not able to smush images.
    Hummingbird unable to create cache directory. Minification will not work, you need to create the folder manually. (our theme has a minify option in the options.)
    Browser Caching unable to set time for js and css.

  • Matthew

    just an update, we did run smush and got the following:

    BULK SMUSH Smush individual images via your Media Library
    All images are smushed and up to date. Awesome!
    226 image(s) were skipped due to an error.
    Could not find /home/content/68/11000368/html/cottonbeltoutfitters/wp-content/uploads/2013/10/size-guide-150x150.jpgCould not find /home/content/68/11000368/html/cottonbeltoutfitters/wp-content/uploads/2013/10/manuel-ritz-sakko-braun_4_0081329600_003_1-150x150.jpgCould not find

  • Adam Czajczyk

    Hello Matthew,

    I checked your site again and adjusted folder/file permissions again and also reviewed settings. Still no success though. Furthermore, there's still an error suggesting that /upload folder is not writable.

    I did notice however that the file ownership/permissions on the server are quite unusual. For example, there's a mix of files/folders owned by "root" (!) and another user. I also see that there are some config files included that are not specific to WordPress.

    This leads me to the point that it would be necessary to make sure that folder/file ownership is proper: I think you're site's powered by Apache so the question is what's the user/group Apache is running with and/or what's the user/group of your account (if this is used). I don't know what hosting are you using but I suppose this may be something that would require help from your host.

    The bottom line is that this aspect doesn't look right and I think it should be taken care of first. I'm not able to do this via FTP because I do not know what's the configuration of your server/hosting account. Could you please get in touch with your host and ask them to help you take care of this (files/folders ownership/permissions of your WP install)?

    Once this is sorted out, let me know please and I'll continue troubleshooting if necessary.

    Kind regards,
    Adam

  • Matthew

    I've been on the phone with Godaddy about 14 more times to get this issue resolved.

    When I finally got someone with experience on the phone, we found a solution.

    For future reference, the technician went to wp options table database, went to page 2, and changed upload_path. She cleared it out/made it empty and WALA, problem solved.

    So this was not a WPMU DEV problem.

    Unfortunately, WPMU plugins are not godaddy certified. It would be nice if they were.

  • Adam Czajczyk

    Hello Matthew,

    I'm glad this is now solved.

    As for GoDaddy "certified plugins". Some hosting providers do indeed run their "lists" of plugins that are "approved" but in most cases this doesn't mean that the given plugin is not compatible. A lot of members of our community use GoDaddy services along with our plugins and I dare to say that usually this is not reason of issues.

    However, we do take care of this and for plugins that may need such a certification we simply get it. The WP Smush Pro plugin is GoDaddy certified:

    https://www.godaddy.com/garage/wordpress-plugin-partner-program/directory/

    That being said, since this issue is resolved I think we now could get back to that other one regarding image optimization here:

    https://premium.wpmudev.org/forums/topic/optimizing-images

    I just responded there so take a look please.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.