wp smush pro 500 error after switching servers from php5 to php7

When I run bulk smush, I get the following error: Error posting to API: 500 Internal Server Error1 image(s) were skipped due to an error.
It is not logging anything to my apache error log.
This is a new server running php7. We had it on a different server with php5 and it worked fine there.
I havent been able to test single file smush because everything I see just has smush stats already.
I can't give access and I can't disable other plugins, this is a live site. I'm hoping it is an easy fix you can tell me, otherwise I will have to spin up a clone to work on it.

  • Sajid

    Hi NOL,
    Hope you are doing good today :slight_smile:

    It seems your webserver is blocking the outbound HTTP request that is required to send images to our server and then after Smushing send them back to your server.

    Please contact your host and ask if they are blocking request to communicate with other servers via API.

    Meanwhile, I am also flagging our developer for his invaluable feedback on this matter. He will post a reply here as soon as possible.

    Take care and have a nice day :slight_smile:
    Cheers, Sajid

  • Nastia

    Hello NOL

    I hope you don't mind me chipping in :slight_smile:

    I've tested the bulk smush option on my server, which runs php ver. 7.0.3 and I can't replicate the same.

    Would you please enable WordPress debugging by putting the following inside the wp-config.php:

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );

    Once you run the bulk smush again, the debug.log will be created inside the wp-content folder. Please, attach the debug.log file in this thread so we can have a closer look.

    We are waiting for your reply!

    Cheers,
    Nastia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.