WP Smush Pro - I have optimized images but didn't help performance

Hi I have optimized all the images using the wp smush pro and the performance of the sight has not changed. The dashboard is also still giving me a low score in that area and telling me to optimize images, which has been done. What am I doing wrong? Thanks

  • Patrick

    Hi there Tanya

    I hope you're well today!

    Yep, I see that GTMetrix.com is giving quite a low score on images & javascript optimization for your site.

    Can you perhaps enable support access so we can login to your admin to see what might be happening here?

    If you're not quite sure how to enable support access, you'll find detailed instructions here:
    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-4

  • Patrick

    Hi again Tanya

    I just popped into your site and see that there are still over 1600 images in need of optimization. That's likely what is giving the low score for that at GTMetrix and elsewhere.

    Just out of habit, I also checked the server info that we can see in your WPMU DEV Dasboard, and I notice that max_execution_time is set to only 30 seconds. That is woefully inadequate for most sites these days, and I would recommend you get your host to increase that to 300 (at least 180).

    Unless you are comfortable editing your php.ini file, in which case you can increase that setting yourself. Easy instructions can be found here:
    https://premium.wpmudev.org/blog/increase-memory-limit/

  • Patrick

    Hi Tanya

    I hope you had a great weekend!

    GTMetrix is bogged down today, so I ran your site through Google pagespeed, who also gives a rather poor report for a few things. But Hummingbird & WP-Smush Pro are designed to help you get a handle on these issues. :slight_smile:

    Google has flagged half a dozen troublesome images, 3 of which are being served by YouTube, so there's not much that can be done about those.

    Also noted are a few javascript & CSS files that could be deferred to the footer instead of the header, as well as browser caching & minification of files.

    Would you mind granting support access once again, and I'll pop into your admin to help you get things set up and tweak the settings?

  • Patrick

    Tanya

    One of the issues is the huge image you're using for the main background throughout the site . That image weighs in at over 1.7Mb which is very heavy & slow to load, especially on mobile devices. I would recommend manually compressing that image, and upload the compressed version to use as your background instead.

    We could also set WP_Smush Pro to Include my original full-size images to see if that improves things. I would recommend also enabling Make a copy of my original images so you have a backup of them on your server, just in case you want to revert back.

    Another is the "Insta-banner" image in your sidebar. That image is almost twice the size it needs to be, and is being force-squeezed into a small container in your HTML (Google really doesn't like that). That image is in the sidebar and displays at no more than 300x375px, so that image should also be compressed and resized to those dimensions.

    Finally, there's your "Bucket-List" email banner which is also being squeezed into a container smaller than the image dimensions, which earns you again a penalty from Google. Resize and compress that image so it's exactly the dimensions of the largest size that displays on your site (1021x172px).

    As for the recommendations about javascript & CSS, I started running the minification scan in Hummingbird, and your site reacted quite strangely: immediately following a simple scan, your site looked like no scripts at all had loaded, and all text & images were displayed in a single long column down the left side of the screen.

    So, before continuing with any of that, it's important to know when would be the best time to do so on a site that is evidently live. I.E..- the time when it is quietest, or when you can notify your users of some "scheduled" maintenance & downtime.

  • Tanya

    Hello, I see that you have activated Hummingbird and I tried to run a performance text but am getting this error: PageSpeed was unable to connect to the server. Ensure that you are using the correct protocol (http vs https), the page loads in a browser, and is accessible on the public Internet.

    I also ran it on GT metrics and this site seems to be slower. I did read on hummingbird that there are cases that is will not work for sites and to test it when on and off and sometimes not using it is best, can you please advise me on what to do. Thanks

  • Patrick

    Hi again Tanya

    I just logged into your site to take another look and see how \i can help out there.

    I now notice that you have another minification plugin already installed and configured - WP Super Minify - and that has inded helped your site pass Google pagespeed recommendations.

    However, there does appear to be an underlying issue with your site's URL, as it refuses to load at GTMetrix with either HTTP or HTTPS as the protocol. As you are on a manged WordPress hosting plan at GoDaddy, and cannot modify your site URL in your admin, I strongly suggest you contact their support to help investigate what may be preventing your site from loading.

    Once we get a handle on the HTTPS issue, your site will likely load much quicker, and we can proceed with additional optimization efforts.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.