[WP Smush Pro] I have Smush PRO/Hummingbird PRO -> CDN issue

I have SMUSH Pro and have bulk smushed all my images. I want to take advantage of your CDN however every time I use it, images within my blog post disappear as well as the sponsor ads in the right side bar (I use widgets with either HTML or Image to do the ads). As soon as I deactivate the CDN the images reappear. I have had it happened now on 2 hosting sites (Bluehost and now Siteground which I just transferred over this week).

  • viobru
    • Support

    Hi, Xrayvsn!

    Happy New Year! Hope you are doing great :slight_smile:

    I'm sorry to hear that you are having issues with Smush CDN. From what you mention, seems that the issue could be caused by a block from the server. Could you please confirm with your host if their firewall setting is blocking the connection to smushcdn.com ?

    If that is not the case, would you mind running a conflict test to make sure that there’s not another plugin or the theme you’re using on your site causing this? You can find information about how to run a conflict test here: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-2
    Please, make sure you have an UPDATED and COMPLETE BACKUP of your site before running the conflict test.

    We look forward to hear from you.

    Kind regards,
    Violeta

  • Patrick Freitas
    • Staff

    Hi Xrayvsn

    How are you today?

    Thanks for the response from the server support, Smush IP is.

    66.135.55.161

    I contacted the developers to check if CDN uses the same IP as the plugin API, However, once you can Smush the images normally this IP wouldn't be blocked.

    As soon as I deactivate the CDN the images reappear. I have had it happened now on 2 hosting sites (Bluehost and now Siteground which I just transferred over this week).

    This was happening on Bluehost too?

    If so, let me ask the support access first to take a closer look for you.

    1. Log in to the WordPress Admin Panel for your site (go to the Network Admin dashboard if on Multisite), and then navigate to the “Support” page from the WPMU DEV menu item (WPMU DEV > Support).

    2. Click the “Grant Support Access” button in the Support Access panel.

    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Best Regards,
    Patrick Freitas

  • Xrayvsn
    • WPMU DEV Initiate

    Got this message from the siteground host team after I gave them the IP address:
    I have checked whether 66.135.55.161 IP is being blocked by our firewall and I can confirm that it is not.

    To further investigate the issue I have looked at the recent access logs for all of your websites and could not manage to find the mentioned IP.

    Please specify how we can recreate the issue on our end and provide us with backend login credentials if needed.

    I will go to the admin panel and grant access. Hopefully you guys can solve the problem because I really would like to take advantage of the CDN.

    Thanks!

  • Xrayvsn
    • WPMU DEV Initiate

    Oh and yes, same thing happened with Bluehost before I made the switch to Siteground. The CDN active would cause in post images to disappear and my sponsor ad widgets in right sidebar. As soon as I deactivate they would immediately come back.

    • Xrayvsn
      • WPMU DEV Initiate

      That actually worked but there was a new problem that happened.

      So when I disabled the Jetpack first and then turned on the CDN, the images were now appropriately being displayed on my ad right side bar and in post.

      However it seems that the Smush CDN does something weird with my theme (I use the Highend Theme option). I set it back to where Jetpack is back on for CDN and smush off (b/c I didn't like it) but when I did it the way you showed, the back side panels of my website (which are dark grey texture turned bright red (I'm talking about the very far right and left side panels) where there is no graphics/text at all, just like a picture frame. I want it dark grey like it is, but could not change it after smush CDN on (remained bright red).

      If there is an email, I can send a pic attachment to show it

  • Kasia Swiderska
    • Support nomad

    Hello Xrayvsn,

    Could you check now? I have added this small CSS fix for the background to Custom CSS styles:

    body {
    	background-image: url(https://xrayvsn.com/wp-content/themes/HighendWP/admin/assets/images/textures/black_denim.png);
    background-repeat: repeat;
    background-position: center center;
    background-attachment: scroll;
    background-size: initial;
    }

    and now with Smush CDN the background seems fine (back to dark grey).

    kind regards,
    Kasia

  • Xrayvsn
    • WPMU DEV Initiate

    I found an additional problem with the new css code that seems to have broken only 1 page (that I found so far on my site) that required me to deactivate it until fixed.

    the page in question is: https://xrayvsn.com/the-hospital/

    It basically has an RSS aggregator by Wordpress on it.

    Whenever I activate the smush pro cdn, it causes the right side bar ads to appear at the very bottom instead of the side. Also if you scroll to the very bottom of page with Smush CDN on, there is some weird text/code at the very bottom that shows up.

    Also whenever smush pro cdn on, every page on site has a small white line that creates a margin between main body and the side bar (hoping that could also be removed).

    Thanks

  • Patrick Freitas
    • Staff

    Hi Xrayvsn

    How are you today?

    Sorry for the delay here,

    You can use same code to fix the subdomain issue

    body {
    	background-image: url(https://xrayvsn.com/wp-content/themes/HighendWP/admin/assets/images/textures/black_denim.png);
    background-repeat: repeat;
    background-position: center center;
    background-attachment: scroll;
    background-size: initial;
    }

    About the RSS aggregator, I wasn't able to replicate the issue on my end, could you grant the support access and we can take a closer look for you?

    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Best Regards,
    Patrick Freitas

  • Xrayvsn
    • WPMU DEV Initiate

    granted access just now. thanks (if you are there and could put the code for subdomain as well b/c not sure where it goes).

    The page in question is: https://xrayvsn.com/the-hospital/.

    Need to see it before CDN turned on and then after (the sponsor ads get pushed all to the bottom and then weird code at very bottom of page). Also would be nice to get rid of that vertical thin white line sitewide between main body and right side panel when code is on

  • Kasia Swiderska
    • Support nomad

    Hello Xrayvsn,

    I will need to escalate this issue on page https://xrayvsn.com/the-hospital/ to Second Line Support Developers.
    I've checked differences between page with Smush CDN and without and for some reason HTML code of the page is changed and that is why this page is broken.
    It is not something that can be fixed with CSS code like this background, so it needs to be checked by the developer.

    But I will need also FTP access to your site so we can investigate it more.

    Note: Don't leave your login details in this ticket.
    Instead, you can send us your details using our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question and the template below:

    Subject: "Attn: Kasia Swiderska"
    - Site login URL
    - WordPress admin username
    - WordPress admin password
    - FTP credentials (host/username/password)OR cPanel credentials (host/username/password)
    - Folder path to site in question
    - Link back to this thread for reference
    - Any other relevant urls/info

    IMPORTANT: Please make sure you select "I have a different question" for your topic, so it doesn't go back to the forums - this and the subject line ensure that it gets assigned to me.

    Please confirm here that you send those credentials

    As for the site in the subdomain. This is a separate site, access is not open, so you can add that previous CSS code snippet in WordPress wp-admin -> Appearance -> Customize

    Then Additional CSS

    Next code goes at the bottom of the field:

    kind regards,
    Kasia

  • Xrayvsn
    • WPMU DEV Initiate

    I did the CSS code to the subdomain. Seems to work fine. When I turned on the Smushpro CDN (after deactivating Jetpack) same issue happened with the Hospital Page (so with the previous credentials I set, hopefully you can fix this site as well when solution found).

    Also would like to have that thin vertical white line removed between the side bar and the main body.

  • Patrick Freitas
    • Staff

    Hi Xrayvsn

    How are you today?

    Got news from Second Line Support, the page https://xrayvsn.com/the-hospital/ is breaking because of a well-known issue on Hustle plugin and Smush CDN.

    As said, this is a known issue and will be fixed on upcoming update, I suggest keeping eyes on updates, once it receives the fix update, you will be able to turn on CDN back.

    Let us know if you need any further help on this issue.
    Best Regards,
    Patrick Freitas

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.