WP Smush Pro installed and activated, Pro features still locked.

Hello!

NOTE: This is NOT regarding WPMU Dev Dashboard (as selected in the dropdown above), for some reason we're unable to select the desired plugin even though it's installed and activated.

We're having problems activating WP Smush Pro on one of your websites.
It shows that it is installed and activated, but all Pro features are still locked.

I don't have the regular "WP Smush" installed either, only the Pro version.
Nor was i able to find the any useful thread on the forums.

We're also getting the following errors in our PHP log....

[21-Feb-2017 09:46:47 UTC] PHP Notice:  Undefined index: type in /public/wp-content/plugins/wpmudev-updates/includes/class-wpmudev-dashboard-site.php on line 1356
[21-Feb-2017 09:46:47 UTC] PHP Notice:  Undefined index: type in /public/wp-content/plugins/wpmudev-updates/includes/class-wpmudev-dashboard-site.php on line 1358
[21-Feb-2017 09:46:47 UTC] PHP Notice:  Undefined index: path in /public/wp-content/plugins/wpmudev-updates/includes/class-wpmudev-dashboard-site.php on line 1361
[21-Feb-2017 09:46:47 UTC] PHP Notice:  Undefined index: filename in /public/wp-content/plugins/wpmudev-updates/includes/class-wpmudev-dashboard-site.php on line 1362
[21-Feb-2017 09:46:47 UTC] PHP Notice:  Undefined index: slug in /public/wp-content/plugins/wpmudev-updates/includes/class-wpmudev-dashboard-site.php on line 1363
[21-Feb-2017 09:46:47 UTC] PHP Notice:  Undefined index: version in /public/wp-content/plugins/wpmudev-updates/includes/class-wpmudev-dashboard-site.php on line 1364
[21-Feb-2017 09:46:47 UTC] PHP Notice:  Undefined index: version in /srv/users/ridahpharma/apps/ridahpharma/public/wp-content/plugins/wpmudev-updates/includes/class-wpmudev-dashboard-upgrader.php on line 70

Also getting this error when trying to remove that specific site from the "Websites" list in the Hub.
"Something went wrong. We could not log you out from the website. Do you want to remove this site from the list anyway?"

And as the title says, WP Smush Pro is installed but all the Pro features are still locked!

Any help would be greatly appreciated :slight_smile:

  • Predrag Dubajic

    Hey Adwisemedia,

    Hope you're doing well today :slight_smile:

    I see that you have multiple sites running WP Smush, is this happening only on this one site or all of them are having the same issue?
    If they are all experiencing the same thing can you tell us if they are all hosted on same server?

    We're also getting the following errors in our PHP log....

    These are just notices and shouldn't be affecting any functionality but they shouldn't be there in first place and I was unable to replicate this issue on multiple sites I have, so could you try reinstalling WPMU DEV Dashboard plugin via FTP and see if the notices are gone after that?

    Also getting this error when trying to remove that specific site from the "Websites" list in the Hub.
    "Something went wrong. We could not log you out from the website. Do you want to remove this site from the list anyway?"

    It could be related to issue with WPMU DEV Dashboard not being properly installed so give above suggestion a try and see if this is still happening.
    Also, could you tell me which browser you're using and have you tried with different one?

    Could you try going to your account page here https://premium.wpmudev.org/hub/account/ and reset your API key from there, please note that this will log you out of WPMU DEV Dashboard on all your sites so you will need to login again.

    After that check if Smush and HUB issues are still happening and let us know of the current status.

    Best regards,
    Predrag

  • Adwisemedia

    So far this is the first site we've encountered this issue on.

    They're mostly hosted on the same server, we have 2 different servers that we're hosting WordPress on, one server has 1 multisite installation and the other server has single/individual installations.

    I've already tried to re-install WPMU DEV Dashboard through wp-admin, but not via FTP.
    But will remove both plugins again and install WPMU DEV Dashboard via FTP and then install WP Smush Pro again.

    I'm currently using Chrome.

    Will try to reset API Key as well, I'll write again in ~10 minutes.

  • Adwisemedia

    After having reset the API key and manually installed WPMU DEV Dashboard via FTP, we're now gettin this error instead.

    [21-Feb-2017 10:40:23 UTC] [WPMUDEV API Error] 4.3 | Error unserializing remote response. ((unknown URL) [500])
    [21-Feb-2017 10:40:28 UTC] [WPMUDEV API Error] 4.3 | HTTP Error: 401 "Unauthorized" (https://premium.wpmudev.org/api/dashboard/v1/user-info/4f0025ac20d054a77bbde427b93c7ee02fde1d5a [401])
    [21-Feb-2017 10:40:44 UTC] [WPMUDEV API Error] 4.3 | Error unserializing remote response. ((unknown URL) [500])
    [21-Feb-2017 10:41:11 UTC] [WPMUDEV API Error] 4.3 | Error unserializing remote response. ((unknown URL) [500])

    Genereated by your plugin.

  • Adwisemedia

    Hi again.

    Now i tried to re-connect on one of our previous websites that worked before.
    Now that one also gets the same error.

    Your server had a problem connecting to WPMU DEV: "Error unserializing remote response.". Please try again.
    
    If this problem continues, please contact your host with this error message and ask:
    
    Is php on my server properly configured to be able to contact https://premium.wpmudev.org/api/dashboard/v1/ with a POST HTTP request via fsockopen or CURL?

    My guess is this will occur on all our sites.

    Edit: Just tried another site, same issue there.

  • Adwisemedia

    I've now also tried....
    - Disabling all plugins except WPMU DEV Dashboard
    - Disable server firewall
    - Disable HTTPS
    - Curl is enabled on the server

    I've done some testing my self and it seems that no matter what i try to curl, it returns localhost.
    Gonna check some more.

    Edit #1: Tried on localhost, same issue there.
    Edit #2: Tried on a fourth server, that isn't one of our servers (some web hosting company), same issue there.
    This looks less and less likely to be an issue related to our servers >.<

  • Predrag Dubajic

    Hi Adwisemedia,

    We started having some issues with our servers just bit after you started this thread, this is most likely that your sites that were working stopped working after API change.

    This has been taken care of a bit later yesterday and it's quite possible that this was related to your original issue.

    Could you try connect your sites now and let us know what the status is, are you able to login again with all the sites that were working properly before and see what's the status of the site that didn't work.

    Sorry for any inconvenience this might caused.

    Best regards,
    Predrag

  • Adwisemedia

    Hello again :slight_smile:

    Back to the original issue...
    WP Smush Pro is now installed and activated, but pro features are still locked.
    No errors this time however and no problems logging in.

    I've tried to remove WP Smush Pro via wp-admin and also via WPMUDEV "Websites" and then re-installing the plugin, but pro features are still locked.

    This is on a multisite installation, earlier today it worked on a single-installation.

    Any ideas to what i could be this time?

  • Adwisemedia

    Scratch that previous message!

    There seemed to be some residual information/data in the database that i manually deleted.
    So i deleted all entries related to WP Smush and WPMU DEV in the database ( table: {prefix}_sitemeta ) and then it worked, also had to log back in to the dashboard plugin since i removed the API key from the database too.

    No bump intended, just adding information that could help someone in the future :slight_smile: