WP Smush pro internal server error 500

I'm getting an error when I try to single or bulk smush: Error posting to API: 500 Internal Server Error

Under my wpmudev dashboard under http requests it says everything is OK. What else can I check?

  • Kasia Swiderska

    Hello Dan,

    It most likely an issue of memory limit and maximum execution time. Please try to increase memory limit and maximum execution time by using one of methods mentioned in following blog post and then check again.

    Here is the link to that blog post:

    You can find the existing memory and execution time limit in WPMU DEV -> Support -> System Info -> PHP.

    kind regards,

  • Dan Berdal

    Hi Kasia, thanks for the suggestion.
    I changed max execution time to 180s and php memory to 512mb but still getting same error when i try individual smush. When I try bulk smush I got a 2 out of 5 images to smush on one site, and still zero on another. These images are less than 200k.

    It fails really quickly, it's not like it's timing out or anything.

    The install that is having trouble has all files hosted on Amazon elastic file system - EFS. I just tried wp smush on the same server but with images not hosted in EFS and it worked fine.

    When I look at my directory on the EFS mount I'm seeing numerical folders left behind like 19222905 with folder permission 000. If I ssh and check out contents of folder I can see it is full of resized images.

    I am not having the same thing happen on the NON efs installation.

    Any ideas on what part of having files hosted on a NFS mount would cause problems for Smush?