[WP Smush Pro] Low Score in HummingBird Pro despite of Smush Pro usage

So, I have configured Smush Pro for maximum compression, I think... Then I ran it!

Enabled settings: ALL except for Make a copy of my full size images and PNG to JPEG conversion...

Still, I get a very low score in Hummingbird for Images and a long list of images I need to optimize... When I click Analyze in Smush Pro, these images don't show up at all...

Please advise what am I doing wrong.

  • Nastia

    Hello Aleksandar

    I hope you are well and welcome to the WPMU DEV community!

    I've scanned your site performance with Google Page Speed insight and there are a lot of png images that need to be optimized. I've uploaded one of these images to my site and the Page Speed Insight performance didn't report back that an image needs an optimization. Please let me know if you're running your site on a cloud hosting. If yes, please clear cache on your server's end and run a performance report one more time.

    For the few JPG images please do the following changes in WP Smush settings, to increase the score for "Optimize images" :
    - Super-smush my images
    - Resize my full size images ( add suggested dimensions in the Width and Height fileds)
    - Smush my original full-size images

    Optionally enable "Make a copy of my full size images" to keep a back from original images, in case you wish to revert back the changes

    Few other images are placed outside /upload/ directory. To optimize these images, please go to Smush Pro > Directory Smush, click on Choose Folder button and select /wp-content/themes/ folder. Smush this folder

    If the issue will still persist, please grant access to your site from WPMU DEV > Support, so I can have a closer look?

    Please see the detailed instructions on the link below:
    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Let me know when you do!

    Kind regards,
    Nastia

  • ROIverhogen

    Hi Aleksandar ,

    Nastia helped me with this problem before as well as some other supports. I had a similar issue where my report told me to resize my images.

    For starters the resize function on smush changes the dimension of the biggest images to the set dimensions. E.g.: an image is 2400x2400px and Smush resize is set on 1080x1080px this image gets scaled to 1080x1080px.
    However it doesn't scale images to their correspondive <div> size on the website. For the optimal score you should check the dimensions of the image holder on the webpage (inspect img element). the developer tool will show you the size of this element. Now in the WordPress media library you can edit the image and scale it down to the dimensions needed for that element.

    Hope this was helpful. If it wasn't I'm sorry for the confusion.

    Cheers,
    Bjorn

  • Dimitris

    Hello Aleksandar,

    hope you're doing good and don't mind me chim in here! :slight_smile:

    I am not sure what the suggested dimensions for
    - Resize my full size images ( add suggested dimensions in the Width and Height fileds)
    should be.

    Smush can tell you what's the maximum dimensions, here's an example from a testing site of mine:

    Could you please enable this, bulk smush again and run a new Performance Report in HummingBird. If you still require assistance, please do grant support access for us, so we can have a better look. You can do that via WPMUDEV Dashboard plugin, no need to share any WP admin credentials. Just navigate in WP admin area under WPMU DEV -> Support page and click on the "grant support access" button. You can find detailed information about it here: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5
    Please do reply back here when access is granted because we don't get any notifications about it.

    Thank you,
    Dimitris

  • Dimitris

    Hello there Aleksandar,

    appreciate the granted support access! :slight_smile:

    There are some JPG images that needs "Compressing and resizing". This means that they are getting loaded in much smaller containers in frontend, so Google moans that you're loading unnecessarily large images. The best way to resolve this, is to locate when exactly these images are getting loaded and manually resize them to match the exact settings.
    More info: https://premium.wpmudev.org/blog/compress-resize-images-wordpress/

    The remaining reported images are PNG, which are already compressed but some extra optimization can be done, by converting them to JPG instead.
    In order to do so, first backup all files and database of your website. Then go to Smush settings and enable the "PNG to JPEG conversion" setting and bulk smush.

    Note: Any PNGs with transparency will be ignored. Smush will only convert PNGs if it results in a smaller file size. The resulting file will have a new filename and extension (JPEG), and any hard-coded URLs on your site that contain the original PNG filename will need to be updated.

    Warm regards,
    Dimitris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.