[WP Smush Pro] Missing images inside the site and posts

Hi
I tried to find help using the chat, but it was bad. being kicked out several times and no direct help while in the chat. And now I heard that a ticket must be issued for this issue which not sure why not from the first contact.

Problem: Missing images from the site front-end and from the blog posts (all of them) after being smushed. The images are still in the library. All the images were jpeg.

Please help

  • Adam Czajczyk

    Hello @info44365!

    I apologize for the trouble you had using our live chat support. In case you're experiencing frequent disconnections, please try switching to a different browser and/or keeping only a single tab (with chat session) open in browser. That should help, hopefully. We're also working alongside LiveChat team (our support chat solution provider) to identify why those disconnections happen and minimize them.

    As for the issue. I have checked your site and the images seem to be there in media library indeed, they are also referenced in source code with correct file names.

    However, it seems that you're using Jetpack's Photon module which offloads images to the external servers and serves them from there. Smush doesn not access these images, in fact there's no way then can be accessed by any 3rd party solution as they simply do not provide any API. Smush couldn't "touch" and change these images.

    In source code, those images from Photon are being used, not the once locally stored on your site. The problem is that Photon (or rather jetpack's servers) returns an error when those images are being called. Furthermore, if you disable Photon extension and even clear cache on site, for some reason the site still tries to fetch images from Photon. I would assume then that there's some additional cache on server.

    Additionally, some of the images (those that are not displayed) return "403 Permission Denied" error when you try to access them directly from your server. That means that they are physically there but server (it's not even on WP level) prevents access to them - which also might be a reason for that Photon error that I mentioned above.

    That being said, I wasn't able to test that further due to the fact that I do not have any access to your CloudFlare dashboard and the server to check and clear caches there and to check what can be preventing access to those locally stored images.

    Could you please try this steps:

    1) go to the CloudFlare dashboard and temporarily set it to "dev" mode (it won't cache anything and interfere then)
    2) In Jetpack settings disable "Serve Images from our server" and "Lazy Load Images" options in "Writing" section
    3) Access your server's control panel (cPanel probably but that might be a different solution as well) and look for any "hot-linking prevention" options there - disable them temporarily
    4) in the same panel look for any caching options and clear that cache
    5) clear the cache on site

    Check if the images are loading then. The images should then be loaded from your server (not photon) and those optimized images should be used.

    If that works, then please set the CloudFlare back to the live mode and if you'd still want to use Photon, you might need to get in touch with them to ask them to purge entire image cache for you as according to their docs they do cache images indefinitely and the only way to regenerate them if any changes were made is to ask them to do this manually.

    If none of that works, let me know please and I'll investigate it further.

    Kind regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.