[WP Smush Pro] Optimize images problem

WP Smush Pro not woking properly I think.
http://prntscr.com/islvbc

  • Nithin

    Hello Golam Rabbani,##1

    Hope you are doing good today. :slight_smile:

    I checked the mentioned images in your website. If you check the Performance Report as shown in your screenshot, under Optimize Images tab, you'll notice images marked as Compressing and resizing.

    Which means that those marked images are appearing larger than the content width of your theme, hence the Performance report is marking it as not optimised.

    In such cases, it'll require re-sizing the image size to fit the content width of your theme. Since you are having many WooCommerce products listed in the homepage, the product images are being showed as not optimized, as the images aren't loaded according to the content width of your theme.

    I'm afraid, at the moment there isn't any easy way in Smush to re-size such images automatically, as the size varies from one theme to another. For a quick workaround, would recommend you to check with your themes support, and see whether they would be able to provide a quick solution regarding this.

    If not, you could try adding the following code inside your child themes functions.php, or in mu-plugins, and see whether it fixes the issue.

    add_action( 'after_setup_theme', 'wpmudev_add_new_image' );
    
    function wpmudev_add_new_image() {
    
    	add_image_size( 'home-smart-deal-images', 173, 173 );
    	add_image_size( 'home-best-selling-image', 182, 182 );
    
    }

    Once added, you'll notice two new checkboxes under Automatic Smush option, under Media > WP Smush settings page. Once you check it, and save the settings, re-smushing the images should fix the issue.

    Please let us know if you have any further query related to this, have a great weekend ahead. :slight_smile:

    Best Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.