[WP Smush Pro] PHP notice: Undefined index

I just upgraded to the latest WP Smush Pro and started getting these PHP warnings:

Notice: Undefined index: rest_route in /Users/hagai/code/eot_v5.dev/wp-content/plugins/wp-smush-pro/core/modules/class-wp-smushit.php on line 1495
Call Stack
# Time Memory Function Location
1 0.0009 368512 {main}( ) .../index.php:0
2 0.0010 370432 require( '/Users/hagai/code/eot_v5.dev/wp-blog-header.php' ) .../index.php:17
3 0.9291 95195096 require_once( '/Users/hagai/code/eot_v5.dev/wp-includes/template-loader.php' ) .../wp-blog-header.php:19
4 0.9341 95201336 include( '/Users/hagai/code/eot_v5.dev/wp-content/plugins/EOT_LMS/templates/template-dashboard.php' ) .../template-loader.php:74
5 1.0211 96843872 do_shortcode( ) .../template-dashboard.php:33
6 1.0211 96853920 preg_replace_callback ( ) .../shortcodes.php:197
7 1.0211 96854648 do_shortcode_tag( ) .../shortcodes.php:197
8 1.0212 96854648 load_template_part_shortcode( ) .../shortcodes.php:319
9 1.0213 96871272 Gamajo_Template_Loader->get_template_part( ) .../class-EOT_LMS-public.php:142
10 1.0213 96871736 Gamajo_Template_Loader->locate_template( ) .../class-gamajo-template-loader.php:88
11 1.0214 96872808 load_template( ) .../class-gamajo-template-loader.php:164
12 1.0222 96960968 require( '/Users/hagai/code/eot_v5.dev/wp-content/plugins/EOT_LMS/parts/part-default.php' ) .../template.php:690
13 1.0231 96999920 get_field( ) .../part-default.php:10
14 1.0268 97022304 acf_format_value( ) .../api-template.php:54
15 1.0268 97022440 apply_filters( ) .../api-value.php:368
16 1.0268 97022840 WP_Hook->apply_filters( ) .../plugin.php:203
17 1.0268 97024344 acf_field_image->format_value( ) .../class-wp-hook.php:286
18 1.0268 97024344 acf_get_attachment( ) .../class-acf-field-image.php:348
19 1.0347 97022624 wp_get_attachment_image_src( ) .../api-helpers.php:3502
20 1.0357 97023096 apply_filters( ) .../media.php:851
21 1.0357 97023496 WP_Hook->apply_filters( ) .../plugin.php:203
22 1.0357 97024248 WC_Regenerate_Images::maybe_resize_image( ) .../class-wp-hook.php:286
23 1.0358 97024624 WC_Regenerate_Images::resize_and_return_image( ) .../class-wc-regenerate-images.php:228
24 1.0702 97238152 wp_update_attachment_metadata( ) .../class-wc-regenerate-images.php:366
25 1.0702 97238600 apply_filters( ) .../post.php:5300
26 1.0702 97239000 WP_Hook->apply_filters( ) .../plugin.php:203
27 1.0702 97240504 WP_Smushit->smush_image( )

  • Ash
    • WordPress Hacker

    Hello Hagai

    This is a known issue and already reported to the developer :slight_smile:

    This is just a notice, which is not harmful to the website but helpful for the developer. You can disable debug mode to hide the notice.

    To disable debug mode please go to wp-config.php and change
    define( 'WP_DEBUG', true );
    to
    define( 'WP_DEBUG', false );
    Though, I have already informed the developer so that he can work on this and take proper steps so that this notice doesn't appear. Hopefully, very soon this will be taken care of. We appreciate your patience on this.

    Have a nice day!

    Cheers,
    Ash

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.