[WP Smush Pro] Smush Pro interfering with Revolution Slider?

Hi
When I activate Smush Pro, the site can no longer serve the images in the sliders. Other images are unaffected.
I have Smush Pro operating with other sites without problems. Not sure what is going on but it is quite reproducible. Slider images are shown until I activate Smush Pro, then no images. As soon as I deactivate Smush Pro, the images return. Have tried clearing cache, etc. I have not unstalled /reinstalled Smush Pro. I have deactivated all plugins EXCEPT the WPMU plugins and Revolution Slider and WordFence - and had the same problem
Revolution Slider was upgraded to 5.0x (the same problem was present at 4.6x). Smush Pro is current as of today's update but this problem is unchanged for several days (so unrelated to that update).
Many thanks in advance for any help.
Cheers,
Scott

  • scosci78
    • WPMU DEV Initiate

    Kasia

    Yes, CDN was enabled. I reactivated the plugin, disabled the CDN, cleared the cache and retried. Same problem. I deactivated the plugin and the sliders are back. So it does not matter if the CDN is enabled or not with the problem I am experiencing.

    Hopefully that additional information is helpful.

    Cheers,

    Scott

  • scosci78
    • WPMU DEV Initiate

    Thank you Patrick

    Sorry it took so long - I was away for a few days.

    For what it is worth - I am also seeing a few Smush Pro-related glitches in another site. The glitches there are not with Revolution Slider, but with other images. Same theme for both sites. That may be a clue to consider.

    Many thanks.

    Scott

  • Patrick Freitas
    • Staff

    Hi scosci78

    Hope you are doing well, I tried to access your dashboard but it is returning a fatal error.

    This page isn’t working ++++++.com is currently unable to handle this request.
    HTTP ERROR 500

    Wouldn't you mind, please, check for the fatal error issue then we can keep debugging the Smush Pro?

    You can run a plugin conflict test from FTP:

    - Login to the FTP of your site and browse to wp-content folder
    - Rename the "plugins" folder to "_plugins"
    - Create a new "plugins" folder
    - Now move the first folder from "_plugins" to "plugins"
    - Go to the website and try to see if the issue is solved or not
    - Repeat Steps 4 & 5 till the symptoms comes back againNOTE: While you are doing this, do not visit WP Admin -> Plugins on your site. This will ensure that your plugins remain active when you copy them back over.

    Also, can you upload the theme to Google drive and send us the link, we can try to replicate on our end too.

    Let us know when the theme is uploaded or the fatal error is fixed.
    Best Regards,
    Patrick Freitas

  • scosci78
    • WPMU DEV Initiate

    Thanks Patrick

    Sorry about that. The HTTP error is rectified. It was a .htaccess issue.

    I will run the plugin conflict check you suggest in due course - at this point it won't get done until next week.

    As to uploading the theme for you to work on. I would need to know the domain you intend to play with it on. The theme checks a license server to make sure it is authorized. I would be happy to add your development domain under my license while you work on it and then delete it after you are through, or I could put you in touch with the developer/support. I am sure they would be cooperative.

    Thanks,
    Scott

    PS Please let me know if experience any additional server errors - I was not aware that was going on since the site itself was fine - it was just the WP admin area.

  • scosci78
    • WPMU DEV Initiate

    Thank you Kasia

    I would be happy to enable support - but the systems tells me that support access is enabled and still open for another 5 days. "No one from support has logged in yet"

    Hmmm - hopefully there is not a further problem with access...

    Please advise!

    Best,

    Scott

  • Patrick Freitas
    • Staff

    Hi scosci78

    Thanks for the access, I was able to log in now.

    Somehow the Smush is modifying the image URL on Revolution Slider and causing the issue.

    I tried to replicate on my end but wasn't able.

    Wouldn't you mind, please, send us some information we can take a closer look at this issue?

    Note: Don't leave your login details in this ticket.

    Instead, you can send us your details using our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question:

    Subject: "Attn: Patrick Freitas"

    - Site login URL:
    
    - WordPress admin username:
    - WordPress admin password:
    
    - FTP/SFTP credentials
    
    Host:
    Username:
    Password:
    Port:
    
    - cPanel credentials
    
    Host:
    Username:
    Password:
    
    - Folder path to the site in question:
    
    <strong>- Link back to this thread for reference</strong>
    
    - Any other relevant URLs/info:

    Please, reply to the ticket once you have sent the information.
    Best Regards
    Patrick Freitas

  • Patrick Freitas
    • Staff

    Hi scosci78

    How are you today?

    Thank you for the information.

    I was able to access the website using the provided information, however, we would the FTP or cPanel as well to debug the problem once we weren't able to replicate on our end.

    You can use the same contact form

    Note: Don't leave your login details in this ticket.

    Instead, you can send us your details using our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question:

    Subject: "Attn: Patrick Freitas"
    
    - FTP/SFTP credentials
    
    Host:
    Username:
    Password:
    Port:

    Best Regards
    Patrick Freitas

  • scosci78
    • WPMU DEV Initiate

    Thank you Patrick - I will get you further access.

    In the mean time, can you please explain what you mean by not being able to replicate the problem?

    From my perspective it is 100% reproducible. Activate the plugin, lose the slider graphics. Every time. Every computer. Every browser. So I am just a little confused when you say you cannot replicate the issue.

    If you log in to the site and activate the plugin - are you saying that you do se the slider graphics on the site? That is very hard for me to conceive given my own testing over the last month or more.

    Thanks for helping me to understand.

    I will get back with further details for access later this AM.

    Cheers,

    Scott

  • Patrick Freitas
    • Staff

    Hi scosci78

    Hope are you doing well.

    Thank you for the credentials, I was able to login using the provided credentials.

    In the mean time, can you please explain what you mean by not being able to replicate the problem?

    From my perspective it is 100% reproducible. Activate the plugin, lose the slider graphics. Every time. Every computer. Every browser. So I am just a little confused when you say you cannot replicate the issue.

    Sorry if you got this wrong. I was able to replicate it on your site, but I wasn't able to replicate on my site.

    Activating the Revolution Slider on my site and adding some slides I was able to activate Smush without this problem.

    I also checked and couldn't find any reported issue for Smush changing the image URL on the Revolution Slider.

    I escalated this thread to our second line support.

    Note the second line support deal with the more complex situation once the second line support updates the thread you will get an e-mail notification.

    Best Regards
    Patrick Freitas

  • Tho Bui
    • Staff

    Hi scosci78,

    I hope you're well today!

    Apologizes for the delay, regarding your issue, I checked and see it's related with Lazyload on Smush. In that case, you can go to the lazyload setting (Smush Pro->Lazyload), and then scroll to Include / Exclude section and exclude the page using Revolution Slider.

    But we have an issue on the Include / Exclude function on specific server site, it will be fixed on the next release version. So if this setting is not working for you, you can try to use this custom snippet which you can use as a guide here :
    https://gist.github.com/wpmudev-sls/c883b29d4cf40c508e785b198e9fd547

    You can download a zip, unzip it and upload file smush-disable-lazyload-on-revoslider.php to your wp-content/mu-plugins folder. If that folder doesn't exist you can simply create it.

    If you are not familiar with mu-plugins you can read about them here:
    https://premium.wpmudev.org/manuals/wpmu-manual-2/using-mu-plugins/
    or you can paste it in your child theme's functions.php file.

    Kind regards,
    Tho Bui

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.