[WP Smush Pro] WP Smush Pro CDN feature might need a domain validation

Hello everyone,
We love the clean, simple and efficient approach that was developed into WP Smush Pro for a CDN. It gives it a great plus-value.

We tried enabling it, and it broke the images of all our sites and disabled it back + emptied caches. We think we know why this happened and we'd like to know how to go about it.

This URL: https://697538.smushcdn.com/0/wp-content/uploads/sites/70/2018/06/9b8138_baabee88e1c84da9a97a7343931839f5_mv2.png?lossy=1&strip=1&webp=1
Was used to load the logo image of this website: https://www.erictruchonphoto.com/

When you browse to the first URL, it says that the site is not registered in the Hub.

Suggestion: Check if the site is registered to the Hub before changing the URLs to the CDN-generated ones. If the site is not registered, you can warn the WP admin through the dashboard (or any way you'd like).

Our main site is registered to the Hub, but not our many others. Do we have to add them manually one by one? Or is there any form of automation we can setup?

We create sites using the native way and change the URL to the final domain name https://www.domainname.tld

Thank you!

  • Nithin
    • Support Wizard

    Hi Vince,

    Sounds like the issue is specific to mapped domains, right? We were able to notice anomalies regarding this, which should be fixed in the next plugin update asap.

    For the time being, please try the following patch attached below, and check whether it works fine in your system. You can replace the file in the following path:
    /wp-content/plugins/wp-smush-pro/core/api/class-wp-smush-api-request.php

    This patch will be made available in the upcoming plugin version, so that you don't have to worry about the changes getting overridden after plugin update.

    Regards,
    Nithin

  • Nithin
    • Support Wizard

    Hi Vince,

    Sorry for the delay in getting back to you, seems like support access to the site is disabled at the moment. Since it's a mapped subsite, it doesn't needed to be listed in the Hub. Could you please grant support staff access so I can take a closer look.

    You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Please let us know once you enable access, so that we could get this sorted. Have a nice weekend. :slight_smile:

    Kind Regards,
    Nithin

  • Nithin
    • Support Wizard

    Hi Vince,

    Sorry for the delay in getting back to you, it seems like the cache is enabled for each subsite individually? I enabled Smush CDN, but it looked like there was minified, and cached files in the mentioned subsite which wasn't getting cleared.

    Since support access to the main website doesn't allow to access the subsite dashboard, I wasn't able to clear the cache specific to the subsite, to see the changes on how the site behaves once Smush CDN is active.

    Could you please share your sites WP admin login credentials, so that we could give a closer look, and help get it sorted asap.

    You can send credentials by using our secure contact form: https://premium.wpmudev.org/contact/#i-have-a-different-question

    - To Mark to my attention, the subject line should contain only: ATTN: Nithin Ramdas
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Please do follow up in the ticket once you have sent the above credentials. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Vince
    • Flash Drive

    Hello Nithin,
    It's most likely WP Rocket's cache.

    There is a super admin account in the "Grant access" notes if that can help you get things started.

    I will provide the information you're asking for shortly through your method as well.
    Thank you for your help!

  • Nithin
    • Support Wizard

    Hi Vince,

    Thanks for sharing the login, I accessed the mentioned subsite http://www.erictruchonphoto.com/, and enabled Smush CDN, and cleared the cache, and checked the logo image, and it seems to load fine.

    Seems to work when loading the CDN link directly via browser too. Please check, and advise if there is anything specific that we should be looking regarding this.

    Have a nice day ahead. :slight_smile:

    Regards,
    Nithin

  • Nithin
    • Support Wizard

    Hi Vince,

    Did you enable it through the Network Admin area? (it seems to be network enabled in the network admin panel, but it's not affecting other websites: https://www.magikweb.net/wp-admin/network/admin.php?page=smush&view=cdn)

    If I recall, the settings was configured for network wide. If you enable the CDN network wide, it should have got enabled for other subsites too.

    At the moment, the CDN is disabled in the above page link. I just quickly enabled the CDN in the network dashboard, and checked the constructionbrunocouture dashboard, and the Smush CDN was enabled in dashboard side.

    When I checked the homepage, I could notice that Smush CDN is enabled, however at the moment there is only one image which is loaded via img tag, ie:
    <img src="link-to-image">

    Rest of the images are loading via CSS, at the moment I'm afraid, Smush CDN can only move the images to CDN loaded via img tags. The option to move the images added via CSS to CDN, is something which our developer is looking forward to implement down the plugins roadmap in future releases.

    I could notice that in such setup if Smush CDN is disabled via the subsite dashboard, it gets disabled network wide too. I'm bringing this into our developers attention, to see whether this is how it behaves, and see if we could make improvements on how it currently behaves.

    We disabled the CDN on the network level because it seemed to create a conflict with Slider Revolution on this site: https://www.activitesfamilles.ca/
    After disabling it and emptying the cache, the website came back to normal.

    Sorry to hear that, I'm afraid, this seems to be a bug, and fortunately our developer already has a fix regarding this in the next plugin update, which should be up very soon. Our Q/A is currently testing the plugin fully, so hoping it should be out very soon.

    I'll also check with the developer to see whether there is any quick patch available, or not. Other than that, for the time being, I'm afraid, you'll have to either disable the " Use network settings for all the sub-sites." settings, so you could enable Smush CDN individually for each site, or keeps Smush CDN disabled until the next release.

    Regards,
    Nithin

  • Vince
    • Flash Drive

    Thank you Nithin,
    I'm very happy with the proactive support. We'll watch the WP Smush Pro CDN evolve over time and will definitely benefit from it at some point. After a few updates, we'll give a shot and test our multiple websites once more.

    Kind regards,
    Vince

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.