WP-Smush settings page slow to load

The settings screen for WP-Smush takes 50 seconds to load on my site. This may have something to do with the sheer number of images in need of bulk smushing - over 25000.

  • Adam Czajczyk

    Hello Amit

    I hope you're well today and thank you for your question!

    I tried to check the issue on your site but the credentials provided by you to Patrick during the chat doesn't work for me and I can't access admin back-end. The site discussed during the chat also doesn't seem to be registered with your account so I can't use support access.

    Did something change since the chat or there was some misunderstanding or did you remove the plugin/the site from The Hub?

    If you still need assistance with the issue, please make sure that the site is registered with The Hub with your current account and that the support access to it is open so I could check it.

    https://premium.wpmudev.org/docs/getting-started/add-a-site-to-the-hub/

    Let me know here, please when it's ready.

    Best regards,
    Adam

  • Amit

    Hi,
    The site was registered but did not realise if I logged out of the Dashboard plugin, that it removes the sync.

    I logged out because Wordpress started to slow down, Especially, when editing posts. When I logged out, it resumed back to fast speed. It seemed something was 'pinging' the Hub a lot, hence, slowing my site admin down. Would like to know why this is happening?

    So, logged back in and it is synced up now. Support granted.

    So, can someone please check this problem with WP Smush settings page which is still very very slow when trying to access it.

    I will wait to hear from you re both issues above.

    Thanks

  • Adam Czajczyk

    Hello Amit

    Thank you for your response and explanation.

    I was now able to check the site and I can confirm that the Smush issue is directly related to the large number of images in Media Library. This is happening because of how the WP is caching some meta data used by Smush to re-create statistics. Our developers are already aware of the issue and are working on a permanent fix but there is a workaround.

    The workaround involves editing core files of the plugin and would result in stats not being shown on the Smush settings page but should improve that page performance (it might also improve overall back-end performance slightly though not drastically). Here is a detailed description on how to apply this:

    https://premium.wpmudev.org/forums/topic/502-error-while-trying-to-load-wp-smush-pro-settings#post-1314234

    If you want me to do this for you, let me know. I would, however, need access over FTP so in that case please also send in

    - FTP credentials (ftp host, port number, username and password) or cPanel credentials (login URL, login and password)
    - site's WP install path information

    Use this contact form to send message to me directly:

    https://premium.wpmudev.org/contact/#i-have-a-different-question

    Use only 'ATTN: Adam Czajczyk" as a subject line and make sure that you included a link back to this ticket.

    I'll then apply the change for you.

    If you feel like applying it by yourself, that's fine. Just let me know please when it's done and if it improved Smush settings page performance for you. I'll then also check the site again against the other issue that you described.

    Best regards,
    Adam

  • Adam Czajczyk

    Hello Amit

    I apologize for keeping you waiting on this.

    The issue seems to be more complex than initially expected as workarounds that I previously tried on your site they didn't work there but they did in all similar cases that we had reported and had a chance to test. Our developers are still looking into it in order to find a "core cause" and a proper solution for it.

    I have also messaged plugin's lead developer directly asking him for additional help.

    Kind regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.