WP Smushit - unable to access images

Hi,

Trying to smush my images but has this message:
Smush server was unable to access images from your site.

It has stayed like that for a long time now... what can I or you do to get it working?

All the best,

Martin

  • Tyler Postle

    Hey Martin,

    Hope you're doing well today and welcome to the WPMU DEV Community!

    Do you have a security plugin active? That is usually the cause of this error, since our last update we have added a bunch of new Smush servers to speed things up, but this also means the IP for the Smush it servers has changed. So if you previously had it white listed then it could be that you've been assigned a different server now.

    If you don't have a security plugin, can you do a full plugin check to make sure non of them are conflicting? You can do this by deactivating all other plugins and then try the Smush again.

    Can you grant support access so we can have a closer look? :slight_smile:

    You can grant support access via admin dashboard - WPMU DEV > Support > Support Access > Grant Access.

    Access will also allow us to get the server your using so we can provide the IP if needed.

    Look forward to hearing back!

    Cheers,
    Tyler

  • Martin

    Hi Tyler,

    Thanks for your fast reply. I have deactivated the two security plugins installed and that did not seem to help.

    I have had the process running for some hours before it stopped... so that is a bit strange.

    I have granted you access as you described. Please advice on what I can do now.

    One last thing. I can see that I only get in average 3% reduction of image files sizes. Is that normal? I had imagined it would be closer to 50%

    All the best,
    Martin

  • Tyler Postle

    Hey Martin,

    Thanks for your reply!

    I've just reset the bulk request and also whitelisted the server IP just in-case. Since you have so many images now, you will need to add this constant to your wp-config.php file:

    define( 'WP_SMPRO_REQUEST_LIMIT', 500 );

    Looks like your server isn't able to send all the available images you have, so batches of 500 should work :slight_smile:

    After that try Smushing again and let us know how it goes.

    As for it only reducing the image by 3%. Smush it is a lossless compression tool - so it doesn't shrink or reduce the quality of your image in anyway. It removes all the behind the scenes meta/EXIF data that isn't needed. This data can sometimes be 50%+ of the image size and sometimes only 1% or maybe even 0 if there isn't any to begin with.

    So the compression will vary quite a bit image to image, but your images will never lose any quality :slight_smile:

    Hope that helps!

    Cheers,
    Tyler

  • Martin

    Hi Tyler,

    Thanks... seems to work again :slight_smile:

    I have not inserted the code you gave me yet. I run Smush.it from the Media library selecting 100 at a time. So to start with I tried to just run everything but got a message saying that there were too many. So therefore 100 at a time. I guess this will work as well.

    One last thing for now. I can see that I have two users with my name logged onto my site. Myself here in Denmark on someone from Canada. That that your server?

    Thanks again,
    Martin