Wp super Cache issue

Hello when i installed wp super cache on my blog i get this error in html view source code:

<!-- WP Super Cache is installed but broken. The path to wp-cache-phase1.php in wp-content/advanced-cache.php must be fixed! -->

i have read the readme file but as far as i know i have done everything correct, the script is located under: wp-content/mu-plugins/wp-super-cache/

wp-cache.php is located under: wp-content/mu-plugins/
advanced-cache.php is located under: wp-content/

any ideas on what could be wrong?

  • Lori

    I'm not sure if this is the place to be asking this questions but I am having issues with this plugin too. (wp super cache)
    Ever since I have installed it, I have been having "header" errors and pages/posts not showing correctly. Does anyone know if this plugin could be causing these problems? If so, any ideas on what to do about it?
    The error i am receiving now is this: Warning: include(edit/tabs.php) [function.include]: failed to open stream: No such file or directory in /home/blogflos/public_html/wp-content/themes/edu-clean/header.php on line 31
    It's looking like it has to do with the tabber???? possibly?
    Any tips would be greatly appreciated or if anyone could point me in a direction to get some help on this I would really be greatful!
    Thanks!

  • Lori

    I'm not sure if this is the place to be asking this questions but I am having issues with this plugin too. (wp super cache)
    Ever since I have installed it, I have been having "header" errors and pages/posts not showing correctly. Does anyone know if this plugin could be causing these problems? If so, any ideas on what to do about it?
    The error i am receiving now is this: Warning: include(edit/tabs.php) [function.include]: failed to open stream: No such file or directory in /home/blogflos/public_html/wp-content/themes/edu-clean/header.php on line 31
    It's looking like it has to do with the tabber???? possibly?
    Any tips would be greatly appreciated or if anyone could point me in a direction to get some help on this I would really be greatful!
    Thanks!

    Got it fixed.........

  • TTiger

    ive add the rules to my htacces but still have these comment in my supercache option panel, how do i see is suprcash is running? ive check this option ON WP Cache and Super Cache enabled

    To serve static html files your server must have the correct mod_rewrite rules added to a file called /home/sexabulo/domains/webfeminin.com/.htaccess You can edit the file yourself add the following rules. Make sure they appear before any existing WordPress rules.

    # BEGIN WPSuperCache
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    AddDefaultCharset UTF-8
    RewriteCond %{REQUEST_URI} !^.*[^/]$
    RewriteCond %{REQUEST_URI} !^.*//.*$
    RewriteCond %{REQUEST_METHOD} !POST
    RewriteCond %{QUERY_STRING} !.*=.*
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress|wp-postpass_).*$
    RewriteCond %{HTTP_USER_AGENT} !^.*(2.0\ MMP|240x320|400X240|AvantGo|BlackBerry|Blazer|Cellphone|Danger|DoCoMo|Elaine/3.0|EudoraWeb|Googlebot-Mobile|hiptop|IEMobile|KYOCERA/WX310K|LG/U990|MIDP-2.|MMEF20|MOT-V|NetFront|Newt|Nintendo\ Wii|Nitro|Nokia|Opera\ Mini|Palm|PlayStation\ Portable|portalmmm|Proxinet|ProxiNet|SHARP-TQ-GX10|SHG-i900|Small|SonyEricsson|Symbian\ OS|SymbianOS|TS21i-10|UP.Browser|UP.Link|webOS|Windows\ CE|WinWAP|YahooSeeker/M1A1-R2D2|iPhone|iPod|Android|BlackBerry9530|LG-TU915\ Obigo|LGE\ VX|webOS|Nokia5800).*
    RewriteCond %{HTTP:Accept-Encoding} gzip
    RewriteCond %{DOCUMENT_ROOT}/wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html.gz -f
    RewriteRule ^(.*) /wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html.gz [L]

    RewriteCond %{REQUEST_URI} !^.*[^/]$
    RewriteCond %{REQUEST_URI} !^.*//.*$
    RewriteCond %{REQUEST_METHOD} !POST
    RewriteCond %{QUERY_STRING} !.*=.*
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress|wp-postpass_).*$
    RewriteCond %{HTTP_USER_AGENT} !^.*(2.0\ MMP|240x320|400X240|AvantGo|BlackBerry|Blazer|Cellphone|Danger|DoCoMo|Elaine/3.0|EudoraWeb|Googlebot-Mobile|hiptop|IEMobile|KYOCERA/WX310K|LG/U990|MIDP-2.|MMEF20|MOT-V|NetFront|Newt|Nintendo\ Wii|Nitro|Nokia|Opera\ Mini|Palm|PlayStation\ Portable|portalmmm|Proxinet|ProxiNet|SHARP-TQ-GX10|SHG-i900|Small|SonyEricsson|Symbian\ OS|SymbianOS|TS21i-10|UP.Browser|UP.Link|webOS|Windows\ CE|WinWAP|YahooSeeker/M1A1-R2D2|iPhone|iPod|Android|BlackBerry9530|LG-TU915\ Obigo|LGE\ VX|webOS|Nokia5800).*
    RewriteCond %{DOCUMENT_ROOT}/wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html -f
    RewriteRule ^(.*) /wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html [L]
    </IfModule>
    # END WPSuperCache

    Rules must be added to /home/sexabulo/domains/webfeminin.com/wp-content/cache/.htaccess too:

    # BEGIN supercache
    <IfModule mod_mime.c>
    <FilesMatch "\.html\.gz$">
    ForceType text/html
    FileETag None
    </FilesMatch>
    AddEncoding gzip .gz
    AddType text/html .gz
    </IfModule>
    <IfModule mod_deflate.c>
    SetEnvIfNoCase Request_URI \.gz$ no-gzip
    </IfModule>
    <IfModule mod_headers.c>
    Header set Vary "Accept-Encoding, Cookie"
    Header set Cache-Control 'max-age=300, must-revalidate'
    </IfModule>
    <IfModule mod_expires.c>
    ExpiresActive On
    ExpiresByType text/html A300
    </IfModule>
    # END supercache

  • johnetec

    Hello,

    I'm going to post this here since it seems to be a relevant wp-super cache thread. I can use super cache on my MU site but I cannot enable compression. When I do, it serves garbage pages. I have set the mod rewrite rules but that did not help. Anyone have any suggestions as to how to get compression to work?

    The site is running really heavy and the nextgen gallery I have installed takes forever to load the next image regardless of the settings.(Images are 50kb or less) I'm trying to speed this site up any way I can. Any suggestions would be much appreciated!

    Site is: http://arizonaapartments.us (It's a beta so no laughing at the really boring design)

    Thanks,

    John

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.