WP Super Cache question

I am trying to install and configure WP Super cache plugin under our CentOS server, I've followed the installation carefully, disabled safe_mode in the server php.ini, yet up to this moment I am getting the message:

---------------------
Warning! PHP Safe Mode Enabled!
You may experience problems running this plugin because SAFE MODE is enabled.Your server is set up to check the owner of PHP scripts before allowing them to read and write files.

You or an administrator may be able to make it work by changing the group owner of the plugin scripts to match that of the web server user. The group owner of the /var/www/vhosts/bpilot.com/httpdocs/wp-content/cache/ directory must also be changed. See the safe mode manual page for further details.
---------------------

Also I've change the cache directory permission to 777...

I've searched the web over and over and all I found was that this problem is mainly related to disabling safe_mode in php.ini, which I am 100% positive is disabled....so any ideas what I might be doing wrong here?

Thanks in advance for your time