WP Super Cache slow?

Hi

I just installed Worpress MultiSite on a new shared hosting (reseller prog @hostgator). And I am trying to optimize my wordpress to deliver fast. Installed SuperCache but when I load http://roxanajones.com/blog/ and look at the source it tells me that it took more than 3s (!!!) to create the page.

That sounds too much. Any idea? advice?

  • Brian Purkiss
    • Smushie Pies

    The average load time of sites these days is higher than three seconds. Though 3 seconds is still a pretty good load time.

    However, the ideal time is 2 seconds.

    There is no magical plugin that can reduce your load time. There are a number of different techniques for reducing load time.

    Taking a quick look at the site, you have 14 different CSS files and 27 different JavaScript files. If you could consolidate them or use a caching plugin to do that for you, that would reduce the load time.

    If there are plugins you aren’t using that you could disable, that would reduce the load time.

    Those would be the two places I would start first. They’d probably have the greatest effect.

  • mort3n
    • The Crimson Coder

    Hi tapuat,

    I also have very good experiences with w3 total cache. Especially when coupled with a content delivery network (CDN). I use MaxCDN (no, I don’t get sponsored by them :wink: ) with very good results for a highly dynamic site on a low ressource shared host.

    The w3 TC plugin has lots of settings but they’re straight forward to handle, especially when consulting one of the many tutorials on the web.

    Cheers

    Mort3n

  • tapuat
    • Design Lord, Child of Thor

    Hi guys,

    Thanks so much for this. I installed W3 cache and get now a 4s load time for http://roxanajones.com/blog. After the 4s waiting period it load pretty fast though :wink:

    I am using MaxCDN and have activated all options.

    I am using HostGator as host with shared hosting on CPUs:

    Name

    Intel(R) Xeon(R) CPU E5530 @ 2.40GHz

    Cache

    8192 KB

    Should I change machine or there is still something to optimize on my site?

    Any advice?

  • mort3n
    • The Crimson Coder

    You need to configure the plugin settings.

    On the General tab you enable the features you need.

    Then, on each of the component tabs you choose the settings for that component.

    This is specific to your site and you’ll want to spend some time on getting it set up right.

    For CSS/JS go the the Minify section on the General page.

    Enable, then choose if you want to serve the files from CDN or not (minify mode). If choosing CDN, then you’ll need to specify the files to serve from CDN as explained in the plugin.

    Then go to the Minify tab choose your settings.

    For images via CDN, go to CDN tab and work through the settings. If you store the images in non-standard folders, then you’ll need to tell the plugin where they are to have them served via CDN. This is all explained on the CDN tab.

    Cheers

    Mort3n

  • mort3n
    • The Crimson Coder

    I find

    'minify.auto' => true,

    so CSS/JS won’t be served by the CDN. This is specified on the General tab.

    You need it to be set to manual and specify the location of the script files.

    You pull a lot of scripts from external sites. Try combining them into one and minify.

    I advice you to consult YSlow.

    Cheers

    Mort3n

  • tapuat
    • Design Lord, Child of Thor

    Try combining them into one and minify.

    You mean manually putting them together and modify the code accordingly?

    I have set the CSS/JS manually but not much of a change it seems :slight_smile:

    Also, it appears that W3 cache it not modifying the URLs of the images which are still served by the main server instead of the CDN. Any suggestion?

    I tried P3, and It showed that qTranslate is a major hurdle but only for wp-admin it seems.

    I really appreciate your help guys. Thank you so much.

  • Brian Purkiss
    • Smushie Pies

    If the first file loading has a delay of 4.3 seconds before being loaded, then the problem is likely your web host.

    You’d need to upgrade to a better web host to decrease that time. All the other configurations will speed things up, but won’t speed up the first delay.

    W3 Super Cache can automatically consolidate the CSS and JS files, but must be configured to do so.

  • tapuat
    • Design Lord, Child of Thor

    We are with HostGator on a Reseller Plan.

    I am not sure this is entirely a host/server issue. If I look with Firebug at the following pages the difference is quite important:

    1) http://roxanajones.com/blog 3.23s waiting time

    2) http://roxanajones.com/category/blog/inspirational-images/ 1.6-1.9s

    3) http://roxanajones.com/ 4.25s

    4) http://roxanajones.com/roxana-jones-biography/ .92s

    The difference between (4) and all the others is the right column with all the widgets. (1),(2),(3) display a right col with widgets. So displaying the widgets costs <1s (if I compare with (2)) to 3s (for (1) and (3)).

    However, the difference between (2) and (1)&(3) is that (2) displays a category of posts while the others display a page.

    Any idea?

    @brian Purkiss:

    W3 Super Cache can automatically consolidate the CSS and JS files, but must be configured to do so.

    Awesome. How do I configure it to do just that if you don’t mind me asking?

  • Brian Purkiss
    • Smushie Pies

    Hm… Just for kicks, try removing all the widgets and testing the load time.

    It’s also worth pointing out that Facebook widgets often drastically increase the load time of a site.

    You should be able to consolidate the files by enabling “minify” in the W3 Total Cache settings page.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.