WP updates with SFTP access only, non-standard port

I am trying to help a client with automatic updates on their WP site. Their server has only SFTP, not FTP or FTPS, and it's running on a non-standard port. The WordPress installation is also in a sub-directory of the site. The automatic updates don't work (either WP core or plugins).

1. They have tried this plugin: https://wordpress.org/plugins/ssh-sftp-updater-support/ but had no success, possibly because of the non-standard port.

2. They added a fix re. upgrades over ftps/ssl (new self_signed_ssl_upgrade_fix.php in /mu-plugins as described at https://wordpress.org/support/topic/failed-update-network-attempt-after-upgrading-to-341 ) and got access with ftps to work over port 21. It seems to log in correctly, but has an error that "Unable to locate WordPress Content directory (wp-content)"

3. They've tried various suggestions from https://wordpress.org/support/topic/upgrade-plugin-unable-to-locate-wordpress-content-directory-wp-content re. that particular error, but haven't had success

I can't give access to the server for security reasons, but has anyone got any tips for getting SFTP to work?