WP_Ajax_Upgrader_Skin not found

When tried to install plugin from the WPMUDEV Dashboared it is showing Server error status: error [500] at the top and the error log is showing something like

PHP Fatal error: Class 'WP_Ajax_Upgrader_Skin' not found in /xxxxx/wp-content/plugins/wpmudev-updates/includes/class-wpmudev-dashboard-upgrader.php

I have found this https://premium.wpmudev.org/forums/topic/php-fatal-error-class-wp_ajax_upgrader_skin
I was using the 4.9.5 and after updating to 4.9.6 it worked for me. I am would like the developers to check the issue and understand the problem and build an error message for it

  • Adam Czajczyk
    • Support Gorilla

    Hello Dominique

    I hope you're well today and thank you for your question!

    The "WP_Ajax_Upgrader_skin" was implemented for the first time in WordPress 4.6 and is there since that release. In this case the error you were getting seems to be a result of some additional underlying issue rather than the main cause of the problem with updates.

    I understand that updating WordPress solve that but since I wasn't able to replicate the problem with 4.9.5 WP (and in fact some previous versions as well) on my test setups, I assume that it might be related to something specific to either setup of this particular site or to the server.

    I'd be happy to investigate it further but for this I would need to be able to do this in that very specific environment where you experienced it. Would you be able to setup a staging site on your server and provide me with access to it? Ideally, it would be site of the same setup that your current live site but based on WP 4.9.5 in a configuration such as the one showing the error and the issue in question. That would help us diagnose the issue and improve our code.

    Kind regards,
    Adam

    • Dominique
      • Recruit

      Yes, I can use it normally.

      There's another problem with the theme (Pindol) which downgrades the WordPress version somehow. WordPress 4.9.6 is installed, but it shows version 4.9 at the moment. I've notified the developer of the theme and they should be working on an update.

  • Predrag Dubajic
    • Support

    Hi Dominique,

    Since support access is still open I had a quick look at the backend and the information there, it seems that the issue is only with the last number actually being hidden from the WP info, so you do have the latest version properly installed, it's just that it doesn't show the .6 part.

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.