wp_remote_get issue on new install using Avada theme

Hi folks, quick question. I've not run into this before so thought this might be the best venue to ask.

I *am* the hosting provider. Server running CloudLinux with all flavors of PHP, curl is in fact enabled. This is one of my new installs of WP (4.2.4) and using the Avada theme. Under the themes "system status" everything has been configured and accepted, with one exception.... wp_remote_get.

I've got literally hundreds of sites hosted on the server using WP and never had this before, for myself or any customers (luck? maybe.... not sure). The notification is in the attached image.

I have checked to ensure that cURL is actually enabled on each and every version of PHP, and it is, no issues. I can also run command line cURL commands without problems. What is missing here? How can this be fixed? I'm sure if its happening with me, it must be happening with other customers as well!?

Thanks in advance :slight_smile:

  • Tyler Postle

    Hey Matt,

    Hope your day is going well!

    This is actually first time I've seen this question here :smiley: it does look like more of a system admin question though. After doing some research I see in most cases it is related to cURL not being active as you alluded too. Have you tried dropping to an older version of PHP such as 5.5 or 5.4 to see if it's related to the PHP version?

    Doing a plugin conflict check might be worth it too. Especially if it's working on your other sites, will need to narrow down whats different about this one in particular.

    I'd recommend asking the Avada support team as well just in-case :slight_smile: let me know if you have further questions! Sorry I don't have an exact solution for you here.

    Cheers,
    Tyler

  • Matt

    Yes, I've actually tried to use 5.2, 5.3, 5.4, 5.5 and 5.6 - my servers run CloudLinux with the PHP Selector which allows complete customization of the PHP extensions and settings from within cPanel. I have actually contacted them and they tell me, as I mentioned, "its a configuration problem". I'm really disappointed in their support with that aspect, however, I will give the plugin conflict test and see what results I get in that. If you do think of anything (or anyone else) - any response is greatly appreciated :wink:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.