WpHUmmingbird plugin is not working

Hi,

When we try to install wp-hummingbird plugin it is showing an error.

Parse error: syntax error, unexpected T_FUNCTION, expecting ')' in /home/content/39/7466839/html/themarketinggroupinc/clients/wsc/wp-content/plugins/wp-hummingbird/core/modules/class-module-minify.php on line 536

Please let us know what is the fix.

Thanks

  • Denitsa

    Hello TMG,
    I hope you are having a fantastic day and thanks for posting here!

    It surely looks like an old PHP version that is no longer supported causing this error.

    What is your current PHP version (if you're unsure, you can check via the WPMU DEV Dashboard -> Support -> System info -> PHP)?

    If it's under 5.6, I'd advise to ask your webhost to update your PHP to a minimum of 5.6 here. Good news is, this will improve security & overall speed of your site, plus older versions of PHP are at their end of life, which means they're no longer supported and you're probably in for future problems with your WordPress install (bummer ).

    You can see more about current WP requirements here on this useful page:
    https://wordpress.org/about/requirements/. You can notice they suggest getting PHP 7+ for best results.

    Tell me how this works for you!

    All the best,
    Denitsa