WPML and domain mapping

Hello,

I am using WPML to tranlate my site. I have subsite which has a mapped domain. When I create translation pages with WPML, they are not directing properly. As far as I see in their forums, this is a common problem. However when I change the name of the site to the mapped domain from Super Admin>>Sites, the direction problem is going away. However this time, some of the links in the mapped subsite directs to the main site witht he following warning

Greetings Site Administrator! You are currently allowing “none” registrations. To change or disable registration go to your Options page.

Registration has been disabled.

When I change register settings, nothing changes. How can I make domain mapping and WPML work together.

Thanks

  • Kimberly
    • Champion of Loops

    Hey There!

    I don’t know if you seen this already, but it seemed worth sharing

    Multilingual Site Network with Domain Mapping

    I do see that there is some history of our domain mapping plug-in not playing nicely with WPML

    There is some information on the WPML forms with an indication that perhaps someone got it working before. I flagged the developer and leave the link for reference

    http://wpml.org/forums/topic/multisite-domain-mapping-wpml-not-working-properly/

    Best

    Kimberly

  • akasya
    • Flash Drive

    Hi Kimberley,

    Thanks for your help. I have seen those links and many more similar ones in WPML forums and tried all sorts of things, but couldnt solve this problem.

    Actually only way to solve the problem so far is to change the name of the site to the url of the mapped domain from Super Admin>>Sites, then the direction problem is going away. However this time, some of the links in the mapped subsite directs to the main site with he following warning

    Greetings Site Administrator! You are currently allowing “none” registrations. To change or disable registration go to your Options page.

    Registration has been disabled.

    Cant I change the name of the site in Super Admin>>Sites from subdomain.maindomain.com to mappeddomain.com without having this error. If this can be solved, it will actually be enough.

    Thanks

  • Kimberly
    • Champion of Loops

    @akasya

    I’ve asked the lead developer to comment here. From what I have been able to find, our plugin just doesn’t support WPML.

    I will see if he can instead help on this issue:

    Barry,

    “Actually only way to solve the problem so far is to change the name of the site to the url of the mapped domain from Super Admin>>Sites, then the direction problem is going away. However this time, some of the links in the mapped subsite directs to the main site with he following warning

    Greetings Site Administrator! You are currently allowing “none” registrations. To change or disable registration go to your Options page.

    Registration has been disabled.

    Cant I change the name of the site in Super Admin>>Sites from subdomain.maindomain.com to mappeddomain.com without having this error. If this can be solved, it will actually be enough.”

  • aecnu
    • WP Unicorn

    Greetings akasya,

    We have not heard back from you as to the status of this issue.

    If you are still having an issue please let us know so that we may try to get you fixed up as soon as possible by choosing to check mark this ticket as unresolved below and posting any new errors or symptoms you are noticing.

    This action will also bring your ticket up front back in plain view again within the ticket system.

    Thank you for being a WPMU Dev Community Member!

    Cheers, Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.