wpmu 2.8.4a with buddypress 1.0.3 compatible?

Has anyone installed wpmu 2.8.4a with Buddypress 1.0.3 yet? Aren't they compatible? I mean buddypress 1.0.3 and all of its components work with wpmu 2.8.4a? If the theme is not working, then wpmudev.org's buddypress themes should be OK right? Thanks...