WPMU Academy - WordPress Development for Beginners

I am becoming more and more frustrated with this course, which is full of inconsistencies and incomplete information.
I have just spent an hour trying to resolve the problem outlined below
In the week 3 tutorial it states:

I recommend creating a local test server. Here’s how to do it:

First, download and install Virtualbox and Vagrant. Create a directory anywhere on your computer to store your project files. I have a “websites” folder in my user directory, in which I’ve created a “phptutorial” directory. I’ll refer to this as the “main project directory” throughout the rest of this tutorial.

Once you created the directory, open the terminal on Linux or OSX, or the command prompt on Windows, and navigate to the folder. If you have created the same folder structure as I have, you can type cd ~/websites/phptutorial on Linux or OSX. On Windows, you can type cd %HOMEPATH%/websites/phptutorial. Once in the correct directory, paste the following command:

curl -L -o 'install.sh' http://bit.ly/1hBfq57 && curl -L -o 'Vagrantfile' http://bit.ly/1mE3Qt9 && vagrant up
view raw
localserver.sh hosted with ? by GitHub

I have downloaded Vagrant and Virtualbox, but just csnnot create the directory “phptutorial” directory

There are no instruction on how to create the directory.

I hace created afolder in my user directory as it suggests, but can not find any means of creating directory within a folder.

I tried creating a folder within the folder but then the cd command failed

Can someone please help. I have had use teh ganeral support ticket as none of my contributions on the fisrt two weeks have been responded to.

I use windows10

  • Adam Czajczyk

    Hello Paul,

    I hope you're well today and thank you for your question!

    I'm not sure if I properly understood the real nature of the troubles that you are experiencing, so in case what I say was to basic and didn't address your question fully - let me know please and I'll follow up.

    The "cd" command assumes that you created both these folders inside your "home" directory (C:disappointed:users/your_user_name/). If it's in another location, you may need to either skip the

    %HOMEPATH%

    part or replace it with other location.

    For example:

    - I created folders on my external drive that's using letter F
    - First directory is named "mysites"
    - And the directory inside is named "phptuts"
    - as a result full path is "F:\mysites\phptuts"

    In this case in a command prompt I need to issue two commands (listed below, each one followed by hitting "enter"):

    F:

    cd mysites/phptuts

    Depending on where did you create these folders, your commands may also vary a bit. Names of these folders doesn't really matter much as long as you keep track of "what is what".

    Kind regards,
    Adam

  • Paul Yates

    Adam,
    Thanks for your very prompt response. As you can tell I am not a windows geek. I am exepert in how to use a computer (Word. Excel, PowerPoint, and all of the rest.
    Neither am I a website developer, I would classify myself as a website designher, but I need o complete these courses to understand what gows on underneath, and have a need to use MYSQL, PHP, Multisite - I already have a limited working knowledge of css and html)

    I have placed my folder under C:\Users\User
    I dont have any named users on my PC (Windows 10)

    My folder is called Website Tutorial

    But when try your command line I get the follwing error

    Microsoft Windows [Version 10.0.14393]
    (c) 2016 Microsoft Corporation. All rights reserved.

    C:\Users\User>%HOMEPATH%/Website tutorial/phptutorial
    '\Users\User' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User>

    Your tutorial suggest that there is a step before the homepath ommand line to create a directory within Website Tutorial, but I cant find any windows featute that enables the creation of a directory.

    I have not even got to First steps yet and it has taken me three hours, albeit, this includes creating Vagrant and Virtualbox

    Just as an aside could you also explain how to make Atom my default code editor. I cant find any information on this but this is what you recommended in week 2. Tim
    Thankyou again

    Paul Yates

  • Paul Yates

    Adam,

    Given that I have not has a response to my last email, I have tried various things and succeeded in creating the directory.

    I did this by creating phptutorials firstly by using the create new folder, and then issuing the cd command, which worked.

    Your tutorial does not mention using the create folder commannd, only create directory, which was why I was confused.

    Howevr the next step failed, the curl bit.

    Here is the error message

    Microsoft Windows [Version 10.0.14393]
    (c) 2016 Microsoft Corporation. All rights reserved.

    C:\Users\User>cd %HOMEPATH%/Website Tutorial/phptutorial

    C:\Users\User\Website Tutorial\phptutorial>curl -L -o 'install.sh' http://bit.ly/1hBfq57 && curl -L -o 'Vagrantfile' http://bit.ly/1mE3Qt9 && vagrant up
    'curl' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Website Tutorial\phptutorial>

    So, I still in desparate need of help.

    Will I have to wait another day?

  • Predrag Dubajic

    Hi Paul,

    Glad to hear you managed to make some progress, based on the latest error it seems that cURL is not installed, you can check the guide here on how to install it:
    http://stackoverflow.com/questions/28736666/curl-not-recognized-as-an-internal-or-external-command-operable-program-or-batc

    I would also suggest checking if you have Visual C++ and OpenSSL installed and if not install them as well.

    Best regards,
    Predrag

  • Paul Yates

    Hi - I am really getting more and more frustrated with installing cURL. I downloaded

    Win32 zip 7.51.0 binary SSL SSHMarc Hörsken
    from libcurl

    I unzippid it, followed the instructions to the letter and I just csny get past the bit wher you run the command mingw32-make mingw32-c++

    It just keeps saying that it cant find mingw32-make file

    Even though I have placed the components into a folder in C: and run the command from there

    I have tried lots of permutations

    The problem is that the instructions do not tell you how to overcome problems. They assume it all works prefectly.

    Is there an easier, foolproof way to acheive the installation of cURL?

    Could I or example use the cURL files that come with Vagrant

    Its now 1.41 in the morning and I started on this at 9.30 this morning, so not happy.

    I am five days into week 3 and have not even started on the coursework yet - just failing miserably to build all teh required comonents

  • Dimitris

    Hey there Paul Yates,

    hope you're doing good and don't mind chiming in! :slight_smile:

    It just keeps saying that it cant find mingw32-make file

    Inside the instructions file in the downloaded curl folder (curl-7.5.1.0/docs/INSTALL.md) or here, it states:

    Make sure that MinGW32's bin dir is in the search path, for example:
    set PATH=c:\mingw32\bin;%PATH%

    In order to set the path to recognize the "mingw32" command, use the instructions here for Windows 10:
    https://www.java.com/en/download/help/path.xml

    An alternative could be to use the Download Manager as described here
    http://stackoverflow.com/a/16216825/3139513

    Warm regards,
    Dimitris

  • Paul Yates

    IT gets worse.
    XAMPP which I had successfully downloaded and installed is no longer working. The dashboard is not picking up the port data. Also when I click on http://localhost/wp/wp-admin/index.php in my browser, it cant find it anymore, but this was also working.
    Also both XAMPP and Vagrant, both of which you recommend installing in the course, both seem to include all of the necessary curl files and curl exe. Why would I need to download and install from an external source, which is what you recommended, if all of the nuts and bolts are already there?

  • Paul Yates

    I did set the path correctly, just as specified.
    As I said I followed the instructions to the letter
    Also, I did not get and email telling me you had responded, so have been twiddling my thumbs all day, getting more and more frustrated. ( It has just arrived late, as if by magic)
    I have anothe week's course to do after this one, and cant until these problems have been resolved, and there will another week released tomorrow, so I will then have three weeks to do all at once.

    • Dimitris

      Hey there Paul,

      I'm deeply sorry for the frustration here, me and my colleagues are doing our best to assist you here. It also seems that we posted simultaneously and I didn't get the latest reply.

      I did set the path correctly, just as specified.
      As I said I followed the instructions to the letter

      Did you manage to complete the installation steps?
      What's the progress so far? Are there any new messages/errors?

      Please advise!
      Dimitris :slight_smile:

  • Dimitris

    Hey,

    seems that we cross-posted here!

    XAMPP which I had successfully downloaded and installed is no longer working. The dashboard is not picking up the port data. Also when I click on http://localhost/wp/wp-admin/index.php in my browser, it cant find it anymore, but this was also working.

    This could be happening due to some port conflicts, try to redirect your XAMPP instance to a different port and check again.
    Here's a how-to guide http://stackoverflow.com/a/21914920/3139513

    About the VVV installation, please proceed with the instructions in my previous reply. :slight_smile:

    Warm regards,
    Dimitris

  • Paul Yates

    Just a few questions I need answering before I continue:

    I am going to start from scratch again by downloading adifferent curl package. The fisrt one I tried just could not getpast the "mingw-make not found" problem, which is a problem that has been reported hundreds of times on various blogs.

    The second one I tried did not even have a mingw-make file, so I am binning that

    One question that I asked and that no one has answered is whether I need to download a package or just use the Curl files in XAMPP or even Vagrant. Could you please advise

    The XAMPP issue is definitely a port issue, as ever since I set the portto 80, 443, I hav received warings that scan to computer no longer working

    THe link that you provided says replace 80, 443 with 8012, but does not state if ther should be a comma and another value. Could you please advise

    Lastly, I also asked the question how do you make Atom your default editor. Given that WPMU have recommended Atom in the tutorial, could you advise how it can be automatically activated for my computer/browser
    It seems to be browser based rather than .exe so it is is dfficult to assign it as a default program

    THanks

  • Dimitris

    Hey there Paul Yates,

    hope you're doing good today!

    One question that I asked and that no one has answered is whether I need to download a package or just use the Curl files in XAMPP or even Vagrant. Could you please advise

    The "curl" command has to be used in order to download and setup VVV to your system.
    This has to be properly installed as described here https://curl.haxx.se/docs/install.html and it's outside the scope of XAMPP or VVV.

    As you're on Windows, there's an alternative installation as described here
    https://github.com/Varying-Vagrant-Vagrants/VVV/wiki/VVV-on-Windows
    using the Chocolatey package manager. Please keep in mind that this is an alternative path for the whole VVV install, not for the curl command.

    THe link that you provided says replace 80, 443 with 8012, but does not state if ther should be a comma and another value. Could you please advise

    The "80, 443" states two different ports. Port 80 is used for http:// calls, while port 443 is used for secured protocol https://. Reference: http://httpd.apache.org/docs/current/bind.html#protocol

    Feel free to replace both, 80 with 8012 and 443 with 433.

    Lastly, I also asked the question how do you make Atom your default editor. Given that WPMU have recommended Atom in the tutorial, could you advise how it can be automatically activated for my computer/browser
    It seems to be browser based rather than .exe so it is is dfficult to assign it as a default program

    I can see that this should have been resolved by now. https://github.com/atom/atom/pull/10818

    Isn't Atom in your choices whenever you right click on a document and click on "open with" option?
    You should also select "Always use this app to open files".

    Here's a executable file to set Atom as the default application for text files on Windows
    https://github.com/JacobDB/atom-launcher

    Warm regards,
    Dimitris

  • Paul Yates

    Hi I need some more help please

    I have overcome teh port conflict problem by usng 8012 and 433, rather thgan 80 and 443

    However, I can no longer access local host, but can access localhost:8012

    This means that cant access wp, but it was working ok on Localhost before the port conflict arose.

    I have followed the instructions in http://stackoverflow.com/questions/11294812/how-to-change-xampp-apache-server-port/21914920#21914920

    i.e.

    4. Configure XAMPP Apache server settings

    If your want to access localhost without specify the port number in the URL
    http://localhost instead of http://localhost:8012.

    Open Xampp Control Panel
    Go to Config ? Service and Port Settings ? Apache
    Replace the Main Port and SSL Port values ??with those chosen (e.g. 8012 and 8013).
    Save Service settings
    Save Configuration of Control Panel
    Restart the Apache Server

    THere must be something else need to do - please advise

  • Paul Yates

    Now another problem

    The good news is that I have now successfully created cURL

    THe bad news is that when I issue teh command:

    curl -L -o 'install.sh' http://bit.ly/1hBfq57 && curl -L -o 'Vagrantfile' http://bit.ly/1mE3Qt9 && vagrant up

    It starts to and runs for about a minute and then fails with

    C:\Users\User>cd %HOMEPATH%/websites/phptutorial

    C:\Users\User\websites\phptutorial>curl -L -o 'install.sh' http://bit.ly/1hBfq57 && curl -L -o 'Vagrantfile' http://bit.ly/1mE3Qt9 && vagrant up
    % Total % Received % Xferd Average Speed Time Time Time Current
    Dload Upload Total Spent Left Speed
    100 196 100 196 0 0 49 0 0:00:04 0:00:04 --:--:-- 49
    100 991 100 991 0 0 218 0 0:00:04 0:00:04 --:--:-- 66066
    % Total % Received % Xferd Average Speed Time Time Time Current
    Dload Upload Total Spent Left Speed
    100 197 100 197 0 0 899 0 --:--:-- --:--:-- --:--:-- 899
    100 460 100 460 0 0 754 0 --:--:-- --:--:-- --:--:-- 754
    A Vagrant environment or target machine is required to run this
    command. Run vagrant init to create a new Vagrant environment. Or,
    get an ID of a target machine from vagrant global-status to run
    this command on. A final option is to change to a directory with a
    Vagrantfile and to try again.

    C:\Users\User\websites\phptutorial>curl -L -o 'install.sh' http://bit.ly/1hBfq57 && curl -L -o 'Vagrantfile' http://bit.ly/1mE3Qt9 && vagrant up
    % Total % Received % Xferd Average Speed Time Time Time Current
    Dload Upload Total Spent Left Speed
    100 196 100 196 0 0 894 0 --:--:-- --:--:-- --:--:-- 894
    100 991 100 991 0 0 1546 0 --:--:-- --:--:-- --:--:-- 1546
    % Total % Received % Xferd Average Speed Time Time Time Current
    Dload Upload Total Spent Left Speed
    100 197 100 197 0 0 965 0 --:--:-- --:--:-- --:--:-- 965
    100 460 100 460 0 0 774 0 --:--:-- --:--:-- --:--:-- 774
    'vagrant' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\websites\phptutorial>

    Between the first failure and the second I moved Vadrant to the same directory level as websites.phptutorial i.e users/user

  • Dimitris

    Hey there Paul Yates,

    hope you're doing good today! :slight_smile:

    About the XAMPP issue, this kind of conflict you experienced may be coming from the Win installation rather than the VVV instance. Could you please try to follow the instructions given in this blog post https://premium.wpmudev.org/blog/setting-up-xampp/ under the "Fixing Port Errors" section? This way you may revert back to Apache's port 80 so your WP installation should be reachable again.

    About the VVV installation, the latest error indicates that the "vagrant" command isn't available so you may have to set a PATH system variable as described here https://www.java.com/en/download/help/path.xml.

    Warm regards,
    Dimitris

  • Paul Yates

    OK,
    I have set the ports back to 80, 443 which is what they were before I had problems accessing local host.
    WPMU told me this was due to a port conflict and that I needed to chane them to 8012, 433.
    So letssee what happens

    However I am still having problem with the run command

    curl -L -o 'install.sh' http://bit.ly/1hBfq57 && curl -L -o 'Vagrantfile' http://bit.ly/1mE3Qt9 && vagrant up

    % Total % Received % Xferd Average Speed Time Time Time Current
    Dload Upload Total Spent Left Speed
    100 196 100 196 0 0 659 0 --:--:-- --:--:-- --:--:-- 697
    Warning: Failed to create the file 'install.sh': Permission denied
    100 991 100 991 0 0 1668 0 --:--:-- --:--:-- --:--:-- 1668
    curl: (23) Failed writing body (0 != 991)
    curl: (6) Could not resolve host: &&
    curl: (6) Could not resolve host: curl
    # -*- mode: ruby -*-
    # vi: set ft=ruby :

    # Vagrantfile API/syntax version. Don't touch unless you know what you're doing!
    VAGRANTFILE_API_VERSION = "2"

    Vagrant.configure(VAGRANTFILE_API_VERSION) do |config|
    config.vm.box = "precise64"
    config.vm.box_url = "http://files.vagrantup.com/precise64.box"
    config.vm.network :private_network, ip: "192.168.33.21"
    config.vm.provision :shell, :path => "install.sh"
    config.vm.synced_folder ".", "/var/www"
    end
    curl: (6) Could not resolve host: &&
    curl: (6) Could not resolve host: vagrant

    I did run command:

    C:\Users\User>cd %HOMEPATH%/websites/phptutorial

    C:\Users\User\websites\phptutorial>

    And Hashicorp\Vagrant is in the same folder as phptutorial

    so more help needed please

    this could be the last step

  • Paul Yates

    apologies for confusing you, I should have done a command prompt, but it still does not work

    C:\Users\User>curl -L -o 'install.sh' http://bit.ly/1hBfq57 && curl -L -o 'Vagrantfile' http://bit.ly/1mE3Qt9 && vagrant up
    % Total % Received % Xferd Average Speed Time Time Time Current
    Dload Upload Total Spent Left Speed
    100 196 100 196 0 0 697 0 --:--:-- --:--:-- --:--:-- 697
    100 991 100 991 0 0 1474 0 --:--:-- --:--:-- --:--:-- 1474
    % Total % Received % Xferd Average Speed Time Time Time Current
    Dload Upload Total Spent Left Speed
    100 197 100 197 0 0 899 0 --:--:-- --:--:-- --:--:-- 899
    100 460 100 460 0 0 736 0 --:--:-- --:--:-- --:--:-- 736
    'vagrant' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User>cd %HOMEPATH%/websites/phptutorial

    C:\Users\User\websites\phptutorial>curl -L -o 'install.sh' http://bit.ly/1hBfq57 && curl -L -o 'Vagrantfile' http://bit.ly/1mE3Qt9 && vagrant up
    % Total % Received % Xferd Average Speed Time Time Time Current
    Dload Upload Total Spent Left Speed
    100 196 100 196 0 0 834 0 --:--:-- --:--:-- --:--:-- 834
    100 991 100 991 0 0 1862 0 --:--:-- --:--:-- --:--:-- 1862
    % Total % Received % Xferd Average Speed Time Time Time Current
    Dload Upload Total Spent Left Speed
    100 197 100 197 0 0 899 0 --:--:-- --:--:-- --:--:-- 899
    100 460 100 460 0 0 893 0 --:--:-- --:--:-- --:--:-- 14838
    'vagrant' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\websites\phptutorial>

  • Dimitris

    Hey there Paul,

    hope you're doing good today! :slight_smile:

    I think we should make a step back here and check couple of things, as I can't provide any more in-depth support here. Feel free to advise our Jobs & Pros section if you wish though, for hiring a specialist to set this up for you. Now, back to necessary steps:

    1. Check if Vagrant is indeed installed. This means a vagrant.exe (or .com, or .bat or whatever win used) binary file somewhere in your system.
    Supposetly, Vagrant is installed in C:\Users\User\vagrant (this is just for example, you should locate the appropriate one in your end)
    To confirm this, open a terminal, go to the path with
    cd %HOMEPATH%/vagrant
    "vagrant" command should now show you some usage info, just type
    vagrant

    If Vagrant isn't properly installed, download the installer here https://www.vagrantup.com/downloads.html
    and check which is the vagrant path

    2. Check that vagrant path of that file is added to Windows PATH variable.
    Until now, the "vagrant" command in terminal will be available only if your current path is C:\Users\User\. Everywhere else will cause an unknown command error message.
    This path where "vagrant" is available is important for us as it should be set in the global Windows PATH, so the "vagrant" command in your terminal will be available under every current path.
    To do so please follow the instructions found here for your Windows version. https://www.java.com/en/download/help/path.xml

    If these two steps are done successfully, then restart once and continue the course tutorial.
    curl -L -o 'install.sh' http://bit.ly/1hBfq57 && curl -L -o 'Vagrantfile' http://bit.ly/1mE3Qt9 && vagrant up

    Warm regards,
    Dimitris

  • Paul Yates

    Dimitri,

    Thankyou for your patience and help.

    I have made some progress. I reinstalled Vagrant, although I thinh it probably was not nessary, as I got exactly the same problems with the new version.

    However I then has a brainwave and moved the vagrant folder out of Users\user\websites\php tutorials into Users \user

    and got rid if its shell folder hashicorps

    and changed the settings for the path in control panel accordingly - restarted, and bingo it worked

    there does nor seem to be any oloic to this, but who cares

    however I now have another problem with the curl command, as follows

    cd %HOMEPATH%/Vagrant/bin

    C:\Users\User>cd %HOMEPATH%/Vagrant/bin

    C:\Users\User\Vagrant\bin>curl -L -o 'install.sh' http://bit.ly/1hBfq57 && curl -L -o 'Vagrantfile' http://bit.ly/1mE3Qt9 && vagrant up
    % Total % Received % Xferd Average Speed Time Time Time Current
    Dload Upload Total Spent Left Speed
    100 196 100 196 0 0 965 0 --:--:-- --:--:-- --:--:-- 965
    Warning: Failed to create the file 'install.sh': Permission denied
    100 991 100 991 0 0 1295 0 --:--:-- --:--:-- --:--:-- 1295
    curl: (23) Failed writing body (0 != 991)

    C:\Users\User\Vagrant\bin>

    I have moved vagrant file and install-sh into users.user

    Any ideas?
    Do I need to create a path in control panel for these?

  • Dimitris

    Hey Paul Yates,

    I just want to assist you the best way possible but as I've said before this is kind of tricky considering this is a local installation. :slight_smile:

    Having said that, the install.sh and Vagrantfile should be in another writable directory as it seems that /Vagrant/bin is denying to write any new files.

    For that you should use a path like before, let's say /Users/user/course where the files should be in place and run the "curl" command like in your previous reply.

    This has the precondition that the path is set correctly to Windows PATH as stated in my previous reply.

    Warm regards,
    Dimitris

  • Paul Yates

    Hi Dimitris

    Thanks again for your help

    I tried waht you suggested - specifying bin was the only way that I could get it to recognise the vagrant command previously

    So I renamed Vagrant (the name of the full folde)r to Vagrantcontrol

    Moved vagrant.exe out of bin and into the Vagrantcontrol root. Vagrantfile is also in there

    But this is now feiling again with vagrant not found - see attachments

    The attachments show you where Vagrantcontrol is situated, what the control panel path is set to and here is the command line error

    C:\Users\User>cd %HOMEPATH%/Vagrantcontrol

    C:\Users\User\Vagrantcontrol>vagrant
    Failed to find Vagrant!

    C:\Users\User\Vagrantcontrol>

    Any more suggestions?

  • Dimitris

    Hi Paul,

    specifying bin was the only way that I could get it to recognise the vagrant command previously

    that's the step that you should have done,

    So I renamed Vagrant (the name of the full folde)r to Vagrantcontrol
    Moved vagrant.exe out of bin and into the Vagrantcontrol root. Vagrantfile is also in there

    and those that you shouldn't, so please try to revert those.

    After doing that, create a new directory like \Users\user\course, open a terminal, navigate into this new created folder and run the "curl" command from course instructions.
    Before that, you can try a simple "vagrant" command to check that's recognizable.

    Take care,
    Dimitris

  • Paul Yates

    Hi Dimitris
    Can you just clarify:

    You want me to rename Vagrantcontrol back to Vagrant
    You want me put vagrant.exe back into Vagrant\bin
    You then want me to create a new folder called Users\User\course

    But what do you want me to out into this course folder?

    I already have a folder called Users\User\websites, which is for the WPMU course work, I did try moving the folder Vagrant into there, but it still did not recognise the vagrant command

  • Dimitris

    Hello Paul,

    that's right, put back the vagrant.exe file so that you have again the ~\Vagrant\bin\vagrant.exe, which should be set in Environment Variables.
    This should ensure that "vagrant" terminal command will be working despite the current path.

    Then use the folder you have already in place to run to "curl" command:

    cd %HOMEPATH%/websites
    
    vagrant
    
    curl -L -o 'install.sh' http://bit.ly/1hBfq57 && curl -L -o 'Vagrantfile' http://bit.ly/1mE3Qt9 && vagrant up

    Cheers,
    Dimitris

  • Paul Yates

    Dimitris, Thankyou for your continued support.

    But I am afriad that it s one step forward and one step backwards.

    I have set environmental variables as you suggested to
    Varaiable vagrant
    Varaible value: C:\Users\User\Vagrant\bin\vagrant.exe

    But when I entered vagrant into the command line it said vagrant not a valid command, etc

    But when I set homepath to cd %HOMEPATH%/Vagrant/bin, it worked

    Which the leaves me withe the dilemma of what homepath to specify for the curl command

    Without setting any homepath I get the following:

    Microsoft Windows [Version 10.0.14393]
    (c) 2016 Microsoft Corporation. All rights reserved.

    C:\Users\User>vagrant
    'vagrant' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User>curl -L -o 'install.sh' http://bit.ly/1hBfq57 && curl -L -o 'Vagrantfile' http://bit.ly/1mE3Qt9 && vagrant up
    % Total % Received % Xferd Average Speed Time Time Time Current
    Dload Upload Total Spent Left Speed
    100 196 100 196 0 0 965 0 --:--:-- --:--:-- --:--:-- 965
    100 991 100 991 0 0 2043 0 --:--:-- --:--:-- --:--:-- 2043
    % Total % Received % Xferd Average Speed Time Time Time Current
    Dload Upload Total Spent Left Speed
    100 197 100 197 0 0 899 0 --:--:-- --:--:-- --:--:-- 899
    100 460 100 460 0 0 980 0 --:--:-- --:--:-- --:--:-- 1965
    'vagrant' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User>

    I have been here before, if you remember but setting the homepath to cd %HOMEPATH%/Vagrant/bin,caused curl command to fail

    Also you have not told me what I need to place in the folder website. Could you please explain

  • Dimitris

    Hey Paul,

    you should leave the executable vagrant file in original position like
    C:\Users\User\Vagrant\bin\vagrant.exe
    and set the environment path variable like
    C:\Users\User\Vagrant\bin

    I have been here before, if you remember but setting the homepath to cd %HOMEPATH%/Vagrant/bin,caused curl command to fail

    In your lastest messages when you run the "curl" command indicate that download is proceeding successfully and "vagrant" command is the broken part. Could you please give that another try?

    On a sidenote, here you can see (if not already) the "Using Vagrant to Set up a WordPress Test Environment" blog post by Daniel Pataki.
    https://premium.wpmudev.org/blog/vagrant-wordpress-test-environment/

    Daniel also informed me that there's no specific reason to use Vagrant for your local installation and development of the course, and any other setup like MAMP or XAMPP should be fine.

    Warm regards,
    Dimitris

  • Paul Yates

    it got further this time, but lots of error messages:

    Could you ask Daniel whather I can use my siteground wordpress testsite instead.? This would save all the bother.

    Or if I use XAMPP what are the eqivalent derecoroes and files to Vagrant that I would need to use?

    C:\Users\User\Vagrant> 'vagrant' is not recognized as an internal or external command,
    ''vagrant'' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant> operable program or batch file.
    'operable' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant>
    C:\Users\User\Vagrant> C:\Users\User>
    The syntax of the command is incorrect.
    C:\Users\User\Vagrant>
    C:\Users\User\Vagrant> I have been here before, if you remember but setting the homepath to cd %HOMEPATH%/Vagrant/bin,caused curl command to fail
    'I' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant>
    C:\Users\User\Vagrant> Also you have not told me what I need to place in the folder website. Could you please explain
    'Also' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant> Wed Nov 23 2016, 6:33:40 PM
    'Wed' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant> (0) Reply
    Reply was unexpected at this time.

    C:\Users\User\Vagrant> Dimitris
    'Dimitris' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant> Support Star
    'Support' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant> 406 pts 1,904 pts LEVEL 11
    '406' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant>
    C:\Users\User\Vagrant> Hey Paul,
    'Hey' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant>
    C:\Users\User\Vagrant> you should leave the executable vagrant file in original position like
    'you' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant> C:\Users\User\Vagrant\bin\vagrant.exe
    Usage: vagrant [options] <command> [<args>]

    -v, --version Print the version and exit.
    -h, --help Print this help.

    Common commands:
    box manages boxes: installation, removal, etc.
    connect connect to a remotely shared Vagrant environment
    destroy stops and deletes all traces of the vagrant machine
    global-status outputs status Vagrant environments for this user
    halt stops the vagrant machine
    help shows the help for a subcommand
    init initializes a new Vagrant environment by creating a Vagrantfile
    login log in to HashiCorp's Atlas
    package packages a running vagrant environment into a box
    plugin manages plugins: install, uninstall, update, etc.
    port displays information about guest port mappings
    powershell connects to machine via powershell remoting
    provision provisions the vagrant machine
    push deploys code in this environment to a configured destination
    rdp connects to machine via RDP
    reload restarts vagrant machine, loads new Vagrantfile configuration
    resume resume a suspended vagrant machine
    share share your Vagrant environment with anyone in the world
    snapshot manages snapshots: saving, restoring, etc.
    ssh connects to machine via SSH
    ssh-config outputs OpenSSH valid configuration to connect to the machine
    status outputs status of the vagrant machine
    suspend suspends the machine
    up starts and provisions the vagrant environment
    version prints current and latest Vagrant version

    For help on any individual command run vagrant COMMAND -h

    Additional subcommands are available, but are either more advanced
    or not commonly used. To see all subcommands, run the command
    vagrant list-commands.

    C:\Users\User\Vagrant> and set the environment path variable like
    'and' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant> C:\Users\User\Vagrant\bin
    'C:\Users\User\Vagrant\bin' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant>
    C:\Users\User\Vagrant> I have been here before, if you remember but setting the homepath to cd %HOMEPATH%/Vagrant/bin,caused curl command to fail
    'I' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant>
    C:\Users\User\Vagrant> In your lastest messages when you run the "curl" command indicate that download is proceeding successfully and "vagrant" command is the broken part. Could you please give that another try?
    'In' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant>
    C:\Users\User\Vagrant> On a sidenote, here you can see (if not already) the "Using Vagrant to Set up a WordPress Test Environment" blog post by Daniel Pataki.
    'On' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant> https://premium.wpmudev.org/blog/vagrant-wordpress-test-environment/
    'https:' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant>
    C:\Users\User\Vagrant> Daniel also informed me that there's no specific reason to use Vagrant for your local installation and development of the course, and any other setup like MAMP or XAMPP should be fine.
    'Daniel' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant>
    C:\Users\User\Vagrant> Warm regards,
    'Warm' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant> Dimitris
    'Dimitris' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant> Rate my support
    'Rate' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant> Fri Nov 25 2016, 10:29:17 AM
    'Fri' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant> Give points (0) Reply
    'Give' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant>
    C:\Users\User\Vagrant>This support topic is Open
    'This' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant>Mark as Resolved
    'Mark' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant>Unsubscribe from This Topic
    'Unsubscribe' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant>FREE WordPress Tutorials, Tips and Tricks
    'FREE' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant>WPMU DEV Plugins
    'WPMU' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant>Plugins
    'Plugins' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant>
    C:\Users\User\Vagrant> Hummingbird
    'Hummingbird' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant> Defender
    'Defender' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant> Hustle
    'Hustle' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant> Snapshot
    'Snapshot' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant> More...
    'More...' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant>
    C:\Users\User\Vagrant>Upfront Themes
    'Upfront' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant>Themes
    'Themes' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant>
    C:\Users\User\Vagrant> Upfront Builder
    'Upfront' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant> Spirit
    'Spirit' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant> Luke & Sara
    'Luke' is not recognized as an internal or external command,
    operable program or batch file.
    'Sara' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant> Parrot
    'Parrot' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant> More...
    'More...' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant>
    C:\Users\User\Vagrant>WPMU DEV Resources
    'WPMU' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant>Resources
    'Resources' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant>
    C:\Users\User\Vagrant> 24/7 Support
    '24' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant> Academy
    'Academy' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant> Member Community
    'Member' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant> Jobs & Pros
    'Jobs' is not recognized as an internal or external command,
    operable program or batch file.
    'Pros' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant> The WhiP
    'The' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant>
    C:\Users\User\Vagrant>WPMU DEV Blog
    'WPMU' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant>Blog
    'Blog' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant>
    C:\Users\User\Vagrant> How I Built a Kick-Ass WordPress Theme With Upfront Builder (And Why I’m Freaking Out)
    'How' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant> How to Customize the WordPress Multisite Activation Email with a Plugin
    'How' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant> How to Code Your Own Custom WordPress Widget
    'How' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant> More...
    'More...' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant>
    C:\Users\User\Vagrant>

  • Paul Yates

    Please ignor the previous post - I pastd a load of erroneous command prompt stuff

    Howver, I did what you suggeste and No difference than before

    I first set up environmental varaibles to your suggestion and restarted

    Could you ask Daniel whather I can use my siteground wordpress testsite instead.? This would save all the bother.

    Or if I use XAMPP what are the eqivalent derecoroes and files to Vagrant that I would need to use?

    Heres what I did

    Microsoft Windows [Version 10.0.14393]
    (c) 2016 Microsoft Corporation. All rights reserved.

    C:\Users\User>cd %HOMEPATH%/Vagrant

    C:\Users\User\Vagrant>vagrant
    'vagrant' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\Vagrant>curl -L -o 'install.sh' http://bit.ly/1hBfq57 && curl -L -o 'Vagrantfile' http://bit.ly/1mE3Qt9 && vagrant up
    % Total % Received % Xferd Average Speed Time Time Time Current
    Dload Upload Total Spent Left Speed
    100 196 100 196 0 0 837 0 --:--:-- --:--:-- --:--:-- 837
    0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0Warning: Failed to create the file 'install.sh': Permission denied
    100 991 100 991 0 0 1548 0 --:--:-- --:--:-- --:--:-- 5761
    curl: (23) Failed writing body (0 != 991)

    C:\Users\User\Vagrant>cd %HOMEPATH%/websites

    C:\Users\User\websites>curl -L -o 'install.sh' http://bit.ly/1hBfq57 && curl -L -o 'Vagrantfile' http://bit.ly/1mE3Qt9 && vagrant up
    % Total % Received % Xferd Average Speed Time Time Time Current
    Dload Upload Total Spent Left Speed
    100 196 100 196 0 0 899 0 --:--:-- --:--:-- --:--:-- 965
    100 991 100 991 0 0 1924 0 --:--:-- --:--:-- --:--:-- 1924
    % Total % Received % Xferd Average Speed Time Time Time Current
    Dload Upload Total Spent Left Speed
    100 197 100 197 0 0 841 0 --:--:-- --:--:-- --:--:-- 899
    100 460 100 460 0 0 755 0 --:--:-- --:--:-- --:--:-- 2674
    'vagrant' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\User\websites>

  • Dimitris

    Hey Paul,

    Could you ask Daniel whather I can use my siteground wordpress testsite instead.? This would save all the bother.
    Or if I use XAMPP what are the eqivalent derecoroes and files to Vagrant that I would need to use?

    A working server instance should be fine, either it's a "live" server in Siteground or a local XAMPP. There are no "equivalent" files as these files are the Vagrant server instance itself. :wink:

    Warm regards,
    Dimitris

  • Paul Yates

    Dimitris

    I have decided to use my existing Siteground test site

    But still cant getpast first base

    The main project file is now your root folder. Create an index.html file in there with any content and it should be rendered correctly when you visit your website at http://192.168.33.21.
    First Steps

    First up, let’s look at PHP tags, variables, values, and echoing.

    Create an index.php file in your main project folder and type “Hello HTML” in it. To verify it is working, visit http://192.168.33.21, and you should see the string displayed.

    My question is where do I place the index.php file on my Siteground site, bearing in mind that I use subdomains in the main site, one of which is my live site

    and then how do I test it - what do I do rather than the visit http://192.168.33.21

  • Dimitris

    Hey there Paul,

    instead of using a index.php file you can use another filename like test.php and then navigate to domainname.com/test.php in your browser (there are no local IP addresses any more in our end).

    If you don't have a domain name pointing to the root folder of your server (probably this should be the public_html/ folder) then you could contact SiteGround support channel and they should be able to provide you kind of "temporary domain" based on the IP you're using and your account name, something like "123.456.789.123/~youraccount/".

    Another solution would be to create a new folder under a directory which is already used by another installation and domain, so you could use "another-domain.com/new-folder-name" in your browser.

    Hope that was some help, support team in SG may help you out with this in no time I think.
    Warm regards,
    Dimitris