WPMU Breaks Connections plugin

Everytime I enable WPMU dashboard, or plugins, it breaks my Connections page resulting in a error 500 or "
Fatal error: Unknown: Cannot use output buffering in output buffering display handlers in Unknown on line 0" depending on which I have activated. How can we fix this?

  • splaquet
    • The Incredible Code Injector

    Did this just start happening recently for you?

    I've been having similar experiences on some accounts, but it appears to be inconsistent for me. As in, some accounts seem completely unaffected. On my end, as far as WPMU plugins, it'd appear to mostly be SmartCrawl causing me grief.

    Although, on a few clients' sites, where they've installed many of their own WordPress repo plugins, I've seen a few other plugins cause 500 errors. Again, renaming the plugin folder to disable the plugin, brought the site back up. My sites mostly use premium and reliable plugins.

    I've had I've been able to bring the site back up by going in via FTP and renaming the SmartCrawl/SEO folder. I'll continue to receive random "Website DOWN" notices from the other sites, but they're usually live when I click the link.

    I've been boggled for about a week or so, and can't quite figure it out.

    My most recent theory is that there's some type of php & database charset conflict happening. With database structures now making a massive switch from Sweedish/Latin -> Utf8 -> Utfmb64, something is bound to break. I've just never really seen it happen in the past.

    Although, the only evidence I have of that is a few, random and inconsistent characters being swapped for others, in the debug.log. I've discovered that when I've compared some of the error references to the characters in the mentioned PHP file code. Ash helped bring that to my attention, then I started noticing it more frequently.

    There's a solid chance that our issues are unrelated. Either way, I look forward to hearing the solution that you come up with. Good luck!

  • Jennai
    • Flash Drive

    As of right now the only problem I'm having is with the Connections plugin. Simply installing the WPMU dashboard kills that page creating an error 500. Installing Smush gives me the other error. There is some conflict between Connections and WPMU. I'm hoping they can help fix it as it's a plugin that is used by a LOT of people (Chambers, etc) and I want to be able to use WPMU on those sites too.

  • Dimitris
    • Support Star

    Hello there Jennai,

    hope you're doing good and I'm really sorry for the issues you're dealing with!

    As of right now the only problem I'm having is with the Connections plugin. Simply installing the WPMU dashboard kills that page creating an error 500.

    Could you please share a URL of this plugin so I can try to replicate this error?
    Also, are you getting this 500 error in a page in /wp-admin/ area or in frontend pages?
    Please advise!

    Installing Smush gives me the other error.

    Is this the other error you're saying?
    Fatal error: Unknown: Cannot use output buffering in output buffering display handlers in Unknown on line 0"

    I gave a try with this one: https://wordpress.org/plugins/connections/
    in a clear WP installation (only using WPMUDEV Dashboard plugin with a default theme and afterwards Smush Pro too, but couldn't replicate any error in backend or frontend pages).

    Could you also please grant temporary support access via WPMUDEV Dashboard plugin to the affected website? No need to share any WP admin credentials. Just navigate in WP admin area under WPMU DEV -> Support page and click on the "grant support access" button. You can find detailed information about it here: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5
    Please do reply back here when access is granted because we don't get any notifications about it.

    Warm regards,
    Dimitris :slight_smile:

  • Jennai
    • Flash Drive

    Good morning (Or evening, whatever time it is there, I hope it's good! lol)

    The errors happen when I attempt to view that page on the web site. I have all of the WPMU stuff disabled and Connections works fine. If I enable, we have those problems.

    As of right now I can have the WPMU dashboard active, analytics through WPMU active and Smush Pro active. The others all cause the 500 error or the other I listed.

    I've granted access. Thank you so much! https://nevadacountybar.com

  • splaquet
    • The Incredible Code Injector

    Jennai , when you say "others", are you implying that every other WPMU plugin crashes your site?

    ...or, are you referring to the standards in the startup pack (dashboard, defender, Smush, hummingbird, snapshot)

    ...or, are you referring to a specific set of WPMU plugins that you have installed? (If this is the case, would you mind sharing which ones on specific?)

    ###

    Side note, but I set up a totally fresh WP install yesterday, using UTF8mb4 as the collation and charset. Everything from WPMU seemed to follow that set, except for a table created by WPMU's Google analytics.

  • Dimitris
    • Support Star

    Hello there Jennai,

    hope you're doing good today! :slight_smile:

    I reviewed the System Info located in WPMUDEV -> Support and noticed that you're using a rather old (slow and unsecured) PHP version (5.5.37).
    I'd rather advise to contact with your hosting provider, in order to upgrade to v.7.0, as it scores much better performance-wise.

    Apart from this, some PHP variables seem to be low too. Could you please follow this article here: https://premium.wpmudev.org/blog/increase-memory-limit/
    in order to increase the following variables to the given values:

    max_execution_time 300
    memory_limit 512M

    Finally, edit wp-config.php file, find a line like
    define('WP_DEBUG', false);and replace it with the following (if the above line doesn’t exist, simply insert next snippet just above the /* That's all, stop editing! Happy blogging. */ comment)

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    @ini_set( 'log_errors', 1 );
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set('display_errors', 0);
    // https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP
    define('WP_MEMORY_LIMIT', '256M');
    define('WP_MAX_MEMORY_LIMIT', '512M');

    Then go ahead and try to replicate the error by enabling one by one our plugins. If the increase of memory limits and max_execution_time didn't do the trick, then you should get the 500 error page once more and a /wp-content/debug.log file should be created. Simply download it, rename it to debug.txt and attach it here in your next reply. If size of text file exceeds the 5MB limit of our blog, please use a service like Dropbox and post the shareable link instead.
    Ref: https://premium.wpmudev.org/blog/debugging-wordpress-how-to-use-wp_debug/

    Warm regards,
    Dimitris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.