WPMU & BuddyPress - How to set a site wide template?!?!? (including sub blogs / domains)

Hi, my name is James and im new to this site and a PHP beginner so please bear with me if I ask some stupid questions, etc... I have been an IT Manager for the past 8 years but when i started the role i built all the sites around table based HTML pages (it was acceptable then :wink:. As time went on I became more of a project and systems manager hence knowing no PHP or scripting languages. I have a good grasp of HTML and CSS and hope with your help I can build a networking site with WPMU and Buddypress...

Ive got quite a few questions but will start of with my first stumbling block...

I originally built the site in standard WP (not MU) and restyled the standard buddypress theme. This all worked fine but I then decided to start from scratch instead using WPMU so I could offer users of the site their own blogging area. I went through the same process of building a child theme so that I could still update the core theme and it would not overwrite my styles/header sheets. But, the main site is working fine and the styles applied but as soon as I got my host to set up the wildcard when I visit the subdomains there is just a blank page. I thought this could be due to an incorrect configuration at their end but if I add ‘/wp-admin’ to the end of the blank page if takes me to the admin area and from there I can select a template and it works fine. So to cut a long story short (sorry, should have done that to begin with) how do I enable universal temples? (or should there be universal ones but as ive deleted all the others and created child theme from the only remaining theme could I have created in wrong folders / directories / links, etc)

Thanks...

  • trailrider
    • WPMU DEV Initiate

    Hi Aaran, thanks for this reponse, how do I 'use your default theme to choose which theme new blogs get' as said at present it is nothing, just a blank page? (could this be becasue I have moved the css styles, header and reigster out of the buddypress theme folder and moved it to the wordpress theme folder?!!?!?)

  • trailrider
    • WPMU DEV Initiate

    This is what im refering to above... ive copied and pasted the theme information from the admin portal below.. I assume for this to work with WPMU the child files have to be set up differently? (I initially follwed single install instructions)
    ------
    (James Theme)
    The template files are located in /themes/james. The stylesheet files are located in /themes/james. 'James Theme' uses templates from BuddyPress Default. Changes made to the templates will affect both themes.
    ------

  • trailrider
    • WPMU DEV Initiate

    Aaran, quick update on this your 'default theme plug-in' rectified this so if others are searching for a solution to this issue installing that plug-in resolved it but im not sure what was actually causing this blank page issue ion the first place (it was template related but that is as far as I got - I found another post saying it's most likely due to the initial setup of WPMU that I would have used www. on the domain but hosted it without the prefix)...

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.