WPMU Dashboard is NOT visible in admin login...

I installed the wpmu dashboard on the holder theme. I then added a new admin user id, logged out of that admin, and logged in as the new admin user I just created.
WPMU Dashboard is missing / not visible. Why?

It is worth noting that I deleted the original admin login as I had neglected to properly name the original admin login userid to something other than 'admin'.

Please advise.
David

  • Joshua
    • Chief of Keepin' it Fresh Div.

    I had this problem as well on a MultiSite install. A bit of searching found this:

    Only the admin user "(your first user)" has access to the WPMU DEV Dashboard plugin and features on this site.

    To change which users can have access to the WPMU DEV Dashboard, place this line in your wp-config.php file with the desired userids:
    define('WPMUDEV_LIMIT_TO_USER', '1'); or
    define('WPMUDEV_LIMIT_TO_USER', '1, 12');

    Hope this helps! (this comes from WPMUDashboard > manage)

  • Patrick
    • Support Monkey

    Hi @dpmedia

    I'm doing a bit of housekeeping by going through some older threads, and I noticed that this one is still open.

    Do you still need assistance on this issue?

    If not, just to get the ticket out of our active system, I'm going to mark it resolved.

    But if you do still need help here, please don't hesitate to re-open the thread by checking the "Mark as not resolved" box below.

    Thanks!

  • technomadia
    • Flash Drive

    This is a very awkward way to do something that should be simple.

    First - I don't see an easy way to tell what the user ID number is for each account. Instructions for figuring this out should be incorporated into the answer.

    Second - it seems like there should be a GUI to enable this - not requiring editing the .php file.

    Personally - I wish the default was that the dashboard was enabled for all users.

    Cheers,

    - Chris

  • Jey Key
    • WPMU DEV Initiate

    Hi, I tried to add user #2 by adding this line to wp-config.php and didn't work.

    I also confirmed with phpmyadmin that user is #2. In wpmu-dashboard -> manage I confirm that plugin says perfectly we both admins have access to the dashboard,

    2nd admin don't see the dashboard in the menu, if I try to paste the URL I get error

    "You do not have sufficient permissions to access this page"

    Any tips ?

    Thanks

  • Patrick
    • Support Monkey

    Hi @Jey Key

    Add the define to your wp-config.php as described above (with the appropriate user IDs of course):

    define('WPMUDEV_LIMIT_TO_USER', '1, 12');

    Then it's important to remember that the plugin will only authorize access to the user(s) who activate it.

    So, the new users you have added to the define must simply deactivate then immediately reactivate the dashboard plugin. This will trigger the new permissions, and they will have full access.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.