WPMU Dashboard not compatible with Sitegrounds Recommended PHP version 7.1

Hi,
I'm am moving all of my sites to this host and of course would like everything futureproofed.

Here is the compatibility report.

FILE: /home/thepho97/public_html/msquaredinc.com/wp-content/plugins/wpmudev-updates/lib/PHPSecLib/Crypt/Random.php
---------------------------------------------------------------------------------------------------------------------------------
FOUND 0 ERRORS AND 4 WARNINGS AFFECTING 2 LINES
---------------------------------------------------------------------------------------------------------------------------------
75 | WARNING | Function mcrypt_create_iv() is deprecated since PHP 7.1; use OpenSSL instead
75 | WARNING | Extension 'mcrypt' is deprecated since PHP 7.1 - use openssl (preferred) or pecl/mcrypt once available instead.
114 | WARNING | Function mcrypt_create_iv() is deprecated since PHP 7.1; use OpenSSL instead
114 | WARNING | Extension 'mcrypt' is deprecated since PHP 7.1 - use openssl (preferred) or pecl/mcrypt once available instead.
---------------------------------------------------------------------------------------------------------------------------------

Thank you

  • Nahid

    Hey msqinc !
    Hope you are having a great day!

    Thank you for your query. The mentioned functions are kept in the plugin for backwards compatibility with older PHP versions. There are a lot of WordPress sites that are being used with older versions of PHP so our developers have to keep that in mind. Regarding the warnings you received in the compatibility report, our developers are working on that to omit those warnings and still keeping it compatible with the older versions of PHP.

    With that said, you can ignore the warning messages and proceed with using the plugin in your site as the mentioned functions will not run in the WPMU DEV Dashboard plugin when it detects newer versions of PHP, e.g. 7 or above. Please report back to us if you find any broken functionality of the plugin in PHP 7.1, if we can replicate the reported issue and and see if it is related to the PHP version, it'll be escalated to the developers and fixed as soon as possible.

    Hope this helps. Let us know if you need any further assistance regarding this. Thanks!

    Kind regards,
    Nahid

  • Nastia

    Hello marge

    Hope all is well!

    Thank you for posting in this thread, however, because this issue is resolved for the original author that has posted it, please create a new one or open a live chat with us. This way, the author will not be getting email notifications each time when there is a new post in the thread.

    All our plugins are compatible with PHP version 7.x. The warning is shown because the plugins include backward PHP compatibility, and the PHP Checker Compatibility plugin is not "smart" enough to detect it. Backward PHP Compatibility is added to our plugins to support all PHP versions, starting from PHP 5.2.

    So feel free to switch to PHP version 7.1 if you have MarketPress plugin active.

    Hope this helps!

    Kind regards,
    Nastia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.