wpmu dashboard wants to update an already updated dashboard

got this in update

WPMU DEV Dashboard
You have version 4.0.3 installed. Update to 4.0.3. View version 4.0.3 details.
Compatibility with WordPress 4.4.1: 100% (according to its author)

Notice the version numbers and all sites are the same.
when you go to update it you get a error page (forgot to copy it)
then if you try again it updates