wpmu dev 3.3 not compatible with wp 3.6 ?

Hi,
I'm trying to make wpmu dev dashboard (ver 3.3) working with WP 3.6, buit it doesn't.
The old version (3.2.5) works perfectly.

It's possible to install 3.2.5 connect to the dashboard and upgrade, but it's not possible to install 3.3 as it's buggy (impossible to connect, I get a strange page without css and working links.

Hope it will help.