WPMU Dev dashboard breaks admin area, updates, etc.

Since a few weeks it's impossible to update, or even view, plugins, themes, or even core on ANY of my sites having the WPMU dashoard installed.
The pages simply don't load, other than the top announcements from you. It's the same on a number of pages, including viewing plugins, viewing themes, and the updates page, preventing me from updating any of my sites.
It's the same on several sites, having different setups, hosted on different servers.
Disabling "wpmu_updates" plugin via ssh makes the pages load again, but then I can't update plugins provided by you.

See the attached screen shot. It looks the same on all pages/sites, but sometimes not even the info after "New WPMU Dev release:" shows - it's just empty after that heading - but sometimes as in the screen shot it stops after showing the info about the plugin you are advertising.

Screenshot

(PS. I had to submit this several times - your web site breaks off communications in the middle of the post!)

  • aristath

    Hello there @poohnix, I hope you're well today!

    Could you please grant me access to your backend so that I may see exactly what is happening?
    To do so, from your dashboard go to WPMUDEV => Support => Support Access and click on the "Grant access" button.

    We'll also need some more information here.
    What host are you using?
    Is this a shared host or a VPS?
    Have you tried setting WP_DEBUG to true in your wp-config.php file?
    Are you using a reverse proxy service like for example CloudFlare?

    Please advise,
    Ari.

  • poohnix

    Hi,

    It happens for all our sites, hosted on various VPS:s and dedicated servers. We don't use CloudFlare or anything like that.
    But I found out something... It doesn't seem to have anything to do with anything on the servers themselves, but with the internet connection *I* use when connecting to them.
    When I'm connected via my "normal" connection - which I always use when developing, and all sites only allow access from that specific IP range an nowhere else - then this error occurs.
    If I allow connection from for example my home connection, and connect that way, then it works as it should,
    So it appears as if *your* system, for *some* services, are blocking that IP range. For reasons unknown.
    You don't block it entirely - I can see the dashboard with no issue for example - but for some things - something needed for those pages to load - you block that IP range. (And it's your system, not mine, which are blocking it, since the pages load fine if I disable your dashboard. Apparently parts of the pages are loaded directly from your system, not via the server.)
    Same thing with this forum. I could view and browse everything, log in to your site and manage my account and whatever, but when I tried to POST to the forum, the post failed, as if your server rejected the packets.
    I don't want to post the IP range here, so how can I give it to you can remove the block?

  • poohnix

    Hi,

    No, unfortunately it's still the same...
    The only page that loads fine is the WPMU DEV Dashboard!
    But all other pages, including the WP dashboard, stops loading right after your advertisement about "New WPMU DEV Release".
    No pages where you put that on top (pretty much everyone of them) load when I use my "normal" connection. (This connection I use now.)
    When I connect using my backup connection (or disable the dashboard plugin), all the pages load fine.

  • Tyler Postle

    Hey poohnix,

    Hope your weekend is going well so far!

    This is bit of an odd situation because the IP ranges that were blocked weren't causing this same issue, it was stopping the dashboard from communicating with our servers here.

    Can you grant support access so I can take a look myself? I know I might not see anything different but want to check just to make sure.

    You can grant support access via admin dashboard - WPMU DEV > Support > Support Access > Grant Access.

    If you dismiss the notices does anything change?

    Look forward to hearing back poohnix!

    Cheers,
    Tyler

  • poohnix

    Ok, I have granted you access to the Barracking site.
    It's the same on all our sites.
    But, as I've said, when accessing from any other IP address, the sites behave as they should, so you will not see the issue I see...
    But if you have any way I can send you a private message, I can give you access through the affected IP range so you can see first hand what happens.
    But I can't post access info here, obviously.

  • aristath

    Hello again @poohnix,

    Can you send me that range of IPs please?
    - Send an email using our secure contact form on https://premium.wpmudev.org/contact/
    - Select "I have a different question" from the dropdown
    - On the subject enter "Attn: aristath".
    - Include the URL of this post in your message so that I may track this issue
    - Include a link to your website
    - Include your IPs range.

    Cheers,
    Ari.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.