WPMU DEV Dashboard lost from menu

Haven't been able to find a useful answer to this... quickest way to get the WPMU DEV Dashboard menu item back into the Admin Menu.

  • Dimitris

    Hey there #Garth,

    hope you're doing good today! :slight_smile:

    Could you please check wp-config.php file for any line like the following?
    define( 'WPMUDEV_LIMIT_TO_USER', '1' );
    The 1 refers to a user ID, so if there's such line in there you can either remove it or use your own ID number.

    If this isn't the case here, please try once more to delete all instances via FTP (proper and renamed folders of WPMUDEV Dashboard plugin) and re-install it as described here.

    If still continues, please try to deactivate all other plugins, revert to a default theme like TwentySeventeen, clear all of the caches involving to your installation (plugins, server side mechanisms, 3rd party services like Cloudflare, clear your browser cache) and test that again. If that resolves it, activate them back one-by-one until you get the conflicted combination.
    https://premium.wpmudev.org/wp-content/uploads/2015/09/Support-Process-Support-Process.gif

    Let us know about your results!
    Warm regards,
    Dimitris

  • #Garth

    a) WPMUDEV_LIMIT_TO_USER is not set
    b) that's the process I followed.
    c) here's what I did...
    I left all WPMUDEV plugins enabled, cleared cache and one by one disabled the other plugins.
    Nothing changed, so I figured I'd disable and then re-enable the WPMUDEV dashboard. It refused to be disabled when I clicked disable, but instead immediately showed up in the menu!!??
    So I re-enabled all the plugins and nothing upset it.

    So... this is how the process panned out:
    - this site was installed and working fine without WPMUDEV Dashboard or Snapshot, Defender, Hummingbird. I installed these after the site was created and working. Of course my problems with these other plugins has been documented elsewhere.
    - the dashboard required an update after it was installed along with the other plugins. it disappeared sometime after that.
    - i tried deactivating and then reactivating it, and while it deactivated and then reactivated, no menu item for it showed.
    - then having deleted the plugin folder and re-installed it and re-updated it again it still would not show.
    - however I didn't click to deactivate it at any time again until I had turned off all the other plugins.

    Some other info about this site:
    It uses a Gavick theme based on the Gavick Pro framework, along with specific plugins, all of which are installed in a Quickstart installer. Gavick's Quickstart installers have never failed me (not once) and their website plugins have all worked reliably, never had an issue with their plugins in relation to install/update or their workings, and I've been working with them for years (only issue I've ever had with *any* of their plugins was the caching of the admin interface in one or two of them which is pretty extensive). I have used all these plugins on a number of other sites, in fact the other 4 sites that are also listed in the WPMUDEV hub include the very same plugins.

    The only other 3 plugins listed on this site are Akismet, Mailpoet (disabled) & Enable Media Replace - never had conflicts from these plugins.

    So my assessment is (for what it's worth)
    - this has nothing to do with other plugins
    - it has everything to do with the way this plugin updates settings in WP
    - it needed to be reinstalled AND deactivated to get it to show

    I'd say it has something to do with the way it is installed and automatically set to active, OR the way it is updated (or the update itself).

    Yet more required plugin diagnosis carried out for WPMUDEV by a user.
    Methinks WPMUDEV would save a heap of support time, and actually be able to keep up with the support tickets, if the major plugins worked reliably. Therein lies the problem with sourcing plugins from many developers and then having to support them.

  • Dimitris

    Hey there #Garth,

    hope you're doing good today! :slight_smile:

    First of all, I'm glad that you've sorted this out. On the other hand, I tried to replicate this locally (without Gavick theme and all plugins that comes with it) but I had no success on that!

    This may was a glitch on the update procedure of WPMUDEV Dashboard plugin indeed, but can't be sure about it. Please keep in mind that our Dashboard plugin is a very crucial part of our business and we constantly care about it! It's never been outsourced or anything like that, and we're really keen on making it as stable as it can get!

    I also understand that this happened only in one of your website, is that right? If that's the case here, and if all of your websites are having the same plugins, then it's safe to conduct that this isn't a conflict.
    But, if you're unsure about it, you can always perform a conflict test as described in a nice flow chart here: https://premium.wpmudev.org/wp-content/uploads/2015/09/Support-Process-Support-Process.gif

    Warm regards,
    Dimitris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.