[WPMU DEV Dashboard] PHP 7.1 and WPMUDEV

This is what I am getting about moving to PHP 7.1
FOUND 0 ERRORS AND 4 WARNINGS AFFECTING 2 LINES
----------------------------------------------------------------------------------------------------------------------------------
75 | WARNING | Extension 'mcrypt' is deprecated since PHP 7.1 - use openssl (preferred) or pecl/mcrypt once available instead.
75 | WARNING | Function mcrypt_create_iv() is deprecated since PHP 7.1; use OpenSSL instead
114 | WARNING | Extension 'mcrypt' is deprecated since PHP 7.1 - use openssl (preferred) or pecl/mcrypt once available instead.
114 | WARNING | Function mcrypt_create_iv() is deprecated since PHP 7.1; use OpenSSL instead
----------------------------------------------------------------------------------------------------------------------------------

Can you help me understand.

  • Predrag Dubajic

    Hey Bill,

    Hope you're doing well today :slight_smile:

    That's the code that's used for the older PHP versions and it's kept in the plugin to assure backward compatibility.
    It also has updated code for the newer PHP versions and the plugin will check PHP version on your site and use the correct code based on that.

    Long story short, above code will not be used on your site since you're running PHP 7.1, and it will use the compatible one instead :slight_smile:

    Let us know if you have any followup questions about this.

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.