WPMU DEV Dashboard plugin conflict with "OnePress Image Elevator" plugin

I use multisite
i deactived all plugins in network and subsites, only network active plugin "WPMU DEV Dashboard", and active "OnePress Image Elevator" plugin in a subsites.

But have error:
"Fatal error: Call to undefined function wp_get_current_user() in /home/69828-54725.cloudwaysapps.com/shtyexsnkr/public_html/wp-includes/capabilities.php on line 448"

Now i cannot access my subsite.

  • Xichy

    error above is when i setup server with php 5.6.

    If i upgrade php 5.6 to php 7, it show error:
    "Fatal error: Uncaught Error: Call to undefined function wp_get_current_user() in /home/69828-54725.cloudwaysapps.com/shtyexsnkr/public_html/wp-includes/capabilities.php:448 Stack trace: #0 /home/69828-54725.cloudwaysapps.com/shtyexsnkr/public_html/wp-content/plugins/wpmudev-updates/includes/class-wpmudev-dashboard-site.php(1498): current_user_can('activate_plugin...') #1 /home/69828-54725.cloudwaysapps.com/shtyexsnkr/public_html/wp-content/plugins/wpmudev-updates/includes/class-wpmudev-dashboard-api.php(1032): WPMUDEV_Dashboard_Site->get_project_infos(3) #2 /home/69828-54725.cloudwaysapps.com/shtyexsnkr/public_html/wp-content/plugins/wpmudev-updates/includes/class-wpmudev-dashboard-site.php(2680): WPMUDEV_Dashboard_Api->calculate_upgrades(Array) #3 /home/69828-54725.cloudwaysapps.com/shtyexsnkr/public_html/wp-includes/plugin.php(235): WPMUDEV_Dashboard_Site->filter_plugin_update_count(Object(stdClass)) #4 /home/69828-54725.cloudwaysapps.com/shtyexsnkr/public_html/wp-includes/option.php(1596): apply_filters('site_transient in /home/69828-54725.cloudwaysapps.com/shtyexsnkr/public_html/wp-includes/capabilities.php on line 448"

    Please help me.

  • Rupok

    Hi 4814, how are you doing today?

    I'm using WPMU DEV Dashboard in my PHP7 instance with hundreds of other plugins, but I didn't face this error. So I assume, "OnePress Image Elevator" is conflicting with our DEV Dashboard plugin. Can you please disable your "OnePress Image Elevator" plugin and check if the errors are still shown?

    Can you please ask "OnePress Image Elevator" developer and let us know what they say about this? There might be something on their coding which is conflicting. Please let us know in details. I'll forward that to our developers to have a look and do what needs to be done from our end.

    Have a nice day. Cheers!
    Rupok

  • sebastien

    Thank you for pointing out that this was due to image elevator. I could get access to my dashboard once this plugin manually deactivated. I'm using PHP 7.1.5 and tried with PHP 5.6 and the issue remains. I will not be able to use image elevator on my multisite.

    On single site install, it seems that there is no conflict.

    Do someone has an alternative or fix?

    Thank you