[WPMU DEV Dashboard] Premium Plug-ins won't install, basic plug-ins install fine

Hello,

We pushed a site live yesterday but have been having problems with some of the WPMU DEV plug-ins. When I try to install on the WPMU DEV dashboard I got a 504 error. When I try to install them from the HUB it just loads forever.
Smartcrawl is having trouble getting a report of the site too. I'm not sure if that would be connected.
Other info:
PHP Memoryt limit = 256mb,
PHP Time Limit = 300
PHP Version = 7.1.19
Server = Apache (Shared)
Theme = Avada 5.6
Unfortunately, I can't allow external log-ins so we would have to troubleshoot together.

  • Patrick Freitas

    Hi Dave

    Sorry to heat that you are having this problem.

    Wouldn't you mind please access the WordPress root folder by a FTP access, find for the wp-config.php file and enable the debug pasting above the line /* That's all, stop editing! Happy blogging. */ the code :

    // Turn debugging on
    define('WP_DEBUG', true);
    
    // Tell WordPress to log everything to /wp-content/debug.log
    define('WP_DEBUG_LOG', true);
    
    // Turn off the display of error messages on your site
    define('WP_DEBUG_DISPLAY', false);
    
    // For good measure, you can also add the follow code, which will hide errors from being displayed on-screen
    @ini_set('display_errors', 0);

    You can follow the full article on:
    https://premium.wpmudev.org/blog/debugging-wordpress-how-to-use-wp_debug/

    After that, try to activate any plugin, back to the FTP go to wp-content folder and search for any debug.log change the debug.log to debug.txt and attach on the reply.

    Let me know the results,
    Best Regards
    Patrick Freitas

  • Dave

    Hello Patrick and thank you for your quick reply,

    I have added those lines into the wp-config and checked the System Info on the WPMU DEV dashboard to make sure that the changes took affect and they did.

    I tried to installed the Google Analytics + plugin but the same error appeared.
    "Server error status: Gateway Time-out [504]"

    I checked for a debug.log file in the wp-content folder but there doesn't appear to be any file.

  • Patrick Freitas

    Hi Dave

    Wouldn't you mind please follow these stepes:

    1. Go to "WPMU DEV -> Dashboard" page
    2. Logout of your account
    3. clear cache on site, if there's any caching plugin enabled, on server (if there's any cache there) and in your browser
    4. Login WPMU DEV Dashboard plugin to your WPMU DEV account again
    5. Try installing the plugin again.

    Let me know the results,
    Best Regards,
    Patrick Freitas

  • Patrick Freitas

    Hi Dave

    Sorry to hear that :disappointed:

    Would't you mind please enable this on the wp-config.php

    define( 'WPMUDEV_API_DEBUG', true);

    Also you can try to increase the max_execution_time to 600 in the php.ini file

    max_execution_time = 600

    and on the wp-config.php

    define('WP_MEMORY_LIMIT', '512M');

    to see if the problem is gone, if it persists you can grant the Support Access by:

    1. Log in to the WordPress Admin Panel for your site (go to the Network Admin dashboard if on Multisite), and then navigate to the “Support” page from the WPMU DEV menu item (WPMU DEV > Support).

    2. Click the “Grant Support Access” button in the Support Access panel.

    You can follow the full article here: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Let me know the results.
    Best Regards,
    Patrick Freitas

  • Dave

    Hello Patrick!

    Thank again for your reply.

    I have enabled the WPMU dev debug api and increased the memory limit to 512m.
    This allowed Hummingbird pro to install! Progress! However I got an error code 500 when trying to activate it.

    I would like to grant support access but as a junior developer, I'm eager to learn how the professionals troubleshoot, especially since I've been trying hard to get this working and would like to know what I have done/am doing wrong.

    Also, the debug.log has appeared (at 4.30am). I'll attach to this reply.

    -Dave

  • Dave

    The first two attempts it was still a .log file but the third attempt was defo a .txt. I'll paste the content here.

    ****** Start of Debug contents *****
    [11-Jul-2018 11:49:07 UTC] [WPMUDEV API Error] 4.5.2 | cURL error 28: Operation timed out after 10001 milliseconds with 0 out of 0 bytes received ((unknown URL) [500])
    [11-Jul-2018 11:49:09 UTC] PHP Notice: Undefined index: rep_level in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-content/plugins/wpmudev-updates/template/dashboard.php on line 23
    [11-Jul-2018 12:21:48 UTC] PHP Notice: Trying to get property of non-object in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-includes/class-wp-query.php on line 3871
    [11-Jul-2018 12:21:48 UTC] PHP Notice: Trying to get property of non-object in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-includes/class-wp-query.php on line 3871
    [11-Jul-2018 12:21:48 UTC] PHP Notice: Trying to get property of non-object in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-includes/class-wp-query.php on line 3871
    [11-Jul-2018 12:21:48 UTC] PHP Notice: Trying to get property of non-object in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-includes/class-wp-query.php on line 3871
    [11-Jul-2018 12:21:48 UTC] PHP Notice: Trying to get property of non-object in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-includes/class-wp-query.php on line 3871
    [11-Jul-2018 12:21:48 UTC] PHP Notice: Trying to get property of non-object in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-includes/class-wp-query.php on line 3871
    [11-Jul-2018 12:21:48 UTC] PHP Notice: Trying to get property of non-object in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-includes/class-wp-query.php on line 3871
    [11-Jul-2018 12:21:48 UTC] PHP Notice: Trying to get property of non-object in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-includes/class-wp-query.php on line 3871
    [11-Jul-2018 12:21:48 UTC] PHP Notice: Trying to get property of non-object in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-includes/class-wp-query.php on line 3871
    [11-Jul-2018 12:21:48 UTC] PHP Notice: Trying to get property of non-object in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-includes/class-wp-query.php on line 3871
    [11-Jul-2018 12:21:48 UTC] PHP Notice: Trying to get property of non-object in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-includes/class-wp-query.php on line 3871
    [11-Jul-2018 12:21:48 UTC] PHP Notice: Trying to get property of non-object in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-includes/class-wp-query.php on line 3871
    [11-Jul-2018 12:21:48 UTC] PHP Notice: Trying to get property of non-object in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-includes/class-wp-query.php on line 3871
    [11-Jul-2018 12:21:50 UTC] PHP Notice: Trying to get property of non-object in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-includes/class-wp-query.php on line 3871
    [11-Jul-2018 12:21:50 UTC] PHP Notice: Trying to get property of non-object in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-includes/class-wp-query.php on line 3871
    [11-Jul-2018 12:21:50 UTC] PHP Notice: Trying to get property of non-object in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-includes/class-wp-query.php on line 3871
    [11-Jul-2018 12:21:50 UTC] PHP Notice: Trying to get property of non-object in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-includes/class-wp-query.php on line 3871
    [11-Jul-2018 12:21:50 UTC] PHP Notice: Trying to get property of non-object in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-includes/class-wp-query.php on line 3871
    [11-Jul-2018 12:21:50 UTC] PHP Notice: Trying to get property of non-object in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-includes/class-wp-query.php on line 3871
    [11-Jul-2018 12:21:50 UTC] PHP Notice: Trying to get property of non-object in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-includes/class-wp-query.php on line 3871
    [11-Jul-2018 12:21:50 UTC] PHP Notice: Trying to get property of non-object in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-includes/class-wp-query.php on line 3871
    [11-Jul-2018 12:21:50 UTC] PHP Notice: Trying to get property of non-object in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-includes/class-wp-query.php on line 3871
    [11-Jul-2018 12:21:50 UTC] PHP Notice: Trying to get property of non-object in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-includes/class-wp-query.php on line 3871
    [11-Jul-2018 12:21:50 UTC] PHP Notice: Trying to get property of non-object in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-includes/class-wp-query.php on line 3871
    [11-Jul-2018 12:21:50 UTC] PHP Notice: Trying to get property of non-object in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-includes/class-wp-query.php on line 3871
    [11-Jul-2018 12:21:50 UTC] PHP Notice: Trying to get property of non-object in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-includes/class-wp-query.php on line 3871
    [11-Jul-2018 12:41:30 UTC] PHP Notice: Undefined index: rep_level in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-content/plugins/wpmudev-updates/template/dashboard.php on line 23
    [11-Jul-2018 12:41:35 UTC] PHP Notice: Undefined index: rep_level in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-content/plugins/wpmudev-updates/template/dashboard.php on line 23
    [11-Jul-2018 13:04:58 UTC] PHP Warning: A non-numeric value encountered in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-content/themes/Avada/404.php on line 41
    [11-Jul-2018 13:04:58 UTC] PHP Warning: A non-numeric value encountered in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-content/themes/Avada/404.php on line 42
    [11-Jul-2018 13:04:58 UTC] PHP Warning: A non-numeric value encountered in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-content/themes/Avada/404.php on line 43
    [11-Jul-2018 13:31:12 UTC] PHP Warning: A non-numeric value encountered in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-content/themes/Avada/404.php on line 41
    [11-Jul-2018 13:31:12 UTC] PHP Warning: A non-numeric value encountered in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-content/themes/Avada/404.php on line 42
    [11-Jul-2018 13:31:12 UTC] PHP Warning: A non-numeric value encountered in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-content/themes/Avada/404.php on line 43
    [11-Jul-2018 13:35:54 UTC] PHP Notice: Undefined index: google_login in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-content/plugins/google-analytics-async/google-analytics-async-files/class-google-analytics-async-dashboard.php on line 74
    [11-Jul-2018 13:35:57 UTC] PHP Notice: Undefined index: google_login in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-content/plugins/google-analytics-async/google-analytics-async-files/class-google-analytics-async-dashboard.php on line 74
    [11-Jul-2018 13:36:47 UTC] PHP Notice: Undefined index: google_login in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-content/plugins/google-analytics-async/google-analytics-async-files/class-google-analytics-async-dashboard.php on line 74
    [11-Jul-2018 13:36:49 UTC] PHP Notice: Undefined index: google_login in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-content/plugins/google-analytics-async/google-analytics-async-files/class-google-analytics-async-dashboard.php on line 74
    [11-Jul-2018 13:37:02 UTC] PHP Notice: Undefined index: google_login in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-content/plugins/google-analytics-async/google-analytics-async-files/class-google-analytics-async-dashboard.php on line 74
    [11-Jul-2018 13:37:19 UTC] PHP Notice: Undefined index: google_login in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-content/plugins/google-analytics-async/google-analytics-async-files/class-google-analytics-async-dashboard.php on line 74
    [11-Jul-2018 13:37:27 UTC] PHP Notice: Undefined index: google_login in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-content/plugins/google-analytics-async/google-analytics-async-files/class-google-analytics-async-dashboard.php on line 74
    [11-Jul-2018 13:37:29 UTC] PHP Notice: Undefined index: track_settings in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-content/plugins/google-analytics-async/google-analytics-async-files/page-settings.php on line 307
    [11-Jul-2018 13:38:00 UTC] PHP Notice: Undefined index: google_login in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-content/plugins/google-analytics-async/google-analytics-async-files/class-google-analytics-async-dashboard.php on line 74
    [11-Jul-2018 13:38:08 UTC] PHP Notice: Undefined index: track_settings in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-content/plugins/google-analytics-async/google-analytics-async-files/page-settings.php on line 307
    [11-Jul-2018 13:39:07 UTC] PHP Notice: Undefined index: anonymize_ip_force in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-content/plugins/google-analytics-async/google-analytics-async-files/page-settings.php on line 307
    [11-Jul-2018 14:48:54 UTC] PHP Warning: A non-numeric value encountered in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-content/themes/Avada/404.php on line 41
    [11-Jul-2018 14:48:54 UTC] PHP Warning: A non-numeric value encountered in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-content/themes/Avada/404.php on line 42
    [11-Jul-2018 14:48:54 UTC] PHP Warning: A non-numeric value encountered in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-content/themes/Avada/404.php on line 43
    [11-Jul-2018 14:49:58 UTC] PHP Notice: Undefined index: HTTP_USER_AGENT in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-content/plugins/hummingbird-performance/core/modules/class-module-page-cache.php on line 554
    [11-Jul-2018 14:49:59 UTC] PHP Notice: Undefined index: HTTP_USER_AGENT in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-content/plugins/hummingbird-performance/core/modules/class-module-page-cache.php on line 554
    [11-Jul-2018 16:25:04 UTC] PHP Warning: A non-numeric value encountered in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-content/themes/Avada/404.php on line 41
    [11-Jul-2018 16:25:04 UTC] PHP Warning: A non-numeric value encountered in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-content/themes/Avada/404.php on line 42
    [11-Jul-2018 16:25:04 UTC] PHP Warning: A non-numeric value encountered in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-content/themes/Avada/404.php on line 43
    [11-Jul-2018 19:37:50 UTC] PHP Notice: Undefined index: HTTP_USER_AGENT in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-content/plugins/hummingbird-performance/core/modules/class-module-page-cache.php on line 554
    [11-Jul-2018 19:37:51 UTC] PHP Notice: Undefined index: HTTP_USER_AGENT in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-content/plugins/hummingbird-performance/core/modules/class-module-page-cache.php on line 554
    [11-Jul-2018 19:37:52 UTC] PHP Notice: Undefined index: HTTP_USER_AGENT in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-content/plugins/hummingbird-performance/core/modules/class-module-page-cache.php on line 554
    [11-Jul-2018 19:37:53 UTC] PHP Notice: Undefined index: HTTP_USER_AGENT in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-content/plugins/hummingbird-performance/core/modules/class-module-page-cache.php on line 554
    [11-Jul-2018 19:37:54 UTC] PHP Notice: Undefined index: HTTP_USER_AGENT in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-content/plugins/hummingbird-performance/core/modules/class-module-page-cache.php on line 554
    [11-Jul-2018 19:37:56 UTC] PHP Notice: Undefined index: HTTP_USER_AGENT in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-content/plugins/hummingbird-performance/core/modules/class-module-page-cache.php on line 554
    [11-Jul-2018 19:37:56 UTC] PHP Notice: Undefined index: HTTP_USER_AGENT in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-content/plugins/revslider/revslider.php on line 207
    [11-Jul-2018 19:37:56 UTC] PHP Notice: Undefined index: HTTP_USER_AGENT in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-content/plugins/revslider/revslider.php on line 207
    [11-Jul-2018 19:37:56 UTC] PHP Notice: Undefined index: HTTP_USER_AGENT in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-content/plugins/revslider/revslider.php on line 207
    [11-Jul-2018 19:37:56 UTC] PHP Notice: Undefined index: HTTP_USER_AGENT in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-content/plugins/revslider/revslider.php on line 207
    [11-Jul-2018 19:37:56 UTC] PHP Notice: Undefined index: HTTP_USER_AGENT in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-content/plugins/revslider/revslider.php on line 207
    [11-Jul-2018 19:37:56 UTC] PHP Notice: Undefined index: HTTP_USER_AGENT in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-content/plugins/revslider/revslider.php on line 207
    [12-Jul-2018 03:35:56 UTC] PHP Warning: A non-numeric value encountered in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-content/themes/Avada/404.php on line 41
    [12-Jul-2018 03:35:56 UTC] PHP Warning: A non-numeric value encountered in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-content/themes/Avada/404.php on line 42
    [12-Jul-2018 03:35:56 UTC] PHP Warning: A non-numeric value encountered in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-content/themes/Avada/404.php on line 43
    [12-Jul-2018 07:50:07 UTC] [WPMUDEV API call] 4.5.2 | POST: https://premium.wpmudev.org/api/dashboard/v2/hub-sync (200)
    [12-Jul-2018 07:50:08 UTC] [WPMUDEV API call] 4.5.2 | GET: https://premium.wpmudev.org/api/dashboard/v2/user-info/6615a209b8ac8c8e88ac452d0985c53a53b4aeaf (200)
    [12-Jul-2018 07:50:24 UTC] [WPMUDEV API call] 4.5.2 | GET: https://premium.wpmudev.org/api/dashboard/v2/changelog/1081721 (200)
    [12-Jul-2018 07:50:24 UTC] [WPMUDEV API call] 4.5.2 | POST: https://premium.wpmudev.org/api/dashboard/v2/hub-sync (200)
    [12-Jul-2018 07:50:29 UTC] PHP Fatal error: Cannot declare class WP_Hummingbird_Utils, because the name is already in use in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-content/plugins/hummingbird-performance/core/class-utils.php on line 16
    ****** End of Debug contents *****

  • Patrick Freitas

    Hi Dave

    Thanks for the log.

    [12-Jul-2018 07:50:29 UTC] PHP Fatal error: Cannot declare class WP_Hummingbird_Utils, because the name is already in use in /var/www/vhosts/186/1040983/webspace/httpdocs/aidanmurphyinsurances.ie/wp-content/plugins/hummingbird-performance/core/class-utils.php on line 16

    Here is the issue, the Hummingbird is trying declare a class already declared, this usually happen when another plugin uses the same class name, but in this case the problem is that Hummingbird is messing up the classes.

    I would suggest remove the plugin, clean all site caches and install it again, see if the problem is gone.

    Best Regards,
    Patrick Freitas

  • Patrick Freitas

    Hi Dave

    Another troubleshoot is running a plugin test.

    So, wouldn't you mind please run a plugin test.

    Using the FTP access the WordPress folder, navigate to wp-content and rename the plugins folder to plugins.bak, create a new plugins folder and move only the WPMUDEV Dasboard plugin to the new folder.

    Access the WordPress dashboard and try to install the plugins back.

    Check if you can install all WPMUDEV Plugins without problem.

    If you are able to install all plugins, go to wp-content/plugins.bak and move one by on to the new plugins folder checking if any issue happen until you find the problematic plugin.

    Best Regards,
    Patrick Freitas

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.