[WPMU DEV Dashboard] Uptime Keeps Reporting Website Down After SSL Expiration

MY SSL expired yesterday and afterwards I moved over to Cloudflare however I have gotten multiple website down website back up notifications since. I had the hosting provider remove the old SSL when i switched to CF. But I’m still getting the alerts as of this morning. So as of now my site is up but after prompting WPMU DEV dash to recheck it still reports my site as down.

  • Adam Czajczyk
    • Support Gorilla

    Hello New Guy

    I hope you’re well today and thank you for your question!

    Since your certificate expired and your hosting provider removed it, did you also had WordPress re-configured?

    I’m asking specifically about the “Site URL”/”WordPress URL” options on “Settings -> General” page in site’s back-end and any possible redirects set (e.g. in .htaccess or some other way) from http:// to https://?

    If that’s been changed but then again SSL protection was added via CloudFlare, these options might need to be updated back to start with “https://” and after that I’d recommend:

    – switching Uptime off in Hummingbird settings on the site

    – clearing all possible caches on site and server (if there are any) and in CloudFlare

    – enabling Uptime back in Hummingbird options on the site

    That should update the URL in The Hub and Uptime configuration. For now, it seems like the site’s reported as down every once in a while for about 10 minutes and that looks to me like the check was temporarily locked by CloudFlare every now and then – constant attempts to hit wrong URL could be causing it.

    If that doesn’t help, let me know please and I’ll also include our developers in the case so they’d check it on our end.

    Best regards,

    Adam

  • New Guy
    • Design Lord, Child of Thor

    Thanks for the response Adam. Even after updating the settings>general domain to https: and clearing cache in Hummingbird, contact my Hosting support to clear server cache, and clearing cache on Cloudflare I’m still having the same issue with Uptime. I deactivate prior to clearing all the cache and reactivate afterwards and still getting down/up notifications.

  • Adam Czajczyk
    • Support Gorilla

    Hi New Guy

    Thank you for getting back to me!

    I checked the site and it seems it did fix that after all. I looked into your Hub for Uptime stats for that site and there are no new downtime reports since you took the action.

    For each of those reported events the reason reported (you can see it if you hover over the downtime time on the downtime events list in the hub) was the expired certificate. But it’s now about 24 hours without new downtimes while before that it was pretty much every ten or so minutes.

    As for the stats – those stats will be there as they are not stored “in plugin” but in The Hub. If any “incident” was recorded it’s going to be displayed and included in stats. The “last 30 days” is the longest period you can check there so assuming there’ll be no downtime event at all within 30 days those already listed there will “go away” and “availability” will grow up up to 100% meanwhile.

    Best regards,

    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.